TP-Link AX23 EU v1.2 Failed OpenWrt upgrade? Please Help

So I have a TP-Link AX1800 (AX23) EU v1.2 and I followed a guide on flashing to use OpenWrt. I did many checks before doing this and was sure this would be fine without bricking the router.

I followed instructions carefully and proceeded to update the firmware via

The update took a while and when it reached 100% the page refreshed and I was presented with telling me " To access, your device must be connected to TP-Link Router’s network. Please check your network connection and try again." from what I understand I was suppose to be presented to the OpenWrt CP to setup my password and name the network...

The green lights on the router are working, I have no Orange/ Red lights or anything. My internet still works as does my WIFI... However it has left me with a open WIFI network (named OpenWrt) and I can not access the OpenWrt control panel to setup my router settings.

At this point I thought I had bricked the device. I have even tried to find Rescue recovery procedure however no method works. I cant even get TFTP to show logs when attempting to recover using any TFTP software. I disabled my firewall/ made inbound & outbound rules to allow TFTP software to work.

Please help. I just dont understand what has gone wrong. almost 12 hours of trying to resolve this by myself and I feel like pulling my hair out.

I also tried following the recover procedure's in this link and I can not get the TP Link recovery page to appear in any browser.

OH Refuses connection. I did notice this out of all the IP addresses to try and get onto the OpenWrt CP.

What IPs are you clients getting ?

Wifi shouldn't work, it's off by default, in OpenWRT.
Which image did you use ?

Tried the web recovery from;a=commit;h=7dceef5ee554ec4ab5d2dd2ff999f4a60bf2e0f4, but I guess it's the same as in the TP-Link link you posted.

I used the image that is suppose to be used for first time installation. The other image from what I understand was to upgrade already existing OpenWrt OS on routers.

openwrt-ramips-mt7621-tplink_archer-ax23-v1-squashfs-factory.bin is the name of the file that I used to upgrade. I got it after checking the Hardware compatibility checker on the OpenWrt website.

And yes the instructions in the link you provided are exactly the same as what I have already tried. and I do not yield the same response from the router.

Also the current IPV4 IP is

I have tried changing this however as per instructions that I have read.

I am not familiar with "Web-UI" as it says in the link you provided. Is this something I need to do? I am a little lost at this point, I am don't have savvy network experience.

The only thing I can think of is that I have tried to upgrade the wrong bin but for some reason my internet still works.

since this is a snapshot image, there's no webui, does ssh work ?

ssh? Im sorry I have no idea what that is. I feel like I should never have done this now.. lol.

UPDATE I Just followed a youtube video of someone who had the same issue and it is FINALLY showing OpenWrt!! Please can you confirm this is it?

there you go, problem solved.

note, every time you flash a new snapshot image, there will be no webUI per default, but the 23.02 RCs are soon out, those will have the webuUI preinstalled.

the RCs can even be seen at

Thank you! Now I just need to find a guide on how to setup QOS. Or are basic features like that already on by default?

opkg update
opkg install luci-app-qos

That should install what's needed. Reboot and the QoS menu will appear on the web GUI under Network.

Doing as you said as we speak! Is there a guide anywhere on how I can setup WIFI networks 1 for 2.4ghz and 5ghz?

I plan to do alot of local streaming very soon and this is all part of my plan to make sure my network is as optimal as it can be.

Radios should be there, just need to enable them and set the passwords.

1 Like

I assume Radio 0 is 2.4ghz and Radio 1 is 5ghz?

You'll figure it out when you see the frequencies offered.

1 Like

ok thank you!

The ax/b/g/n is the 802.11n radio.

1 Like

i think the current stable release includes the spi frequency fix, so installing the stable release should work and also includes luci

Going to reboot now and check. Is it ok if I ask some more questions about setting up the WIFI? Im a little concerned I will mess something up. This is all very new to me.

Sure, but you may wish to make a thread specific to setting up WiFi.

If you mess something up, you can always reset, and incorrect wifi setting shouldn't kill the device, just the wifi :slight_smile:

1 Like

So far I seem to have done the job. 2 WIFI Networks one for each band. I am all setup!

I have installed what @lleachii said also.

I will create a separate topic on configuring QOS so I dont mess this topic up.

Thank you all for getting me up and started!!

I am about to buy a AX23 but noticed that there's a V1.2 while openwrt states support with v1.0. Looks like you have got success does it mean the openwrt firmware is compatible with the v1.2 hardware as well? Thanks.