TP-Link Archer D50 v1 - can't install OpenWrt

Hi I'm new to the forum and maybe even a little inexperienced. I tried to update the firmware of my TPLINK ARCHER D50 , but from the console I get - Error code:4503
The uploaded file was not accepted. I also tried via TFTP , but without success , I do not see the packets pass and even sniffing via wireshark I can not do the transfer - Can you help me ?

TFTP often fails because there's a firewall running on the TFTP host.

I have disable the firewall, but the server don't Connects with router.
I have configured the ethernet, like see in you tube video (IP address 192.168.0.66 :thinking::thinking::thinking::thinking:)


, but i think it'not appropriate for my TP link router.
I remember you my model ( TP li k archer d50 v1) and attach photo

hi
thank

This is the massage when I download the file (openwrt-21.02.2-ath79-generic-tplink_archer-d50-v1-squashfs-sysupgrade.bin) that propose this page ( https://openwrt.org/toh/hwdata/tp-link/tp-link_archer_d50_v1 )
Sorry but I don't understand if this forum is active or not !!!

What kind of question is this?

It might very well be TP-Link bumped the minimum image version. Try downgrading to an older TP-Link firmware image before flashing OpenWrt.

The code block here might need modifying:

https://github.com/openwrt/openwrt/blob/c45b5abf6fce79ff3aab6d98cde3e8ff0ae1b1d6/target/linux/ath79/image/generic-tp-link.mk#L212

did you actually read the instruction(s) on how to install the openwrt firmware ?

1 Like

@EnricoFiorini You linked to the hardware data page; it contains a link to the git commit that has detailed instructions on the installation procedure.

1 Like

Ok I read the installation procedure ,but the article mentions "The following instructions require a connection to the J2 UART header"; if i don't know what it is and how can i get it not how to use it, am i screwed ??
There isn't anotrethre possibility??

Thanks

Ok ho capito la connessione UART è una connessione seriale , ma il connettore seriale , dove lo trovo ???? che non è disponibile?
Grazie

it's inside the device, and you need a special USB cable (less than $10) to connect to the router.
and in worst case, do some soldering 1st.

All'interno - bisogna aprire il router. You gotta open the router. You can use Italian as long as you provide a translation, not everyone talks Italian (or can throw it in some online translator with varying success).

Take photos of the board and share them here, because the Broadcom DSL chip seems to have a header too. That's not the one you should connect to.

sorry to use Italian language!!
This is the Board

the serial's probably the four vertical holes to the right, or the ones far up left.

you'll need to connect three out of those - GND, RX & TX.

hi, this converter it's ok?
XTVTX 3 PZ Modulo USB a TTL 5PIN Convertitore Seriale Modulo Downloader per UART STC 3.3 V e 5 V con fili Jumper https://www.amazon.it/dp/B093GWC41Q/ref=cm_sw_r_apan_glt_i_29JC6XT1FHANBRQR51Z2?_encoding=UTF8&psc=1

or this?

HiLetgo CP2102 USB 2.0 to TTL UART Serial Converter Module 5Pin STC PRGMR with Dupont Wire https://www.amazon.it/dp/B00LODGRV8/ref=cm_sw_r_apan_glt_i_XQ0CT840XVZZYVWV3E7W?_encoding=UTF8&psc=1

and I must use J2 or J16?

the 2nd one isn't available, but the 1st should work.
if you want to spend more money there are version capable for running at 1.8v and/or 2.5v too.

the install instruction clearly says, and this is C&Ped from your own post -
The following instructions require a connection to the J2 UART header

the pinout's in the git.


I connected the router as per specification, after identifying the Vcc Pin, but I can't establish the connection.
When the connection is opened, through "Putty", the mass Pin turns red, but in Shell it is not possible to write and nothing appears, can you help me?

I have connected only Gnd - rx & tx