TP-Link Archer C7 v4, WPA key not saved

I wanted to get familiar with OpenWRT again so I loaded 19.07.7 on a spare TP-Link that I had and configured the default WiFi network for WPA2, assigned it to LAN and created a key. When I clicked Save and Apply the network remains disabled. If I change it to no authentication it becomes enabled. When I change it back to WPA2 it becomes disabled again. I SSHd to the router and noticed that the /etc/config/wireless file did not contain the option key '' line so I manually added it and then was able to enable it.

If I attempt to change the key from the GUI, it can display the existing value, but it doesn't change the value in the configuration file if I save it.

I did a search but didn't find any known issue with this hardware or the GUI not saving the key values, so I thought I'd post here in case someone else recognized the symptoms and might offer additional insight.

Sounds like bad blocks. Try factory reset and retest. If that doesn't work try reflashing the firmware. Doing so may help map them out. Make sure there are no " or ' in the WPA2 key.

Thanks @16F84. I've reset and reloaded the firmware. The WPA key is pretty simple.

I think this symptom is too specific to be bad blocks. I can save other changes to the /etc/config/wireless file via the GUI, but the key value will not update, and adding it manually via SSH works fine.

I'll poke around and see if there is some logging I can find that might show an error happens when attempting to save the settings with a key value.

Using the browser debug tools for Firefox, I don't see any errors being returned when I save the configuration, yet the key value is not saved.

I switched to Chrome and was then able to make changes to the key value, so whatever that bug is, it seemed specific to Firefox and openWRT.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

@tmomas, I can flag this as Solved, but I guess that depends on how the term is used here. I have a work-around, but I don't know the root cause. I'd view this as either a Firefox or an openWRT bug, but I don't know which.

1 Like

Yeah I had alot of "fun" with firefox too. Alot. It got to the point where I had to have the "clear cache" page tabbed alongside the NIC on/off switch. That works.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.