TP-Link Archer C7 v4 5GHZ performance

My Environment

Here is my router info

TP-Link Archer C7 v4

Qualcomm Atheros QCA956X ver 1 rev 0

The 5G setup is 80MHZ Channel 153

Firmware Version
OpenWrt 19.07.3 r11063-85e04e9f46 / LuCI openwrt-19.07 branch git-20.150.62258-217d331

Kernel Version

My desktop is running Kubuntu Focal Fossa

My desktop wireless card

I recently upgraded my wireless service from 100 to 200 Mbs .

My speed went up but not as much as I had hoped . Speed tests to multiple online test sites show I get a max of 140 Mbs .
If I plug the desktop into a gig port on the router I get 200 Mbs with no problem .

I also have a laptop (also running Kubuntu Focal Fossa) and an IPhone each of which sees about the same wireless performance as the desktop .

All of these tests are run within 2 feet of the router .

Should I expect better performance ?

I ran 'top' on the router while doing a speed test and 'ksoftirqd' seemed to be maxing out the cpu so perhaps this is just a limitation of this device ? It is an inexpensive router I must admit .

Other than this everything works flawlessly .

80MHz is using 4 channels and channel 152 means that one 20MHz channel will spill into ISM band. Try to configure channel 149 to begin with.

Also, run iperf3 test from laptop to LAN first and see what performance you get. My Archer C7 tops out at around 450Mbit iperf3 using 80MHz. But routing might cost you some CPU as well.

If nothing else helps, try overclocking the device or use custom build with HW offloading.


1 Like

Changing channels didnt seem to buy me anything . I ran iperf3 in both directions and the results seem odd but maybe not .
First on the router I did

iperf3 -s -B
then on the host I did
iperf3 -c
and got

[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.00  sec   376 MBytes   315 Mbits/sec    0             sender
[  5]   0.00-10.01  sec   372 MBytes   312 Mbits/sec                  receiver

then I reversed the test and got

[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-10.09  sec  94.9 MBytes  78.9 Mbits/sec   19             sender
[  5]   0.00-10.11  sec  94.9 MBytes  78.8 Mbits/sec                  receiver

So as my next test I did iperf3 between my desktop and my laptop with the best result being from he laptop to the desktop with slightly less than 160 Mbs . So do I have some routing issue on the Archer ?

That was a wired desktop and wireless laptop?

There's no routing when you go from the LAN ports to a wifi AP on the same network bridge. Is the CPU still maxed on SIRQ? The SIRQs are mostly serving the wifi driver.

Running iperf on the router itself uses a lot of CPU so that is not a realistic test. Go between two fast external devices as you did in the last test.

As previous poster mentioned, running iperf3 between wired destop (as long as it is connected to one of four LAN ports) and WiFi laptop involves no routing, so it cannot be that.

When I run iperf3 server on my iPhone (WiFiPerf Endpoint app) and client on my wired desktop I get ~400Mbit/sec with 80MHz channels on non-overclocked router (up to 500Mbit/sec when overclocked). But it is when running four streams at once. If I run only one stream I got less.

Try re-running your benchmark using these settings:
iperf3 -c -t 20 -P 4
(And run iperf3 client/server only on your laptop/desktop, not inside router.)

Also, check whether your laptop connects using 802.11ac,
Disable "Allow legacy 802.11b rates" and make sure "WMM mode" is enabled in 5GHz settings in router.

Your connection should state "866.7 Mbit/s, 80MHz, VHT-MCS 9, VHT-NSS 2, Short GI" in router when having laptop in close proximity of router and running iperf3.

both desktop and laptop are wireless . The laptop connection looks like this

6.0 Mbit/s, 20 MHz
433.3 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 1, Short GI

So maybe that explains the numbers I see below when iperfing between it and the desktop .
But the desktop connection looks like this

866.7 Mbit/s, 80 MHz, VHT-MCS 9, VHT-NSS 2, Short GI

So I'm back to my original question of desktop 5G wifi performance when going out to all the internet speed tests

[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-20.00  sec  96.9 MBytes  40.7 Mbits/sec    0             sender
[  5]   0.00-20.07  sec  94.7 MBytes  39.6 Mbits/sec                  receiver
[  7]   0.00-20.00  sec  71.0 MBytes  29.8 Mbits/sec    0             sender
[  7]   0.00-20.07  sec  68.6 MBytes  28.7 Mbits/sec                  receiver
[  9]   0.00-20.00  sec  83.8 MBytes  35.2 Mbits/sec    0             sender
[  9]   0.00-20.07  sec  81.2 MBytes  33.9 Mbits/sec                  receiver
[ 11]   0.00-20.00  sec  87.5 MBytes  36.7 Mbits/sec    1             sender
[ 11]   0.00-20.07  sec  85.3 MBytes  35.7 Mbits/sec                  receiver
[SUM]   0.00-20.00  sec   339 MBytes   142 Mbits/sec    1             sender
[SUM]   0.00-20.07  sec   330 MBytes   138 Mbits/sec                  receiver

But then on the desktop I do this

nmcli d wifi list


  •       50:C7:BF:DE:51:7B  ollie5    Infra         48      405 Mbit/s  100     ▂▄▆█  WPA2

so now I'm not sure what to expect

You are doing it wrong.
First of all, running iperf3 between two devices that are both on same WiFi will (theoretically) cut speed in half. In practice, you get one third of speed.

Second, your laptop WiFi card seems to be 1:1 device which supports max 433Mbit PHY, which means that you will not be able to hit more than 200Mbit/sec real speed no matter what you do,

Retest with one device connected via ehternet and other on WiFi. Only then will you know if WiFi is limiting factor.

Ha . That should have been obvious , wifi to wifi .
So I hooked the desktop to a gig port and ran the perf from the laptop to the desktop and it easily hit a lttle more than 200 Mbs .
So It doesnt seem that the router is the limiting factor . For some reason the desktop wifi connection is not as good as some of the numbers say .

Thanks for all the info .

So I missed the setting under 'Firewall' for software/hardware offloading which show up on the standard release . After turning them on my desktop now hits 200 MbS .

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.