TP-Link Archer C7 inaccessible after installation/configurating LEDE

Today I wanted to install LEDE on my Archer C7. As documented on this website I executed following and as a result I cannot connect to my Archer C7 anymore. What to do now because I cannot determine how to connect to it. i configured my Archer C7 as but I cannot connect to it with my SSH-Client.

First steps

Flash the LEDE firmware image. Use the Standard Flashing Instructions to install LEDE on your device, then come back to finish these steps.
Connect to the newly-flashed device via Ethernet using DHCP It is important to use an Ethernet connection, even if you flashed using Wi-Fi.
On routers: Connect your computer to a Local Area Network (LAN) port of the router using DHCP.
On access points: Connect your computer to a Local Area Network (LAN) port of the router using DHCP.
On other devices: The newly-flashed device will acquire an address using DHCP. Check your existing router’s web-interface to learn which address it got.
SSH to the new LEDE device. In your terminal program, enter ssh root@ You can follow along with these steps below in the transcript (below).
Set the password. LEDE ships without a password. Enter passwd and type the new password twice. Note: Use a good password: it the protection for your home network. Write username and password on a sticker on the bottom of the device so you don't forget.
Connect to an existing network (with Internet access)
Like an Access Point If you want to connect your device to an existing network without using routing functions (for example, you just want to use its wifi but the main router of your network is another device), you must configure it for your network, then you will use one of its LAN ports to connect it to your network.
type uci set network.lan.ipaddr='new-ip-address' and press Return (“new-ip-address” is the new IP address you want for the LEDE device in your network)
type uci set network.lan.gateway='your-gateway-address' and press Return (“your-gateway-address” is the IP address of the gateway you have in your network. The gateway is the device that is connected to the internet and usually has the login and password of your Internet contract. If you have another router you use to connect to the Internet, it's probably the gateway so put its address here.)
type uci set network.lan.dns='' and press Return (the is Google's DNS servers, you can use the address of another DNS server if you prefer)
type uci commit && service network restart (this will save the changes and restart network interfaces)
now you can connect the network cable from the device's LAN port to your existing network (the other router's LAN ports usually)
connect again to the device at its new address as defined above

tl;dr, If you truly cannot fathom out where things went South on you it is a painless TFTP recovery on the C7V2.

Hi. I wrote the procedure on the Quick Start Guide. I'm not sure where you ran into a problem. (The text above seems to be a paste of the instructions.)

Can you tell me what steps you took when you were installing/configuring? How far did you get? Can you say what's working (and not working) now? Thanks.

I executed the steps as mentioned in this topic. After that I can not connect to my TP-Link Archer C7 anymore. My laptop does not get an IP-Address from my C7 and I cannot connect to the C7 using as I had configured during the steps as mentioned in this topic. So at this moment I cannot connect to my C7 because I don't know on what IP-Address I have to connect.

Is your machine set for DHCP, did you static assign an IP address for your machine?
Not sure what OS you are using but what IP shows under CMD - IPCONFIG (win) IFCONFIG(linux/unix).

At worst I would do a reset (push button). I would assume that would erase back to default settings the LEDE firmware and you can try again the setup.

I just recently setup my C7 with Toke C7 version about a week ago, it was simple.
IF the setup of does not work try the default for LEDE which is

What addresses did you enter for 'new-ip-address' and 'your-gateway-address' in the steps above?

(I assume you are connecting to the router using an Ethernet cable - LEDE ships with wi-fi disabled, so you won't be able to use it right off the bat.)

I have my Archer C7 replaced by a new one and installed LEDE and LUCI and everything is working now. I am now looking for Parental Control software so I can configure time limits for my childeren devices using wifi and webfiltering. So far I haven't found software to arrange this.

I have a related issue to this. After I've set up my Archer C7 as a dumb AP, it works and all clients connected to it get an IP address from the main router on my network. I am also able to SSH/WinSCP into this router.

However, I cannot opkg update or opkg install luci on this C7. Why is it not getting an internet connection? Does that require a DHCP address? I've presently set it to a static IP outside the range of the main DHCP as instructed here. It is connected to the main router on a LAN port, not the WAN port.

@rajsris Look at this thread for the answer. You could activate DHCP Client* on your AP on LAN interface to get a lease from the main router, this way everything will be configured appropriately. It most likely has something to do with IPv6.

EDIT: *Setting LAN to DHCP could render your AP unreachable and unmanageable if it can't obtain it's address from the main router after a reboot or power failure. To be used if you know what you are getting yourself into :grin:

In Access Point mode, is there any way for the WAN port to be used to connect to the main DHCP router? All the guides say to use a LAN port for this connection, but I'm just wondering if a simple config change can enable this.

@rajsris I don't think that it is that easy because AFAIK on the Archer C7 v2, WAN port has its own VLAN, its own firewall zone, etc. You might have to change all that to make it behave like a LAN port.

There is a problem here.

I also have the C7 V2. You can setup LEDE to a point and that is where things go wrong. If you edit the IPv4 address of the LAN interface but you DON'T update the gateway you will be fine (as long as your gateway address is the router, it will default to this when you click "Save&Apply" . As soon as you enter a gateway even it is the correct one, LEDE on the C7 no longer allows access to the WAN. I only got this issue when I did a fresh install and wiped all settings before doing so.
I have recreated this behavior 4 times now by doing fresh installs. If you specify the gateway at all, it's all over, you can try to delete it, but your connection to the WAN will still be blocked.

I spent two days on this, I was getting intermittent success with ping's to google's DNS servers at one point. So I physically tested all the old cables, I couldn't find a fault, so I replaced the cables anyway.

The only thing to restore access to the WAN is to preform a RESET under Backup/Restore and do all you network settings again...except for the default gateway :slight_smile:

should have mentioned this, for me it was on the LAN ports not the WLAN, I don't use the WLAN at all.


Does it work if you set up your AP C7v2 as DHCP client, instead of specifying an IPv4 address and gateway?

For me, I'm not using the C7 as AP at the moment, but I remember doing it this way worked fine, you could get ntp time, and opkg update worked.

DHCP client on LAN could end up with an unreachable AP if for some reason your main router doesn't supply DHCP. It's easy to recover from, but just letting you know what some else pointed out to me.

The way I set it up is to have DHCP router give a fixed reserved IP address to the AP. This works well for me and is almost always reachable.

Yes me too I was setup that way and never had a problem. But if, for example, there is a power outage and your main router doesn't comes up, or fail delivering DHCP, then your AP could not receive an IP. Although a UPS solve that problem.

The router i set up to receive it's external IP address as DHCP. It is only the internal IP address range that I am setting e.g
if I leave it there everything works. If I put manually as the gateway the everything stops working. If I then delete the gateway entry it still does not work. Only a reset gets Internet access back up.

The issue is not that there are workarounds.

The issue is something is wrong when setting the gateway and even more so when you consider deleting this entry does now revert the router back to a working state, which it should do without fail is no other settings have changed.

As I have mention in an earlier post I am able to reproduce this simply by performing a reset, setting the internal IP address range, then manually setting a gateway. On my C7 V2 this always leads to a unusable router.

The gateway field in the lan interface should be left blank in most scenarios. There must only be one default gateway on the system and this is on the WAN interface in most cases.

I cannot really reproduce your particular problem but it is expected that LAN->WAN routing breaks when you specify a bad gateway on LAN. In order to diagnose what is going on in the faulty state, please post the contents of /etc/config/network and the output of ubus call network.interface dump.