TP-Link Archer C6 v2 EU recover stock firmware

Hello,

could someone give me an instruction, how to recover stock OEM firmware into TP-Link Archer C6 v2 EU?
Now Im using OpenWRT 19.07.1, but Im facing poor performance on 5GHz radio, which is the reason for rollback to stock OEM firmware.
I tried to upload stock fw over LuCI and TFTP as well, but router became soft-bricked everytime.
After that, if I upload OpenWRT image over TFTP, router starts well.
I suppose, that there is something about stripping bootloader part from stock firmware, but I really don`t know, how to tho this.

Thanks

Hi there
you don't need to strip firmware because this router firmware doesn't contain uboot
just rename ArcherC6v2_eu-up-ver1-2-1-P1[20200110-rel60119] to ArcherC6v2_tp_recovery.bin
then upload it via TFTP Server

Thanks for reply. I allready did so, and also forced 100Mbps FullDuplex connection as it is specified in router techdata page. But still the same behavior: TFTP shows popup and runs succesfully to 100%. Then router restarts and hangs on power LED steady light up and all other LEDs off.

I just made a Stripped firmware Try it via TFTP and let me know

https://cdn.uploader.win/demo/12-Feb-2020/ArcherC6v2_tp_recovery-2ba28d.bin

check it out first before doing that :point_up_2:

I made all the same as on video, but unfortunately still the same result: after restart router hangs on power LED steady light up and all other LEDs off

openwrt

Hi There
I followed this Video on Youtube and rolled back to Stock Firmware




Without any problem I tested it with My Archer C60 V2
first of all, turn off your firewall then set ip to 192.168.0.66 in LAN card, then rename your firmware to tp_recovery then upload it via TFTP Server when upload is successfully done "BE PAITIENT" for at least 60 Seconds and DO NOT DO anything untill The router restarts

I say it again,You don't need Stripped Firmware because firmwares that contain boot need to Stripped
Download Archer C6 V2(EU)
https://static.tp-link.com/2020/202001/20200123/Archer%20C6(EU)_V2_020110.zip
Rename it to ArcherC6v2_tp_recovery
that's it

Still the same. My cases:

Use of ArcherC6v2_eu-up-ver1-2-1-P1[20200110-rel60119].bin: TFTP transfer goes well, but after restart router hangs on power LED steady light up and all other LEDs off.

Use of openwrt-19.07.1-ath79-generic-tplink_archer-c6-v2-squashfs-factory.bin: TFTP transfer goes well, and after restart router boots and works fine.

Have you found a solution for this yet?

Not so far. I suppose, that original firmware has to be stripped, but don`t know, how much.

Hello can u make another stripped firmware for the c6 eu v2? Thanks

http://www.mediafire.com/file/hkigcuh6x8clxpp/ArcherC6v2_tp_recovery-1.bin/file
http://www.mediafire.com/file/f75brrcz4h3th6v/ArcherC6v2_tp_recovery-2.bin/file

There are 2 stripped images first of all try Num 1 if it isn't done successfully try Num 2
dont forget to rename to ArcherC6v2_tp_recovery.bin

  1. Connect one of the router's LAN ports (it doesn't work with the WAN port!) to a network switch

  2. Connect another cable from the switch to the computer/TFTP server

  3. Set the computer IP to 192.168.0.66

  4. Start a tftp server with the image in the tftp root directory renamed to ArcherC6v2_tp_recovery.bin

  5. Connect the power cable to the router, press and hold the reset button and turn the router on

  6. Keep the reset button pressed until the WPS LED lights up

  7. Wait ~150 seconds until flashing and booting is completed

Let me know

Hello, thanks for the help
I am curious if it's doable without a switch ?

You should try them
I don't use this model
If you have openwrt installed,try upload image via web
2888a0c5aeb53ee21495778be42eb3aa155e68a0_2_690x339
then you should see something like this
e30f4f9a9f2318bc91fc9c8494d10d46dae30c0f_2_690x339

Alright i will try
I never knew i can flash stock images from openwrt

Tried both versions, but without success. So I am back on 19.07.2.
I found strange behavior: After TFTP upload of orig fw it will reboot shortly after 100% in tftp gui. However, after upload of openwrt, it will take few seconds, maybe for some processing.
I suppose, this is caused by reaching end of partiton space (maybe this assumption is wrong)

Okay, so I just made an account here just to post this.

To return to the stock firmware through tftpd, you'll have to use the very first (oldest) firmware available on the official website. All the others will show success in tftpd but won't boot. Here is the direct link https://static.tp-link.com/2020/202001/20200123/Archer%20C6(EU)_V2_020110.zip.
You can update to the latest firmware after installing this one via webupgrade.

Hope this helps someone.

1 Like

Good to know. I never had to do it, but it's a very valuable piece of information, thanks!

I need this, please explain. I tried flashing this firmware on my Archer C6 but its just booting to Openwrt always. Please help me out

I had big issues with 1.3.6. version of the firmware. Upgraded to open wrt and then tried downgrade to 1.2.1. as suggested in David's post. After that the router was bricked.

Next I followed the in unbrick guide with tftp that David posted, but non of the firmware resulted in a successful unbrick.

But I got it to work, you need to find firmware 1.0.1. It's not on the tp-link site anymore, but someone posted it on 4 shared. this one successfully can be applied with this method. After that you can upgrade to 1.2.1. through tp-link ui.

Here is the link that I managed to find on the net for stock 1.0.1. firmware.

Hope this saves 4 hours of stress for the ones in the same situation :slight_smile:

Final addition. This stock firmware restore can also directly be done from 1.3.x versions of the router. Just use tftpd64 program and follow David's instructions and use the provided 1.0.1 version.
Just did this on my second archer c6 eu v2.0 without open-wrt

1 Like