Archer C6 v2 - Returning to stock firmware from OpenWrt

I have two Archer C6 routers one is a v2 and the other v3.2. The v2 is running 22.02.1 but the v3.2 is only supported in SNAPSHOT so I’ve left it running stock.
I’m finding the inconsistencies between the two a bit jarring and I’d like to revert the v2 back to stock until both are supported in stable OpenWrt releases.

I found This topic, but it only talks about 19.07.x and it’s not clear whether I would have to TFTP, or if I can just upload the stock firmware through LUCI.

Any advice from people in the know?

Does this help? Tp-Link Archer C6 V2 Revert to Stock Firmware [Guide]

1 Like

The instructions there are similar, but they mostly talk about bricked devices and having to use specific firmware versions, some from unofficial links.

My router is very much working and I had hoped to avoid these hoops if it’s actually possible to just upgrade with normal stock firmware via LUCI or UCI commands.

I'd rather do a TFTP recovery, than attempting to write the stock image using Openwrt.

I have suffered to revert back to stock image and have read several topics in forum and outside until manage to do it.

If well remember I had to use an image provided in the wiki and using TFTP method.
Unfortunately the SSD from desktop where I saved the steps died.

Sorry about your router issues. I have some untested ideas which may be risky. Those steps are acclaimed to have successfully reverted firmware on another TP-Link device. Let me know if you are interested.

See this thread on a TFTP recovery for a C6 v2...

Also, a good rule of thumb on the reset button is to continue holding it in until the WPS light comes on, then release.

The issue was the fact, TFTP was triggered, but even before finish to flash stock FW router reboot.

With openwrt bin it worked fine all the time but with others the behavior explained happened several times until I finally manage to do it.

1 Like

That is likely caused by the header in the stock firmware.

Someone may have a stripped version.

You could also flash stock using a serial connection, which would bypass the header check.

Can you please describe the steps to do it via a serial connection? I haven't been able to successfully revert via tftp method

After trying and trying for many days I found the solution that worked for me.
follow the many posts about using the TFTP recovery procedure.
But! the key to success is that you have to do the "sysupgrade" after the factory firmware of OpenWRT.
So what I did is first download some old openWRT firmware version (just one older than the latest) and upload it to the router using TFTP, after the router reboots I upgrade the firmware using the GUI with the newest firmware of OpenWRT.

Now you can download the stock firmware from the tp-link website (whatever is available) and use the TFTP recovery procedure with it (you do not need the original 1.01 version).

And it works! the router restarts and updates the firmware with the TP-Link stock version (see the power-led blinks).

hope it helps.