TP-Link Archer C58 back to Default Firmware


I am attempting to restore my TP-Link Archer C58 v1 router back to its default firmware (currently on OpenWrt 19.07.3 r11063-85e04e9f46). I have tried numerous guides found on Google and Youtube but I am having no luck.

Any help would be greatly appreciated.


1 Like

Maybe you should state what you have tried already without success, otherwise you might get the same non working instructions again.

Hi tmomas,

Thanks for the reply.
I have tried following the generic uninstall guide and I have tried re-installing the original firmware via a TFTP server.

For anyone in the future that comes across the same issue, I carried out the steps from this guide.

In summary:

  1. Download Tftpd32 by Ph, Jounin [This can be found on Google, be careful where you download it from]
  2. Download TP-Link Archer C58 firmware, rename it to tp_recovery.bin [THIS IS FOR C58 EU v1, PLEASE CHECK LABEL UNDER ROUTER]
  3. Power on router and plug patch lead into LAN port of a computer and LAN port of router
  4. Change LAN adapter settings on the computer by carrying out the following steps:
    1. Go to control panel
    1. Go to Network and Internet
    1. Go to Network and Sharing Centre
    1. Go to Change adapter settings
    1. Double click on Ethernet
    1. Click properties
    1. Click Internet Protocol Version 4
    1. Click properties
    1. Click use the following IP address
    1. Enter for IP
    1. Enter for subnet mask
    1. Click ok
  1. Now the LAN port is configured, launch Tftpd32
  2. Allow it to communicate on all networks if asked
  3. Go to log viewer
  4. Change current directory to the folder containing the tp_recovery.bin file
  5. Change server interface to the one with IP
  6. Switch off router
  7. Hold reset button
  8. Power on whilst holding reset button
  9. Wait for Tftpd32 software to detect router and re-install the firmware

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.