[Solved] Reset Archer C2600 to original firmware

I have an TP-Link Archer C2600 router with LEDE on it. I wan't to go back to original firmware. Can I just use the 'system' -> 'Backup/flash firmware' option on routerlogin, or is there someway else i need to do it? I am curious because when i search for this router, it seems like it is often bricked and I am therefore not sure if this is the correct way to do it. Mine, although, gives me internet through cabel atleast.

I got this router from a secondhand store and didn't know it had this firmware on it. That's why im going back. That is also why I am very low-knowledged about this.

Firmware Version: LEDE Reboot 17.01.4 r3560-79f57e422d / LuCI lede-17.01 branch (git-17.290.79498-d3f0685)

Thank you.

Try this tutorial, which works for several TP-Link routers -

Rename the stock firmware file archerC2600vx_tp_recovery.bin, replacing the x with the version number of your C2600.

I just have no experience with TFTP servers or anything. So i hoped the other way was a possibility - that seemed a lot easier :smile:
My router is not bricked (atleast from what I know) so that i why all those turtorials, like the one you link, was confusing me.

Your router does not have to be bricked to use the TFTP tutorial...

Take your time and follow the directions, and you should have no problems.

Hi again. I tried this turtorial 2 times, and it don't seem to work. All the 'text' in the TFTP program (As shown in the last picture) doesn't show. It reboots but when i go to it is still with LEDE on it.
Afterwards, I tried flashing the firmware 'online' with, but it says "The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.".

I don't know if this is a part of the problem. I downloaded "Archer_C2600_V1_160902_1475196820201r.zip"
and extracted the files to the desktop and renamed the .bin file to "archerC2600v1_tp_recovery.bin".

Now I don't know what to do.

I had this router Archer C2600 and i followed this tutorial, all it worked!
Try to stop the antivirus, firewall and all software that would prevent packet transfer.

If you are experimenting with C2600 and you flash the wrong firmware and the device doesn't boot, you can restore the factory firmware:

Set PC to fixed ip address
Download factory firmware from TP-Link and rename it to ArcherC2600_1.0_tp_recovery.bin
Start a tftp server with the file ArcherC2600_1.0_tp_recovery.bin in its root directory
Turn off the router
Press and hold Reset button
Turn on router with the reset button pressed and wait ~15 seconds
Release the reset button and after a short time the firmware should be transferred from the tftp server
Wait ~5 minute to complete recovery.

Good luck

Common issues I see when it doesn't work...

  1. TFTP server running on the attached computer does not have permissions through the firewall.

  2. Router not powered off first.

  3. Reset button not held in for at least 10 seconds after the router is powered on.

Hi. Just a quick update. I got it working by using my other computer - don't know what happend before. Thanks alot for the help, i really appreciate that!

Should I close down this thread or anything?

Thanks alot!

Hello, all.
I tried the method above but router (also an Archer C2600) is still booting to OpenWRT (see screenshot).

Anything I might be missing?

I have the same Problem.


after a failed flash an original firmware from LEDE, the router is dead. The router with Archer c2600 v.1.1
Nothing lights up. I pulled it to the person who revived other routers and he said the bootloader was destroyed. There is need to change the flash chip and load a new bootloader. Where can I find this flash chip with a bootloader? Flash chip is Spansion FL256SAIFRO...

I would be very grateful if someone help with information!
Best Regards!

I have also tried the tftp recovery. Luckily i have given up before i have broken the router. Have you flashed Openwrt the first time over tftp or the web-interface? I just curious, coz i flashed my over the web interface and the tftp flash back to stock firmware also not work. It seems for other people to work, so we have done something different i think.

Try changing the cable that connects the network card to the router, follow the steps above just like in the movie presented on youtube, and be patient to transfer the firmware...
When you upgrade to the router, leave a ping on the router access address for the original firmware, you will know when the installation is ready...

Good luck

How can the cable influence if the tftp shows that the router load the firmware image, and the router restart? The only problem is that the router for some reason dont accept the new firmware and after the restart the router still boot openwrt. I would like to look in the serial output but for this router i need a Bi-Directional Logic Level Shifter Converter and good soldering iron what i both dont have.

1 Like

Can you kindly share the link to movie presented on youtube ?

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.