TP-Link Archer A6 v2.0 - cannot install

I recently bought this router. I thought that this is "identical" to Archer C6 v2.
I tried to install almost all version through gui but with no luck ("Invalid file type")
I tried install via tftp - but also no luck -
Firmware was downloaded, router restarted but with stock firmware.
Any ideas?
Stock firmware version: 1.3.6 Build 20200902 rel.65590(4555)
I also downgraded to
ArcherA6v2_eu-up-ver1-3-0-P1[20200402-rel51999].bin and
but this also does not help :frowning:
Any ideas?

Pity :frowning: Is this any thing I can do to help make A6 image? Without openwrt this router is useless for me, and I cannot return it.

Link was primarily for pointing you to the installation procedure...

Sorry, I do not understand.
TP-Link Archer A6 V2 build? - I cannot see instruction there, only further links - but this is for US version;a=commit;h=d03aae1a09fce5a5d5747855bc07ee1f54388e03 - but this is for _C_6 not _A_6

under we can see discussion about A6 (EU) but I cannot see this in code
especially this:

what am I missing?

I've seen this issue on other TP-Link devices if you use a long file name.

Download the OpenWRT factory firmware image for the C6 V2

Non-US is tplink_archer-c6-v2-squashfs-factory.bin

Rename it factory.bin

In the TP-Link GUI, use that file to upgrade to OpenWRT.

tried this (with tplink.bin and firmware.bin) - no success.

See the updated post to make sure you're getting the correct OpenWRT firmware file.

Failing a TP-Link GUI interface upgrade, try using the TFTP server method...which is used to debrick devices as well.

See this video.

Pay close attention to the step on how to determine what to name the firmware file, for your particular TP-Link device.

@kjonca It's quite possible yours might have a newer firmware that makes the OEM upgrade mechanism error. See the last patch in that GitHub PR specifically.

  • Can you attach serial to see what's going on exactly?
  • Could you share the name of the most recent firmware TP-Link offers for your device? That might give a clue as to the soft_ver the firmware could expect.
  • In which region/country did you purchase it?
1 Like

Try the TFTP Method. It is mentioned on the page that at times, you cannot install the image directly as the firmware needs the correct type of "magic" to be accepted on the Web UI.

See this:

From my original post:
"I tried install via tftp - but also no luck -
Firmware was downloaded, router restarted but with stock firmware."

"Can you attach serial" - I doubt. In attachment you can see board photo. I cannot see any obvious serial thing.

Latest firmvare name is "1.3.6 Build 20200902 rel.65590" but with firmware (when I downgraded) "1.3.0 Build 20200402 rel.51999" installation also failed

This router was bought in Poland(EU).

"See the last patch in that GitHub PR specifically." Can you please specify patch url.

might be under the metal shielding.

what about the back ?

I am afraid I have no manual abilities to remove this metal shield.
Back is attached

even more metal, bummer :frowning:

Which firmware file did you use for TFTP?

Did you follow the instructions in the video?

Different ones.
snapshot, 21.02.1

If you mean:

  1. set up eth interface in host to
  2. run tftpd server
  3. put firmware into tftp server directory and rename it to ArcherC6v2_tp_recovery.bin (wireshark logs show that router searched this file)

then yes

I mean did you use the non-US C6 V2 factory image, and did you follow the steps in the video, particularly how to find out what to rename the image...

You're probably better off in the long run just sticking with stock firmware.

Please be more specific. Yes, I used non-US firmware.

Can you explain what do you mean?
For me main thought from this video was:
"From tftpd server logs, we can guess which firmware is searched by router and use this name for firmware"
Am I wrong?