Too long ping on mr150 / mr6400v5

i have a mr150 2.2 with openwrt for mr6400v5, last uqmi from
but i see long ping via lte connection

config interface 'lte'
        option proto 'qmi'
        option force_link '1'
        option device '/dev/cdc-wdm0'
        option apn 'internet'
        option auth 'both'
        option username 'gdata'
        option password 'gdata'
        option delay '35'
        option default_profile '1'
        option pdptype 'ipv4'
        option peerdns '0'
        list dns ''
        list dns ''
wwan0     Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          inet addr:  P-t-P:  Mask:
          inet6 addr: fe80::8c62:4b64:ba21:568/64 Scope:Link
          RX packets:17 errors:0 dropped:0 overruns:0 frame:0
          TX packets:27 errors:120 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:1396 (1.3 KiB)  TX bytes:2316 (2.2 KiB)



what i do wrong?

@mrhaav - tagging since it's their firmware.

...running on an unsupported device.

1 Like

modem is same
vendor id, dev id
pcb is same

Are the TP-Link firmware files the same?
Tried to cross flash ?

firmware from mr150 working, but in admin side "error 1", because i change imei
and firmware from mr6400v5 working (in bottom show is mr150 and same error 1 and undefined imei)

i'm post photo in

look a like sinus graph

Pointless pinging across the internet if your ISP is really using a shared address to link with you. You need to limit the ping to the other end of the p-t-p interface and see what is returned.


Yes exactly. Run a traceroute (to anywhere) to get the IP of the ISP's first router serving you and try pinging it. They are usually configured to answer pings.

1 Like

Check the signal parameters first, make sure you're connected in LTE mode.

As @AndrewZ said, check if you are connected to LTE. You can check in syslog logread -e lte or run uqmi -d /dev/cdc-wdm0 --get-signal-info
But, stop the daemon first: /etc/init.d/uqmi_d stop.

same result:

root@OpenWrt:~# uqmi -d /dev/cdc-wdm0 --get-signal-info
        "type": "lte",
        "rssi": -44,
        "rsrq": -13,
        "rsrp": -76,
        "snr": 0.400000
root@OpenWrt:~# logread -e lte
Thu Jun  8 14:45:10 2023 kernel: [    0.638376] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
Thu Jun  8 14:45:10 2023 kern.notice kernel: [   14.737438] random: jsonfilter: uninitialized urandom read (4 bytes read)
Thu Jun  8 14:45:35 2023 daemon.notice netifd: Interface 'lte' is setting up now
Fri Jun  9 03:29:32 2023 daemon.notice netifd: lte (2580): Waiting for modem to initiate
Fri Jun  9 03:29:34 2023 daemon.notice netifd: lte (2580): PINcode disabled
Fri Jun  9 03:29:34 2023 daemon.notice netifd: lte (2580): Data format set to raw-ip
Fri Jun  9 03:29:34 2023 daemon.notice netifd: lte (2580): Default profile: 1
Fri Jun  9 03:29:35 2023 daemon.notice netifd: lte (2580): Airplane mode off
Fri Jun  9 03:29:36 2023 daemon.notice netifd: lte (2580):  searching on 25002
Fri Jun  9 03:29:38 2023 daemon.notice netifd: lte (2580):  registered on 25002
Fri Jun  9 03:29:38 2023 daemon.notice netifd: lte (2580): Registered to MegaFon on LTE
Fri Jun  9 03:29:40 2023 daemon.notice netifd: lte (2580): Connected with IPv4
Fri Jun  9 03:29:40 2023 daemon.notice netifd: lte (2580): Setting up wwan0
Fri Jun  9 03:29:40 2023 daemon.notice netifd: Interface 'lte' is now up
Fri Jun  9 03:29:41 2023 user.notice firewall: Reloading firewall due to ifup of lte (wwan0)
Fri Jun  9 03:29:46 2023 user.notice firewall: Reloading firewall due to ifupdate of lte (wwan0)
root@OpenWrt:~# ping
PING ( 56 data bytes
64 bytes from seq=39 ttl=242 time=101.084 ms
--- ping statistics ---
87 packets transmitted, 1 packets received, 98% packet loss
round-trip min/avg/max = 101.084/101.084/101.084 ms
root@OpenWrt:~# traceroute
traceroute to (, 30 hops max, 46 byte packets
 1  *  *  *
 2  *  *  *
 3  *  *  *
 4  *  *  *
 5  *  *  *
 6  *  *  *
 7  *  *  *
 8 (  42.877 ms (  40.945 ms  *
 9  *  *  *
root@OpenWrt:~# ping
PING ( 56 data bytes
64 bytes from seq=110 ttl=248 time=6013.412 ms
64 bytes from seq=111 ttl=248 time=5019.336 ms
64 bytes from seq=112 ttl=248 time=4019.189 ms
64 bytes from seq=113 ttl=248 time=3018.973 ms
64 bytes from seq=114 ttl=248 time=2018.757 ms
64 bytes from seq=115 ttl=248 time=1021.508 ms
64 bytes from seq=116 ttl=248 time=39.739 ms
64 bytes from seq=117 ttl=248 time=58.438 ms
64 bytes from seq=118 ttl=248 time=49.150 ms
64 bytes from seq=119 ttl=248 time=46.876 ms
64 bytes from seq=120 ttl=248 time=47.614 ms
64 bytes from seq=121 ttl=248 time=38.313 ms
64 bytes from seq=122 ttl=248 time=38.047 ms
64 bytes from seq=123 ttl=248 time=37.779 ms
64 bytes from seq=124 ttl=248 time=38.488 ms
64 bytes from seq=125 ttl=248 time=46.217 ms
64 bytes from seq=126 ttl=248 time=41.944 ms
64 bytes from seq=127 ttl=248 time=37.674 ms
64 bytes from seq=128 ttl=248 time=37.285 ms
64 bytes from seq=129 ttl=248 time=37.091 ms
--- ping statistics ---
159 packets transmitted, 20 packets received, 87% packet loss
round-trip min/avg/max = 37.091/1085.291/6013.412 ms

Try running those tests in parallel - ping in one window and uqmi (manually or in the script with a loop) in another.

you mean uqmi -d /dev/cdc-wdm0 --get-signal-info?

Yes, correct.
You can probably get a better looking output with -s:
--single, -s: Print output as a single line (for scripts)

You probably have some correlation between the latency/packet loss and negative SINR values.
I would repeat the tests on a different band and/or in the different location (different base station).

i'm change location, sinr is 9-12, but no have internet via lte :rofl:
traceroute, ping not response

i was change mobile operator, but it's not had result