TL-WR902AC V3 bricked, and any help would be appreciated

I have TL-WR902AC v3 and was able to load OpenWrt using tftp; however, something happened, and I tried to reset the router and it bricked (I believe).

When the router powers up, only power button is lit and nothing happens.

When I hold the reset button and power up, same happens. Or if I hold the reset button a little longer, then the light flashes, but nothing happens. I tried to follow the debrick mrthod using the factory firmware and strip using mobaxterm and create the tp_recovery bin and tried to use tftp, but the router doesn’t seem to be responding at all.

I tried to ping the ip address or, not responding at any stage.

Is it dead completely?

Any help to understand this would be appreciated.


The best way to check the device is use a (3,3V) TTL serial connection to the TL-WR902AC v3. Then you can stop the boot process and re-install OEM or OpenWrt firmware by tftp.
Make sure the used power adapter can deliver 3Watt (= 5Volt, 600mA minimal).
When you don't have a TTL serial the timing of starting the tftp is crucial, 2 to 10 seconds after start of the device.


This device is NOT RECOMMENDED for future use with OpenWrt due to low flash/ram.
DO NOT BUY DEVICES WITH 8MB FLASH / 64MB RAM if you intend to flash an up-to-date and secure OpenWrt version onto it! See 8/64 warning for details.
This device does not have sufficient resources (flash and/or RAM) to provide secure and reliable operation.
This means that you will not be able to install many packages, and that you might experience crashes due to OOM situations more or less often. See OpenWrt on 8/64 devices what you can do now.

Although is written that the latest version does work on it.

Try the "unbrick" procedure written on: TP-Link TL-WR902AC bad flash recovery - #9 by ogniemi


64MB starts to show with dozen wifi clients, it safely boots to 1.1

Thank you very much.

I was following the unbrick procedure on TP-Link TL-WR902AC bad flash recovery - #9 by ogniemi, but I never get any response from the SCP session, so I couldn't proceed any further. I will try few more times again with the timing in mind.

Is there any good guide for TTL serial process for these types of routers?

I can learn a lot from this.

Thank you very much!

Vendor procedure:


I doubt your router is really 'dead'. It could have got a wrong or faulty image.
The router will not boot fully but the pre-boot works.

With a TTL serial connection you can follow all steps of the router.
A helpfull link:

During pre-boot a different ip-address could be used for the re-flash process.
When using a TTL-serial you can stop the pre-boot at this point (any key), and check the pre-boot settings with command: printenv

When the pre-boot is faulty the router won't fully boot at all.
On some routers you have to use a hardware jumper (connect 2 points) during boot process to sent a asc-file to the router to boot a different pre-boot.

'I never get any response from the SCP session'? Did you check step 4 closely, you must boot the router into 'safe-mode' and your PC (with tftp) has the right ip-address (
It could be that the 'old' pre-boot is still active, then use other (OEM) ip-address for your PC (tftp).


Thank you very much for your help DGdodo!

I will definitely take time and go through it again and report it back here.

I have a feeling the router is not completely dead yet. I didn't do anything to fry the PCB, just flash the image, so definitely will try the steps again.

Thank you for your guidance again!