TL-WR841N v13 OpenWrt WiFi Repeater Mode

I install the OpenWrt firmware as expected to this post: TL-WR841N v13 installation and now i am back to stock firmware again to write to you becase i want your help to set it as an repeater.

I change to openwrt because of drop speed all the time and now with the stripped firmware i install seems more stable than the official for some reason.. :thinking:

I find this guide https://openwrt.org/docs/guide-user/network/wifi/relay_configuration but i stuck to

### Required packages

You must install **relayd** package if you want to do what is discussed in this article. If you want to use Luci GUI to set up your wifi extender, install **luci-proto-relay** package too.

Then i find this guide https://www.nerd-quickies.net/2017/04/03/setup-lanwlan-bridge-with-openwrt-luci/ and download the PuTTY and the luci-proto-relay from the link it gave and try to set the ip same as the guide. The problem was i set the 192.168.15.1 and i go to adapter settings at ipv4 and give to pc 192.168.15.2 but the routers site 192.168.15.1 wont load.. I notice in the interface section the default address is like that: 192.168.1.1/255.255.255.0/24 if i remember right for the /24 at the end..

Is there a guide for this?

Thank you all in advance for reading my bad English and explanation and the big text

What is the issue installing the required packages?

The issue is when i set the ip of the guide says and i cant load the routers page.

I set the ip to 192.168.15.1 and at my network adapter at ip v4 i set the 192.168.15.2 and mask 255.255.255.0 but i cant access to routers page to continue the second guides steps i post here.

Changing the address is not needed, as long as it doesn't conflict with the network of the main Access Point.
What address is the main Access Point giving out? Furthermore you can install the packages from the beginning and configure them later.
Just make sure that there is no cache problem in your browser when you change the address.

Hm.. So i install the relay package right after i install the openwrt firmware to router and after that i will follow the steps for set up the repeater mode.

Unfortunately necessary because the main access points ip i want to repeat is 192.168.1.1

First of all, any idea what i'm doing wrong with the ip change?

You should only change the IP address field under LAN interface. The mask remains the same. Click on Save & Apply and add a static address to your PC in the same range with mask 255.255.255.0 No need for default gateway or DNS.
Check with ping first, then try to open the page in browser.

I connected with PuTTY with the default address (192.168.1.1) to install the relay package and change the ip after but the commands from the guide is for Linux and I am on Windows. Any help for this?

Step by step it will work!

When you connect with putty to Openwrt you are working on a linux environment, so no worries about that.

Ok i follow the commands from the guide and everything was ok with the relay pack installation.

To install it i must have internet so i turn on hotspot at my mobile and connect my old repeater to this and repeat the shared network from my phone. Connect a cable from repeaters ethernet to wan port at my router and connect the router to pc with another ethernet cable.

I install the pack with PuTTY and following the commands form the guide and after finish it i go to change the ip to set it up as repeater as is the next step..

Look what i did and the error i get at the following photos.

1st step first
2nd step second
3rd step third

And now look what i get from the begging and all the time at Advanced Setting tab.

Advanced Settings for

And after some time i get a notification message: Rolling back changes because of fail something like that write the message and i press the unsaved settings blue button at the right corner.

Unsaved Settings fifth

It looks strange that it doesn't let you edit the IP address, but anyway.
In step 2, since there is no Netmask option anymore, use for IPv4 address 192.168.15.1/24
Leave Gateway empty.
In Advanced settings you must not fill anything in Use gateway metric. You can see it is red, so it is not a correct option.
Save and apply

In the Advanced Settings is pre-writed the word root i not change nothing there. At all my tryes i try to leave it blank and change it with 0 but even the error goes it not help this to change the ip.

I try as you say for leave the gateway empty and fill the ip as you said and still nothing.. At the end fail and roll back to previous settings.

Something isn't right here. Metric should not be a word like root.
Better do a factory reset on the router and start over again.

I do reset every time right after firmware install.

Is it this firmware version bug? The firmware i install is from @julianocs post here: TL-WR841N v13 WiFi not stable? and the version is Build_20190111_Driver20190111

No need for factory reset after firmware install, if you select not to keep the settings.
Better discuss it with the image creator, as this is not expected behavior.

I hope @julianocs see my post and say his opinion.

@trendy Do you have any suggestions for software version that works properly?

How about the official one?

I download it and try to install but i get bootloop with this firmware..

Edit: Sorry my bad, now i see is sysupgrade file and not tftp recovery, i try to install it as a tftp recovery file and thats why i get bootloop. I go to install it now and try again!

Edit 2: I notice that the official openwrt is a little bit different than the other i flashed and try. At official openwrt i can modify the default 192.168.1.1 and change it at the same form. To the other version "unofficial" i install i had to add new address and cant modify the default.

Even modify and change to 192.168.15.1 and fail and try with 192.168.15.1/24 with or without mask black at the official openwrt i cant change successfully the ip address and get the same error, changes fail bla bla..