TL-WR841N v13 installation

1. First, you'll need to get a TFTP server running, I'm assuming you are on Windows, but since I don't know if you're under x86 or x64, you can get this one: http://tftpd32.jounin.net/download/tftpd32.452.zip
Just extract the archive into some folder on your disk.

2. Copy the full firmware file openwrt-xxxxxxxxxxxxxxxxxxxxx-squashfs-tftp-recovery.bin and place it in the same folder as the tftp server files you extracted earlier. Rename the firmware file exactly to tp_recovery.bin.

3. Open your wired network interface's settings and set your IPv4 manually to 192.168.0.66, click OK

4. Disconnect every cable from your router apart from the one connecting to your computer

5. Power off the router and open the TFTP server by running the executable extracted earlier (tftpd32.exe)

6. Now, press the reset button on the back of the router and power it on without releasing the reset button, wait for about 10 seconds or until the TFTP server shows some activity (loading bar), meaning the router is downloading the firmware file for flashing - once it reaches 100%, you may release the reset button and then wait about 2 more minutes until the flashing process is complete (pay attention to the LED lights).

7. Again, open your wired network interface's settings and set your IPv4 back to automatic, click OK; if the flashing process was completed correctly you should get assigned an IP address by the router within the subnet 192.168.1.0/24, in which case OpenWRT LuCI should be accessible through http://192.168.1.1

NOTE: If you did not succeed in step 6, meaning that the router never downloaded the firmware file, it may be due to WIndows' connectivity detection creating a delay that goes beyond the window of time during which the router's TFTP client tries to find the server. In this case, you have 3 options:
A. Get a network switch, connect one cable from your machine to the switch and a second cable from the router to the switch, now try again the process from step 6.
B. Get a machine with Windows XP, I think this "feature" was introduced in Win Vista or 7;
C. Get a machine with Linux, but you'll have to gather how to get a TFTP server working on it, shouldn't be too hard though.

Hope this helps.

P.S: This video sums it up well enough: https://www.youtube.com/watch?v=EC-3pxbHoHw
Just ignore the steps to download the firmware (which you already have), ignore the steps to download WinSCP and LuCI, and also ignore anything after 9:20

Thank you very much @ner0 for the analytic and understanding steps.

I have two more questions.

First, if a new version of the firmware released i will update it as always we update routers firmware from settings and upload via cable connection the file to router and the file will named openwrt-ramips-xxxxxxxxxxx-squashfs-sysupgrade.bin ? And the second one is if i install OpenWrt is there a way to get back at stock firmware?

@GiannisSma

  1. Yes, the sysupgrade firmware file is supposed to be used to upgrade an existing OpenWRT firmware from within. In these early builds though, things may not always work according to plan... just the other day I did an upgrade using the sysupgrade image and the router soft-bricked, I had to re-flash using the full OpenWRT firmware image. Backup the router settings beforehand, there is little chance to actually hard-brick the device so you shouldn't need to worry.

  2. Yes, you can revert back to the stock firmware but unfortunately you cannot use the original firmware file to do so, apparently the firmware must be stripped of some extra data so that it can be flashed exactly as OpenWRT is flashed: with TFTP. I remember having this issue a while ago and found a stripped version here: Installing on TP-Link TL-WR841N V13

There is a link to download the file tp_recovery(TL-WR841N(EU)_V13_STRIPPED).zip, inside it is the stripped stock firmware which can be used to flash and revert to the original TP-Link firmware (as the filename indicates, this stripped stock is for EU versions).

NOTE: After a quick comparison, my conclusion is that the stripped version is the exact same firmware as TL-WR841Nv13_EU_0.9.1_4.16_up_boot[180119-rel65243].bin, but without the first 200 bytes. Although I am unsure, I assume that the US firmware version would also be flashable through TFTP if you were to remove the same 200 byte header.

i gave up on this router because the wifi didnt work\was unstable. i tried flashing the stripped firmware but it didnt work either. it was an NA version. just thought i would chime in for what its worth. if you have a stripped version you want me to try let me know. right now im just using it as a backup for my main wired router

Can you share the stripped version?
Also, what happens after the FW update?

Where did you get the stripped version?

geeze dude how do we edit our profiles. i didnt realize it would show our full names publicly. oh and i found one version by googling and then another i made from instructions i googled. neither worked.

what do you mean "what happens after the FW update?" on a stripped firmware it goes back to stock. a stripped firmware just has a few bytes stripped out of the stock firmware so it will flash correclty. it doesn add any features or anyuthing and its not openwrt its tplink firmware.

what do you want it for?

what do you what the stripped version for? do you realize what its for?

Never mind, I think there was some confusion between me and your incoherent rants, my bad.

what was incoherent about anything i said? everyone understood what i was saying, except you apparently. and why contact me in email? just post your reply in the forum thank you

i didnt realize you were the one posting the comment about using the stripped firmware in the first place. i thought you were someone joining in the conversation later and thought it was for flashing openwrt. so i was wrong there. but all i was saying is that i tried with a stripped version on an american version and it didnt work. ill try the one you posted. i dont really need the router back on stock firmware but ill do it to confirm whether or not it works on american versions

i also had 2 forum pages open and got them mixed up. that was the problem. but you dont have to be ass about it

I didn't contact you by e-mail, if anything you got an e-mail notification from the forum.
You initially said the following:

i tried flashing the stripped firmware but it didnt work either

So my interpretation of this was that your router wasn't booting and my follow-up question was to try and help unbrick what I understood to be a soft-brick or inability to get back to stock. I made the smart-ass comment because you were being passive-aggressive in your replies and I didn't take it kindly. That being said, besides the fact that the router isn't working properly, I still haven't figured out if there is an actual problem you are facing or you're just commenting on the poor performance of the router itself. Maybe someone else will be able to help seeing as they understood what you were explaining. No hard feelings.

the striped firmware worked. im an idiot. so sue me : )

1 Like