Tl-wr1043nd v1 bricked


Some years ago, I bought a router TPLINK TL-WR1043ND(DE) V1.2 on order to install Openwrt. But the router was very new and did not support the version that i tried to install and then it bricked.

I've tried everything several years ago with no solution, and I've take it again.

I have tried with serial access using putty/hyperterminal/termit and tftpserver but when I have to write the comman "tpl" it is as I have not written anything.

This is the text that I get when I boot the rouuter

U-Boot 1.1.4 (Mar 31 2012 - 10:40:21)

AP83 (ar9100) U-boot 0.0.11
32 MB
id read 0x100000ff
flash size 8MB, sector count = 128
Flash:  8 MB
Using default environment

In:    serial
Out:   serial
Err:   serial
Net:   ag7100_enet_initialize...
No valid address in Flash. Using fixed address
: cfg1 0xf cfg2 0x7114
eth0: 00:03:7f:09:0b:ad
eth0 up
Autobooting in 1 seconds## Booting image at bf020000 ...
   Uncompressing Kernel Image ... OK

Starting kernel ...

Linux version ( (gcc version 4.3.3 (GCC) ) #5 Wed Dec 21 01:59:33 CET 2011
bootconsole [early0] enabled
CPU revision is: 00019374 (MIPS 24Kc)
Atheros AR9132 rev 2, CPU:400.000 MHz, AHB:200.000 MHz, DDR:400.000 MHz
Determined physical RAM map:
 memory: 02000000 @ 00000000 (usable)
Initrd not found or empty - disabling initrd
Zone PFN ranges:
  Normal   0x00000000 -> 0x00002000
Movable zone start PFN for each node
early_node_map[1] active PFN ranges
    0: 0x00000000 -> 0x00002000
Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 8128
Kernel command line: rootfstype=squashfs,yaffs,jffs2 noinitrd console=ttyS0,115200 board=TL-WR1043ND
PID hash table entries: 128 (order: -3, 512 bytes)
Dentry cache hash table entries: 4096 (order: 2, 16384 bytes)
Inode-cache hash table entries: 2048 (order: 1, 8192 bytes)
Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
Writing ErrCtl register=00000000
Readback ErrCtl register=00000000
Memory: 29276k/32768k available (2126k kernel code, 3492k reserved, 423k data, 152k init, 0k highmem)
SLUB: Genslabs=7, HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
Hierarchical RCU implementation.
Calibrating delay loop... 266.24 BogoMIPS (lpj=1331200)
Mount-cache hash table entries: 512
NET: Registered protocol family 16
MIPS: machine is TP-LINK TL-WR1043ND
bio: create slab <bio-0> at 0
Switching to clocksource MIPS
NET: Registered protocol family 2
IP route cache hash table entries: 1024 (order: 0, 4096 bytes)
TCP established hash table entries: 1024 (order: 1, 8192 bytes)
TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
TCP: Hash tables configured (established 1024 bind 1024)
TCP reno registered
NET: Registered protocol family 1
squashfs: version 4.0 (2009/01/31) Phillip Lougher
Registering mini_fo version $Id$
JFFS2 version 2.2. (NAND) (SUMMARY)  © 2001-2006 Red Hat, Inc.
yaffs Dec 10 2011 18:14:12 Installing.
msgmni has been set to 57
io scheduler noop registered
io scheduler deadline registered (default)
Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11) is a 16550A
console [ttyS0] enabled, bootconsole disabled
console [ttyS0] enabled, bootconsole disabled
Atheros AR71xx SPI Controller driver version 0.2.4
m25p80 spi0.0: unrecognized JEDEC id 1c3017
Realtek RTL8366RB ethernet switch driver version 0.2.3
rtl8366rb rtl8366rb: using GPIO pins 18 (SDA) and 19 (SCK)
rtl8366rb rtl8366rb: RTL5937 ver. 3 chip found
rtl8366rb: probed
eth0: Atheros AG71xx at 0xb9000000, irq 4
Atheros AR71xx hardware watchdog driver version 0.1.0
TCP westwood registered
NET: Registered protocol family 17
802.1Q VLAN Support v1.8 Ben Greear <>
All bugs added by David S. Miller <>
VFS: Cannot open root device "<NULL>" or unknown-block(0,0)
Please append a correct "root=" boot option; here are the available partitions:
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)

Can you help me? What am I doing wrong?

Thank you in advance

If you have connected the serial cable correctly, you should be able to type Quickly! “tpl”. The boot loader even gives you a second bootdelay to let you do this. It might take you a few attempts to get this right. Once you are at the Uboot prompt, ther are a number of different how-to’s specifically for your router. As long as you have a Uboot that at least tries to boot into Linux, the router is not dead, it just has the wrong/corrupt firmware.

One thing you might try when you are not able to get the “tpl” to get accepted, is play with the flow control settings: specifically the XON/XOFF as suggested at the end here:

I used the tool here and everything worked fine.
Follow the instructions here: [SOLVED] Bricked Tp-Link WR1043ND v4 (2nd post)

Thanks to you two.

I will try with the flow control to XON/XOFF.

Yesterday I tried with the mentioned tool but did not worked. I will try configuring the new parameter.

Thanks again.

This tutorial on the TP-Link forum uses TFTP instead of serial...

Rename the stock firmware file wr1043v1_tp_recovery.bin

OP mentioned v1.2. As far as I’m aware, the TFTP recovery wasn’t part of the Uboot (without needing serial) until v1.8

Doesn’t hurt to try, but the OP also said he tried in the past with no success.

The TP-Link forum tutorial uses a TFTP server run from an attached computer, not in uboot.

:smile: of course the TFTP Server part runs on a “normal” computer. The problem is accessing / starting the TFTP client. This needs to be done manually via a serial console, or “automatic” by pressing e.g. the reset or WPS button when powering up the device. This is implemented within the Uboot. A more user friendly way would be to start a small web server to allow firmware upload. Most modern devices have this type of features.

@pepe2k has made a lot of Uboot modifications for a lot of devices to have all these “failsafe” features. But even to start using before these mods, the OP still needs to get some firmware running first or at least have serial access to the Uboot console.

Sadly u-boot_mod doesn't cover the TL-WR1043NDv1 (AR9132), if the installed OEM u-boot has (non-serial) tftp recovery support depends on the last installed OEM firmware (TP-Link retrofitted tftp recovery sometime in 2013, earlier TL-WR1043NDv1 didn't ship with it originally).

See the serial console recovery section for V1.x in this OpenWrt wiki article...

In the requirements section, the second item may explain why you can't type tpl -

terminal program set to 115200 8N1, no flow control

minicom –baudrate 115200 –device /dev/ttyUSB0 –8bit (I couldn't type the tpl command using this)

screen /dev/ttyUSB0 115200,cs8,-ixon (this worked for me)

Web-based bootloader for V1 and V2 TL-WR1043ND :
I haven't tried it yet.