The opkg update command failed with code 6. Please Help me. why its showing? [solved]

why its showing on opkg update?

Wget returned 4 means that it cannot make the connection.
Check your gateway and dns, especially if the device is setup as a dumb ap or manually configured relative to the uplink.

i just reset the router and connect with pppoe setting. and internet is working correctly. but in
opkg update its showing network setting failed. then how can i using internet now?

See. my connection is okay

I'd suggest that you don't try and ping if the trouble is reaching Perhaps try pinging Also try that as a traceroute.

see. all is okay

And it's still having trouble with the update?

Yes. :frowning: how can i fix this?

i upgraded again from 21.x.x to 22.3.2 and with full reset. still this problem im facing

And if you wget for one of those files that fails, via cli ?

Not sure is your case but I had the same trouble with a different wget message and solved with Use Custom DNS Server properly set (LuCI: Network --> Interfaces --> LAN --> Edit --> Advanced Settings)... maybe you colud try....

One possibility is that your router has wrong date (and time), so that the server's SSL certificates are not valid and the SSL handshake fails.

Is it still wget returned 4, or a different error on the update now?

time and date is correct :frowning:

still wget returned 4 error

which dns should i put there?

i cant use cli :frowning: i dont know the process actually

Depending on the IP address I get from my ISP, for some reason opkg update also fails here (even if I can ping

I need to force a WAN reconnection (Vivo Fibra, PPPoE) to get a different IP until opkg works.

So far I have not found the reason for this (my current hypothesis is that my ISP has many IP address in some blocklists which may be gated by some server used by opkg update).

A similar problem happens when I do my own builds. "./scripts/feeds update -a" fails even if I have Internet connection. The solution is the same as above.

This issue is specific to my ISP (Vivo Fibra). With a different ISP (Claro HFC) it works fine.

so its happening for my ISP?

Can you go to using the web browser on your computer while connected through this ISP?

1 Like