The OpenWrt Firmware Selector

Bro
So how do I change the uci commands ?!
I did not find the /etc/config/wireless file !
Please explain exactly what to do, or if you have time, do it with AnyDesk
PLEASE :pensive:

You should start a new thread over in the "Installing and Using" category, as fixing your wifi is off-topic in this thread...

1 Like

Same thing here.

When landing at OpenWrt Firmware Selector, the version is SNAPSHOT (r25565-dea42f67ab) with a Date of 2024-03-16 13:55:05

After amending "Installed Packages" to:

base-files busybox ca-bundle dnsmasq dropbear firewall4 fitblk fstools kmod-crypto-hw-safexcel kmod-gpio-button-hotplug kmod-leds-gpio kmod-leds-ws2812b kmod-mt7915e kmod-mt7986-firmware kmod-nft-offload kmod-phy-aquantia libc libgcc logd luci mt7986-wo-firmware mtd netifd nftables odhcp6c odhcpd-ipv6only opkg ppp ppp-mod-pppoe procd procd-seccomp procd-ujail uboot-envtools uci uclient-fetch urandom-seed urngd
htop iperf3 luci python3-speedtest-cli
wpad-openssl
luci-ssl-openssl
luci-app-statistics collectd-mod-cpufreq collectd-mod-ipstatistics collectd-mod-ping collectd-mod-processes collectd-mod-sensors collectd-mod-thermal collectd-mod-wireless

And clicking "Request Build", the build is available instantly, as a very old build:

Version: SNAPSHOT (r25442-97f542238a) Date: 2024-03-09T22:42:37.000000Z

(March 9th instead of March 16th)

That's weird. Maybe some caching gone wrong?

As I understand so far, the firmware selector version will not refresh before nightly build, right?

Problem is, some targets like mt7621 stuck on March 12th. Any bugs are blocking auto building?

Edit: Oops, just realized that the developers are busy supporting the upcoming 6.6 kernel for mt7621.

Cannot build latest 22.03 image "Unsupported version: 22.03.6" . Old ath79 have no other option

1 Like

I created firmware through this site a few days ago, and now when I want to create firmware again, it gives me the firmware of that day. Am I doing something wrong?
Device: Mi Router 4A Gigabit

If you request the same build (target, version and packages), the ASU server used by the Firmware Selector will return a cached version for several days until the cache expires and the build is purged. So, it sounds to me that what you're seeing is expected behavior.

1 Like

I'm using the same packages. Thank you

Well, I guess Firmware Selector defaults to the latest stable version of Openwrt (23.05.03) which is only a few days old. Before 23.05.02 was the stable version during a few months.
Or did you download master/snapshot?

Add these at the end if you have 3 interfaces, change names and passes

uci set wireless.@wifi-device[1].disabled=0
uci set wireless.@wifi-iface[1].disabled=0
uci set wireless.@wifi-iface[1].ssid='nicename'
uci set wireless.@wifi-iface[1].key='securepassword'
uci set wireless.@wifi-iface[1].encryption='psk2+ccmp'

uci set wireless.@wifi-device[2].disabled=0
uci set wireless.@wifi-iface[2].disabled=0
uci set wireless.@wifi-iface[2].ssid='anothername'
uci set wireless.@wifi-iface[2].key='thispasscanbesameordifferent'
uci set wireless.@wifi-iface[2].encryption='psk2+ccmp'

I've flashed the recent snapshot from attendedSysupgrade and now the Xiaomi AX3600 does not longer boot. Cannot trigger failsafe mode via reset button. What can I do now?

If you restore the router, then NEVER use snapshot again unless you are a beta tester and don’t know how to restore a router.

1 Like

If you use the "Script to run on first boot (uci-defaults)" and include something in it, for example the same IP address, even if it is the same 192.168.1.1, then the server will compile a new build.

I also see that there is a very clear difference in noise level between a MERCUSYS MR70X (mt7621) with -88-91 dBm at 2.4 GHz and -92 dBm at 5 GHz and an Archer C60 v1 (ath79) with -95 dBm constant at 2.4 GHz and -105 dBm at 5 GHz.