The OpenWrt Firmware Selector

Yeah, same here. Looks like a new version of (or flag on) gcc doesn't like some of the format strings. See the bottom of this for one example:

The procd build error is gone, so my x86 builds are solid. Not sure what arch the ipq807x devices fall under, but give it a try...

1 Like

The Firmware Selector now has a small button to fill in a uci-defaults script to set common options:


Cool, but /etc/config/wireless is populated by hotplug events, ie. depending on the time the wireless PHY pops up (think: loading kernel modules, loading firmware, ... all takes time) this can be long after uci-defaults has already been run.

I've tried to resolve this by adding support for dynamically generated wireless defaults, long ago, and was hoping to receive more feedback:


Unsupported version: 22.03.4???

Previously discussed:

Also see:

It's great, but...
There is a choice of this version, so it is added, but the assembly does not go, because it is not supported?
And also, for example, version 19.07.XX for old routers. There is a choice, so added, but also not supported? Why then is there a choice?

Did you have an opportunity to read the linked posts?

:point_right: Here

Your answer appears in the first linked post. If you have additional questions, feel free to inquire.

I'm not understanding the version 19 example. Are you using an EOL version to compare a service release version not yet available?

I can select these versions on the page, but this does not lead to a positive result. Although by clicking on the "FOLDER" icon, I can download ready-made images with these firmware versions.
If I can select version data, why isn't the build happening? If for some reason these versions are not available for assembly, why are they available for selection?
I apologize for my bad english.


  • 19.07.10 - "Unsupported branch" - old


@aparcar ???

Then why can I choose it?
For training?
If one is not yet there, and the other is already gone, perhaps it needs to be removed from the "MENU"?

He will be able to answer. Feel free to wait for an answer.

You can also Private Message him if you do not wish to wait for an answer.


Last night, for example, there were only 3 choices available.

  1. Snapshot
  2. 22.03.3
  3. 21.02.5

Already explained:

That's not what I saw here.

I suspect the problems are a bunch of release-in-progress issues that will be fixed when the release is done.


HiWiFi HC5611


SNAPSHOT (r22594-5ec781c444)

2023-04-18 22:10:57


My educated guess is, you are kind of short on time on a caps-locked keyboard and you recently learned 2 new things by trying:

  1. snapshot are developer releases that don‘t come with a LuCi Web GUI by default. You have to install the GUI on snapshots manually
  2. that device is not supported yet. There are only developer snapshot releases so far. Could just be that no one has yet figured out, how to get Wifi up and running on that device. There seems to be a dedicated forum thread for that device, in case you find more time for posting: Add support for HiWiFi HC5611 for OpenWrt

2 posts were split to a new topic: Ac1200/archer c5 v3 not found in firmware selector

When you choose Customize installed packages and/or first boot script the default Installed Packages that appear in the list box aren't supposed to match those installed in the Official Stable versions?
Its notably missing Luci at least which should be on Stable versions ...
Or are they hardcoded somehow?

Can I get the list of packages installed by default on an official version to replace this list and match a custom build with the stable versions? That is without actually installing an official version and opkg list-installed...
I tried to get it from downloads.openwrt,org matching build dir but I'm not sure if I could use the list from config.buildinfo, the manifest file or where...

As far as I know, snapshots never contain Luci. You have to add it to the snapshot yourself – either in the Firmware Selector build your own firmware, build the firmware yourself on your machine, or install Luci through SSH (opkg update, opkg install luci).

1 Like