"The device is supported, but this image is incompatible for sysupgrade"

Hi all,

I already tried in the 22.03.1 thread (OpenWrt 22.03.1 first service release - #19 by Ramon) but did not get a response. So let me try again :slight_smile:

I got the below warning about image version going from 21.02 to 23.03.0 So I used factory file and flashed it via UI, worked no problem. But now with going to 22.03.1 and going to 22.03.2 i keep getting the same warning. So did I do something wrong and I am still on image version 1.1? or is the warning false? or

Does anybody have any idea?

Thanks,

Ramon

P.S. Its an E4200V2

Tue Oct 18 18:47:37 CEST 2022 upgrade: The device is supported, but this image is incompatible for sysupgrade based on the image version (1.1->2.0). Tue Oct 18 18:47:37 CEST 2022 upgrade: Partition design has changed compared to older versions (up to 21.02) due to kernel size restrictions. Upgrade via sysupgrade mechanism is not possible, so new installation via factory style image is required. Image check failed.

The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform.

Did you overwrite the compat_version perchance:

/etc/config/system

config system
  option compat_version '1.1'

not sure what that should be for you on specified device relative to where you are at with OpenWrt version.

Did you restore settings (after the factory flash) ?
Or "kept settings" in the flashing?

If yes, then you likely have restored also the compat_version '1.1' setting that anomeome already mentioned. Your current image is supposed to have changed that to 2.0, but if you have restored an older backup, you have likely reverted it back to 1.1 causing the warning in this flash.

E4200 v2 seems to be a dual firmware device, which could explain what you are seeing.

I did restore settings. and yes I checked and found that i have 1.1 there now.

Well how would that work then if its a row in a config file? or does it check regardless of what is written there?

So how to proceed, just remore the line, replace the line with 2.0? And can I just use the sysupgrade file, or do i need to do factory again, and then restore settings?

Thanks all for the help!

I tried to indicate that I do not know what yours should currently indicate, but see the above hnyman post as to what it should be for your current version; so wrong?

so uhm, yes, if you are sure as to where you are at, you can just edit to the correct value.

I ran 22.03.0, and 22.03.1 both flashed them with factory image. So I guess both flash stores should be 2.0. But I can only edit the current one, while I guess both still say 1.1 in the config file. So well euuhhmm

If you can flip partitions on that device...

not sure how, other than just reset it during boot or something. I just tried editing the line, on the current partition then the warning is gone. But well if it flashes to the other partition, that may still be 1.1 layout although I did flash twice with 2.0 already,

seems to be supported

Ahhh thx, didnt know that one

Looks like im good to go!

But that does mean that the partition version check may just rely on one of the current config file, while it flashes to the other.

Anyway i am going to dare to flash the sysupgrade :slight_smile:

The restore is the reason for your trouble. You overwrote the value 2.0 in the new image's built-in settings with the older value from your backup.

As you have flashed with new factory images twice, you should have the proper partition structure already on both firmware partitions. Just edit the value to 2.0 in the current one. It will be carried on in the next sysupgrade to the other firmware partition along other OpenWrt settings.

Note that there is no real partition table, just the firmware's internal knowledge how they should be.
And the 1.1 vs. 2.0 is just a helpful for preventing accidental sysupgrades with wrong images.

Right.

Thanks for confirming!

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.