Support for ZBT WE826-Q

Has anyone tried to add support for the ZBT WE826-Q?

This is a QCA9533 based router and appears to be very similar to the AP147-010. We are interested in using it with modern PCie modems like the Sierra MC7455.

The ZBT firmware is based on Lede 17.01 so it is pretty old and it's drivers are outdated when it comes to modems released in the last few years.

It has a hardware watchdog controlled by a GPIO pin which requires the pin to be pulsed one a second. ZBT has sent me the details of this and I was able to add this to my build system when creating an AP147-010 image that does work on it except for one problem.

If I build a Lede 17.01 image for this everything works correctly but if I make a 18.06.x build for it the USB system is not recognized.

In the 17.01 System Log you see this :

[    5.269770] SCSI subsystem initialized 
[    5.279536] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver 
[    5.287781] ehci-platform: EHCI generic platform driver 
[    5.293336] ehci-platform ehci-platform: EHCI Host Controller 
[    5.299332] ehci-platform ehci-platform: new USB bus registered, assigned bus number 1 
[    5.309614] ehci-platform ehci-platform: irq 3, io mem 0x1b000000 
[    5.328370] ehci-platform ehci-platform: USB 2.0 started, EHCI 1.00 
[    5.335679] hub 1-0:1.0: USB hub found 
[    5.339957] hub 1-0:1.0: 1 port detected 
[    5.346816] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver

but in 18.06.x you get

[    5.425720] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver 
[    5.441733] SCSI subsystem initialized 
[    5.450530] ehci-platform: EHCI generic platform driver 
[    5.459014] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver

The USB system is not found in 18.06.x. Something is different from 17.01.

The packages in each build are the same. I have also tried a stock OpenWrt 18.06.5 and a 19.07 image with the same results.

ZBT is not interested in working with us to get a 18.06.x build working, even after repeated requests from the company that wants to sell these routers.

We also have a QCA9533 router from SX-Tech that works with an AP147-010 image built with 17.01 but shows the same USB problem with 18.06.x.

Does any one know anything about what might be causing this problem?

I am experienced in modifying OpenWrt and building images (I run the ROOter Project) so it isn't a newbie problem. I have made images for other AP147-010 clones that didn't have this problem.

Any help or pointers to a possible problem area would be appreciated.


Hi @Dairyman did you make any progress on this? We'd like to connect some vulnerable folk around our area (the new Covid-19 reality) and this seemed like a good shout.

I did finally figure out the problem and have created ROOter images for this router.

You can find it at

The problem stemmed from a lack of pullup resistors on certain pins of the SOC and a change in OpenWWrt from 17.01 to 18.06.

You might have a look at the ZBT WE826-T (metal case), as a low-cost alternative. Good support for openwrt, as the WE826-family is rather widerspread. Very stable using the EC25.

At ROOter we have been using the WE826-T ever since it was first supported by OpenWrt. It is a well used and supported device.

The big difference to many people is the Wifi between the Q and the T.

The T is MT76 and the Q is Ath9k and most feel that Ath9k is better supported and works better.

I was doing image creation for a company that sells plenty of WE826-T but wanted a similar router that had better Wifi. ZBT did not, and still doesn't, have a firmware for the Q that is newer than 17.01 and that has terrible modem support.

We finally figured out the problem without any help from ZBT as they were uninterested in firmware that wasn't 17.01.

1 Like

Hey all thanks for this. @Dairyman is exactly right, I'd trust ath9k far more than mt76, which can be so flaky.

I'd like to create my own OpenWRT image that are super stripped down (to give space to some research partners who might want to deploy agents on the router). Are you thinking of getting these changes into OpenWRT? Or could you help me do it? Happy to put in the graft if it helps others.

I have various WISPs as clients, using the WE826 with MT7620 and openwrt. And my custom builds, usually some type of hotspots, also incl. EC25. There _were_issues, in the very past, though.

Thanks for this - will bear in mind

ROOter is a slight fork of OpenWrt with the changes being mostly cosmetic and affecting the Material theme. The actual modem support is done using the usual OpenWrt style packages. There are a few driver patches to make modems work better but it is really just OpenWrt with a bunch of packages added.

To ease making ROOter images I have a build system package that will create an OpenWrt buiild system (18.06.6, 18.06.7, 19.07.0 or 19.07.2) and install all the needed packages. Just by running a single script.

If you know about OpenWrt and want to try your hand at this go to

It includes a tutorial on how to set up and build images.

1 Like

Some people find the MT76 wifi quite adequate and are happy using the WE-826-T. Others find it to be somewhat flaky and like the Ath9K Wifi better. All a matter of if it works for you.

We have working images for both the T and the Q routers so people can use which one they want.

Hi Dairyman, thanks for this. Been getting my head round ROOter, well done, such a solid piece of work :slight_smile:

WRT to Q, do I just build the APl47 image in AR7xxx while selecting the package for the wee826-q? Is that what will get me a usable image?

As you figured, you select AP147 as the device then select the ext-rooter16 and we826-q packages. This will create the correct image.

For better support you probably should post on the ROOter forum as we don't always lurk here.

Thanks for your ROOter image . I'm using a we826-q in China , and people in China needs programs like ssr or v2ray to get connected to youtube and google ... My question is when i use this image , I can not insall iptables-mod-tproxy , which leads to can not insall ssr or v2ray , any idea how to solve this ?

here is the information :
After flashing the local compiled image to my route, I got this error when using opkg install sometimes:

  • satisfy_dependencies_for: Cannot satisfy the following dependencies for iptables-mod-tproxy:
  • kernel (= 4.9.152-1-0b692028eb19a63deb9c9d19c9fee83c)
  • opkg_install_cmd: Cannot install package iptables-mod-tproxy.

Hi. I'm new to this but not programing, linux, etc. I'm looking to install on the following device, but am afraid to brick it. Is there a way to back up and recover in case it doesn't work? Looking forward to updating the FW for this and being able to control the DNS settings in particular.


This device is very well supported on openwrt. Use the Quectel EC25 modem in case, highest speed not required. The WE826 has a recovery mode, device to be flashed via LAN connection, using standard browser.
Do not worry about backup, you can always flash another image.
BTW: You can buy (much) cheaper directly in China, via alibaba.

He is asking about the WE826-Q and not the WE826-T which has OpenWrt

The WE826-Q is an AP147-010 clone and can run that image except that
there are some problem areas.

First, it has a hardware watchdog monitor that requires a heartbeat on
GPIO 2 or else the router will reboot after a short period.

Second, the 920-usb-chipidea-AR933x-platform-support.patch disables
the USB because the hardware is missing what appears to be some pullups
on pins of the SOC. That patch needs to be changed in order to make the
USB and PCie slot work. ZBT uses Lede 17.01 as their firmware as that
patch came as part of 18.06.

1 Like

Thank you very much for the reply. I truly appreciate it. Can you provide me with the correct link for instructions and downloads? I have no problem flashing devices (Wifi router, Android devices, etc.) just need more details. The reason I'm trying this is because the device uses foreign DNS servers and I'm not really OK with that. And of course the current UI doesn't let me change it. I see the current installation also has a telnet interface as well, but don't have the root/admin password.

The easiest way to change this router is to flash it to a firmware
called ROOter.

This is a project I run that has developed an OpenWrt based firmware
that provides major support for routers using cellular modems.

Your router would use this firmware :

This has all the changes I outlined and has been tested on my and others
WE826-Q and is known to work correctly.

This is the only firmware I know of that supports this router.

Thank you very much. I'll try it soon.

Howdy! I downloaded your build toolkit for OpenWRT 19.07.2 and it appears that AP147 is not a target device in AR7xxx. Am I missing something obvious?