Support for Xiaomi Wifi R3P Pro?


#21

I was under the illusion that the R3P back end ROM was was very similar if not pretty much the same as OpenWRT. I really hope it gets supported as I've bought one now. Its just being used as an access point at the moment as I use pfsense as my primary router at home for the most part.

I guess I could be a tester for one of the devs with my 24hr old router (gulp) :thinking:

It's such a nice well built bit of kit, it would be a shame to see it left idle on this heavily restricted official Xiaomi ROM.


#22

I could help if I had this device. Someone who has - should open it, test GPIOs for leds and buttons.
Flash map seems to be similar to R3G (already supported).


#23

R3G has MT7612EN Wi-Fi chip, and R3P has MT7615N this is the main difference.
Stock firmware is based on old version of Openwrt (12.x) with custom scripts.
I can provide required development/testing. I have experience and tools (uart/ jtag/ direct nand programmer ) and don't afraid to brick the router. The only thing I don't have enough is time. So If somebody have test sources/tree , I will be glad to build/flash (tftp boot) / test


#24

Is that essential? If i can help it i'd rather not as its like 48hrs old lol, but if i have to for the bigger picture I will see what i can do. :scream:


#25

Even with basic router support, its mt7615 radios aren't supported in OpenWrt/ mt76 yet (there are apparently some efforts underway, but it will take a while until that becomes available and usable).


#26

For the people who have graciously offered to test out Alpha-grade code....

No, it shouldn't brick your router. Wifi (obviously) doesn't work. The build is sync'ed to the openwrt "gate" so any brokenness there will also be in this build.

Disclaimer: my R3P is being used by the school I work at, and it's hard to take it offline for private testing... The changes included in this build have been tested (a few months ago), and booted then. Feedback is very welcome.

NB: Read the installation instructions for the Xiaomi "3G" router to understand how to install these bits.

Good luck!


#27

Er. That would be:

(first build was broken... sorry)


#28

For some reason there's no more traffic on this thread, and I seem the the only person spamming it...

I finally got around to taking the R3P offline for some testing. Turns out it was a good idea. As a result there's a new pre-release (below) which has been tested and actually does boot properly and turn on the network and give you a luci login screen. (also fixed the GPIOs and leds)
[ snip ]

Beta release!

the latest bits (below) don't require console access (see the link for installation instructions).

So: install the bits (from ssh) and reboot and you'll get a working openwrt system and luci (etc).

I'm calling it "beta". Now it's safe. Now you can test it.


#29

The latest version doesn't have wifi support, does it? so it compiled without drivers for mt7615 or you have problems with drivers?


#30

@pellmen: No wifi support yet. I've loaded @nossiac's mt7615 kernel module but haven't tested anything further (I'm still working out bugs in the platform support).

Once the platform seems completely sane, I'll test with mt7615 and if all goes well, release an image that includes that module (and other support).


#31

We already a year ago had problems with drivers from @nossiac, you can see it in https://github.com/Nossiac/mtk-openwrt-feeds/issues/26
We had full platform support, i'll try to ask @dissent1 to load his source of working platform to git. Maybe it will help you a little. A lot of people from 4pda are waiting for your release) and a lot of them have uart and can be a tester. Unfortunatly i still don't have uart, but if it doesn't needed to unbrick r3p i can be a tester too.


#32

@pellmen i saw the issue you're referring to (#26) but @nossiac's answer seems to be that the OP should have had 2 eeprom.bin files, hence it looks like operator error.

As for uart and not having it... i think it's a really nice thing to have in general (especially when something goes wrong....) you can use a raspberry pi as well (if you have one of those).

Thanks for the offer to help with platform support... i've already looked at @dissent1's sources (at least the ones he has on github)... I think i'm a little further ahead (and there have been some changes to openwrt's build/platform framework since)... And i'm flattered that the guys at 4pda care for what I'm doing. I anticipate having something really sane (as in push-ready) out in a couple of days.


#33

Hello!
No no, you're not alone (in the dark) but I'm not able to help you alas...
Until your beta doesn't have wifi capabilities, I couldn't test it. But When it will be wifi-able I could test it for you (and for me) very easily.
Have you any idea of when I could enter in your danse ?
Anyway, thank you a lot for all this work!

TTYL


#34

So long as there's a way to roll back to stock firmware if crap hits the fan Im up for testing.

I bought one of them USB 2.0 to TTL UART 6PIN CP2102 module serial converters if needed.


#35

@souk: rolling back is pretty easy even if the crap collides with the fan (even some form of bricking actually)... it's a smart trick the guys who ported the Xiaomi R3G came up with: we keep part of the stock firmware around, so we can put the stock firmware on a usb stick and reset (and hold the reset pin) and it'll go back to the stock firmware.

Having said that, I hope to release another build tonight, so maybe wait until tomorrow :wink:


#36

@Xmal: the wifi chip (7615) isn't natively supported by openwrt, and I haven't ever tested @nossiac's binary modules... so I can't promise anything about the wifi.... obviously I'll do my best.


#37

I've tried to collect all drivers that i know for this moment in this message for our mt7615. maybe it will help you:
1) MT7622_7615_SoftAP_v5.0.2.0_20180430.tar.xz
2) mt76-18.06.2.tar.gz

3) MT7615_LinuxAP_V4.4.2.1_20170829


#38

Thanks for your input Pellmen..:+1:


#39

So, I've tested beta image , and it is working. No wireless as expected. Wired network is working. Kernel version is 4.14.97. I've tried to load nossaic's kernel module with no luck obviously.
So - what we are doing now ?

I've loaded image via TFTP boot (controlling bootloader over uart) - it's working like a charm , fast and reliable


#40

@ilyas - can you add .config to git repository ?