Support for Xiaomi Wifi R3P Pro?

Hello people. In my case, I can fix most issues, but I still have this same wifi problem when I restart the router.

1 Like

The error that I have is this:

MediaTek Nand driver init, version v2.1 Fix AHB virt2phys error

How I can fix it?

Hello my friends.

Why is luci-app-access-control not available to install on R3P Pro?

Can I install straight from GitHub?

opkg install https://github.com/k-szuster/luci-access-control/releases/download/0.4.2-DD/luci-app-access-control_0.4.2_all.ipk

Hi friends,

I am trying to use firewall rules for Parental controls as per https://openwrt.org/docs/guide-user/firewall/fw3_configurations/fw3_parent_controls but it is not working, I am getting the error below.

Warning: Unable to locate ipset utility, disabling ipset support
Warning: Option @rule[9].weekdays must not be a list
Warning: Section @rule[9] (Reject Ludmilla iPhone) skipped due to invalid options
Warning: Option @rule[10].weekdays must not be a list
Warning: Section @rule[10] (Reject Laura iPad) skipped due to invalid options

are all other settings kept? is this the only thing that is not "saved"? if so, this is a new problem i haven't encountered before.

can you send me a full dmesg and logread log output? (use pastebin or something)

see this thread

if you really want to install the package, download it and then install it:

curl -O https://github.com/k-szuster/luci-access-control/releases/download/0.4.2-DD/luci-app-access-control_0.4.2_all.ipk
opkg install luci-app-access-control_0.4.2_all.ipk

(i'm not sure that curl is installed by default. you might need to install it. or wget)

this isn't an error message. it's a rather strange driver initialization message. don't worry about it.

This is what my dmesg says about ubifs:

[   12.363924] UBIFS (ubi0:1): background thread "ubifs_bgt0_1" started, PID 508
[   12.542621] UBIFS (ubi0:1): UBIFS: mounted UBI device 0, volume 1, name "rootfs_data"
[   12.550458] UBIFS (ubi0:1): LEB size: 126976 bytes (124 KiB), min./max. I/O unit sizes: 2048 bytes/2048 bytes
[   12.560351] UBIFS (ubi0:1): FS size: 239349760 bytes (228 MiB, 1885 LEBs), journal size 11935744 bytes (11 MiB, 94 LEBs)
[   12.571189] UBIFS (ubi0:1): reserved for root: 4952683 bytes (4836 KiB)
[   12.577776] UBIFS (ubi0:1): media format: w4/r0 (latest is w5/r0), UUID 4F509D67-7990-4FF1-84EF-915FDF615813, small LPT model
[   12.591131] mount_root: overlay filesystem has not been fully initialized yet
[   12.598948] mount_root: switching to ubifs overlay

I couldn't find anything you mentioned. BTW, I just updated again. Am I correct to only do a

systemupdate http://downloads.openwrt.org/snapshots/targets/ramips/mt7621/openwrt-ramips-mt7621-xiaomi_mir3p-squashfs-sysupgrade.bin

Is there any script or something that will automatically install luci etc after each upgrade?

Thank you all so much for the replies and help.

Hi Ilyas.

Thanks for this information, but I have some other message:

Warning: Option @rule[9].weekdays must not be a list
Warning: Section @rule[9] (Reject Ludmilla iPhone) skipped due to invalid options
Warning: Option @rule[10].weekdays must not be a list
Warning: Section @rule[10] (Reject Laura iPad) skipped due to invalid options

I used this doc you send me.
I have created the firewall rules but do not work, I think is because this error.
After the time I have scheduled the access to internet still works.

Hi,

Are all other settings kept? Yes

is this the only thing that is not "saved"? Yes

Please see the log information below.


@muhammed @Adilson

right. so this is a different bug we're dealing with. for some reason the wifi ends up not being "enabled". you're going to need to check your settings. when wifi is disabled you should see something in /etc/config/wireless to that effect. in general, clicking on the tab for the wifi and clicking 'enable' and then 'save configuration changes' should do the trick.

@adilson

honestly i don't know. i don't think this has anything to do with the R3P.. maybe see if there's a support forum for firewall?

Yes. This is what I have to do every time the router restarts. :frowning:

@adilson

what does /etc/config/wireless look like? (it will also have your wifi password in it, so maybe edit that part before posting it)... but in general, if wifi is disabled it should have something pretty obvious like "enabled = 0" or "disabled" in it)

also, is wifi (wlan0, wlan1) in the bridge? check that (brctl show ... or in the luci interface). it almost certainly is, but i'm having a hard time imagining what could possibly make it do that (there was nothing in the log you sent... maybe it was from too-early boot and there would have been later messages... don't know). channel isn't 'auto' is it? (it shouldn't be)

test with:

uci set wireless.@wifi-device[0].disabled=0; uci commit wireless; wifi

always a problem reset all and reflash with sysupgrade firmware

Hello everyone.
Last year I switched to openwrt 4.14.111. Now I want to upgrade, I downloaded version 4.14.132 from iscilyas and lates official firmware. I tried to upgrade via sysupgrade, but after restarting, the LED lights up yellow, does not even blink. I go to ssh after the update, but there, as before, the kernel version 4.14.111, neither the Internet nor Wi-Fi works. At the same time, returning through sysupgrade back to version 4.14.111 works well. Router is reloaded normally, the LED turns blue, the Internet and Wi-Fi appear.
I was switched to openwrt from a pandora without pdboot. Maybe i need to reflash factory.bin somehow? Or may be i need additionally flash some blocks like: cat kernel1.bin factory.bin | mtd write - firmware

I'm still running @ilyas v4.14.111 build, with uptime >90d without any issues.
Can You give me quick update, how does the upstream OpenWRT (with open drivers) perform against it?
Does the update bring benefits?

Hi Guys!
So being tired of the Xiaomi rom for the R3P I decided to flash the latest snapshot of Openwrt on the router.
After installing LuCi everything seems to work kind of normally, however just like other users reported, the WiFi will not come automatically up after boot. I checked the /etc/config/network and /WiFi and the "disable" options for all the interfaces are set to 0, the only way I have to make the WiFi work after boot is to ssh into the machine and send a ''wifi'' command, that way the SSID starts to be broadcasted correctly and I can use the WiFi as long as the router will not reboot.

Is there anything I can do to make the WiFi work correctly? Thanks a lot!

Do other changes stay after the reboot?

Hi Andrey!
Yes, all the other settings are maintained.
This morning another user of the forum proposed a solution to fix the WiFi issue, basically by disabling the async loading of the WiFi driver. This way I was able to bring WiFi on boot correctly and start using the router :slight_smile:

How to do it? Im with same problem as u.