Support for TP-LINK EX220 device

When will we have support for a test or beta version for the Tp-Link ex220 device, which is identical to the ax23 v1 and a snapshot version was released but without the factory file, just the sysupgrade. If anyone can develop a test version for me

https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=2a0c9cc8cdaa76414993deaff3371dba294638db

Wouldn't there be an easier way, I'm afraid of ruining uboot. Do you have comp create a way to install through Windows and a step by step with commands?

I'm sure the committer only posts the hardest way of installing Openwrt. Not.

There's no such risk, until then, enjoy stock fw.

No, but feel free to create one.

After two days of studying the necessary commands, today I decided to open the router and start installing openwrt. When I opened the router's case, when I came across the board that did not have the pins for connection, my adapter did not come with these pins. I have to wait for a developer to create a factory file for installation from the stock firmware, if anyone is aware and can help

You'll probably find the pot of gold at the end of the rainbow sooner than that.

Is there any technical difficulty in doing so?

Apparently, or it would have been done already.

1 Like

strangely, the ax23, which is really a router in its essence, can be installed via stock, this one cannot, with the dump of the spi memory would I be able to do the installation? I have an acquaintance with an ax23 with openwrt installed

Are the two Openwrt images identical?

If not, then the image won't work, cross flashed.

I don't see any real reason why flashing wouldn't be possible without pins on the PCB.

I really tried everything, even a full dump of a friend's ax23 but I couldn't make it work, I believe that the official launch will take too long for it, how difficult is it to sign openwrt to make it work?

Is there any way to speed this up?

Depends, are you a fast worker ?

I'll be honest with you, I don't even have the parameters to start compiling my openwrt, I'm an enthusiast, you know, I wanted to add openwrt to have a more precise qos, I know that the proposal is for you to do it yourself but I don't have a way to compile

Compiling is the easiest part, and you can do it for free on a cloud host provided by Microsoft, Google, Oracle or Amazon.

I managed to install openwrt, I soldered the pins to it, now that it doesn't activate its full speed and nat offloading, even activating it doesn't seem to make the slightest difference.



I have the EX220 v1.2. Will this snapshot work, or this is only for v1.0 ?

for TP-Link, v1.X usually means v1.0.

1 Like

Worked like a charm :slight_smile:

I created a guide of the whole process to install it.

1 Like

i have an ex220 thats my isp brought it. the uboot from it doesnt work since the wan port? i have to open it and soldering since the board?