Support for TP-LINK EX220 device

flashing isn't usually done via the WAN port.

when I flashed my wr940m v6 it was through the wan port using the tftp. so, the ex220 its only by the serial port?

read the git entry (scroll up) ?

that's why my post said usually, not always.

A developer in question inboxed me with the following message: If you can send me a copy of the EX220's bootloader partition, I might be able to come up with a solution to install openwrt without soldering by finding an exploit in the bootloader's web recovery (similar to this: https://github.com/naf419/tplink_deco_exploits/ 2, if anyone can help I would be grateful, as I no longer have openwrt installed due to it staying in a loop after installing a package and thus leaving me have to go back into stock.

Would you be able to do an openwrt flash dump? My TTL adapter is having problems, but I have the eprom recorder with the clamp;

We have already had the official release of the version for the ex220 device, however without the factory installer, we would really have to have some incentive in this part to make it work without having to open the router to connect the serial cable

Can someone send me a link to the oem firmware image, i.e. one that could be used in the web-recovery mode to revert to stock?

Yes, https://www.mediafire.com/file/lnmrg7bm3pnm8c7/EX220_UP_2023-07-18_09.23.39+0.18.0+2.0.0+v605f.0+Build+230717+Rel.73513n.rar/file

Greetings, when I use the space to interrupt, check that the serial connections are well connected as well as the TTL adapter, a similar error occurred and I had to buy another one, but it worked correctly after purchase.

Hi,
I'm having problems installing OpenWRT 23.05.3 on the TP Link EX220.

I've soldered serial pins to the device, and I've been able to get UBoot to start the initramfs image with OpenWRT 23.05.3 (using the instructions from https://gist.github.com/ro99/77579b1d22fcde9ca72e0180b17bbc9d).

I've been able to download a kernel sysupgrade image to the device from an SCP server, but when I try to run sysupgrade, the image verification fails:

sysupgrade -v /tmp/firmware_image.bin
Fri Mar 22 22:11:12 UTC 2024 upgrade: Image metadata not present
Fri Mar 22 22:11:12 UTC 2024 upgrade: Use sysupgrade -F to override this check when downgrading or flashing to vendor firmware
Image check failed.

I've sourced the sysupgrade image both from https://firmware-selector.openwrt.org/ and https://openwrt.org/toh/tp-link/ex220_v1 but both fail. Is there anything I can do to fix this?

Thanks,
Joost

Do what's suggested ?

I had already tried to run sysupgrade with -F, but then it still doesn't work, the machine reboots after the command concludes but the device still loads the original EX220 firmware by TP Link...