Support for TP-LINK ec230 G1 ver.1

I have an ISP locked tplink c6 I guess is ver 1 from the sticker. I saw that others are supported on the hardware list and I've tried to flash the firmware with the c6 V2 via update and tftp with no luck, any help would be greatly appreciated.

Many thanks Bowen

If that's your ISP's device, they probably won't be happy with you flashing it.

It's a unused device I had lying around after the ISP swapped to ZTE routers, and I live in Thailand I don't think they much care.

There was a similar thread on this device a little over a year ago...

No tech specs on DeviWiki or TechInfoDepot, and still not supported on OpenWrt.

Where did you see a reference to a C6?

I might have been mistaken with the c6 it's just what Google threw at me.ive opened it up and there's no sign of a serial port, SSH is locked out and the main IC seems to be under a sheild with the rest under a heatsink

I don't have a rework station to remove the sheild sadly and there's nothing under the Ali pate on the backside.
After looking further it's not named as a C* just Ac1350.

So from what I can see the board is identical to the c6, the issue being the firmware name I guess, tftp and OEM update fail and I have no idea what I'm doing in the telnet.

I've done a port to this device, EC230-G1 in this pull request, though it is STILL not yet merged.
My branch however is still based on 21.02 if you want to build it.

Maybe you, or somebody motivated enough can rebase it to current master :wink:

p/s: access to UART is required to install OpenWRT, and also mentioned in the pull request (UART Tx would be near the small antenna labeled TP_UART_IN, and UART Rx would be near CPU labeled TP_UART_OUT). Idk how to make it easier, maybe you can find out more

p/p/s: you can pry off the metal shield, it is held by friction.

What is the current status of your work?

Hello @izuannazrin
I followed your Github work, great job thanks allot.
I noticed your suggestion to use TTL in there and I have few questions appreciate if you may answer:
1- how you connected the TTL pins to the board? I mean they are very small :smiley: , perhaps you may send photo :smiley: It is very very small and can't by soldered.
2- Which OpenWRT Firmware to use? Archer C6 ? C50? ..etc which other identical firmware works on this ISP version of router ?
2- Is there a way to flash using TFTP only?
I'm facing issues prompting TFPT to get any output, I used several articles to know which local IP to use as static in IPv4 , there are many: , 0.66 , 0.20 , 0.100 (all from several TP link articles) Also TPlink sometimes point to reset button as WAP button in some routers, which makes trying endless.
May I know for this ISP router TPlink EC230-G1 what is the right server IP for the TFPT to use?

Sadly currently my router is only in loop, power led lights on, then after 5 sec all lights on for 1 sec then they goes off again, power always. No reset working or Network over LAN getting any IP