Support for TL-WR840N(ES) Ver 5.0 (EU)


#223

When you reboot it, the entire configuration sets to default again. But nice try. It can be done properly with refined polish.


#224

@robimarko I restored my device with your dump_prvi.bin and went fine, then I noticed it was not my region so I tried to flash (Web GUI) the last firmware of my region but gave an error. In spite of that, I decided to TFTP that file and now the light has gone.
I have a USB TTL but Putty is not receiving any signal. Is it over?


#225

can you add luci-app-sqm?
thx


#226

No,why did you do that?
Now you messed up calibration for the radio.

Calibration is device specific.

Also,now you gotta use SPI programmer to recover since that dump of original firmware that came on mine v5 has uboot that will brick your device when using it to TFTP recover.

All you had to do was use TFTP to load LEDE TFTP image and then sysupgrade from it.
Now you made a mess


#227

Yes, I know. I screwed it.

The problem was that I wasn't able to restore to stock with any firmware. The only one that worked was your dump but It went to EU region I think. My device is ES (Latin America) which we can find its last firmware here: https://static.tp-link.com/TL-WR840N(ES)_V5_170503.zip

Then, once I restored with yours, I updated to the last EU firmware I found. But in there, there were problems with the "Range Extender" mode that were not in the ES firmware I had first. May be bugs or something. That's why I wanted to go to the original one (which was fine). So, I decided to Sysdowngrade from Web with no luck (some kind of errors were shown). Then, I had the genius idea to TFTP it and that was all for the champion.

Can it be calibrated if I get a similar one? (The store I bought it still has some).
I have a USBJTAG NT, can that do the job? If yes, could you please guide me?

I haven't been able to find specific info. I've never recovered a router through Jtag before, only Serial.

PS: I friend of mine gave me a WR740N which has no lights too. Can that be recovered as well?


#228

Calibration is unique to a specific device, your radio will work even now with calibration from mine.
But it may not be functioning as good as one calibrated to your specific unit.
So buying another one and using that is the same as using my dump you already flashed.

JTAG should be able to do the job, but I have not recovered anything using JTAG and also you would need to first enable JTAG mode by pulling up or down a specific pin on SoC which you can find in a datasheet but most likely is not exposed anywhere on the board.

Simplest way is to get yourself a SPI programmer like CH341A which is like 3-4 USD.
And reflash the SPI flash on the board with my dump or yours if you made one.
It will work then but calibration would not be exactly right,still better than nothing


#229

All right. I understand.
How is one supposed to calibrate routers?
I don't have the data sheet with me, is the ISP flash the one with the 8 pins on the other side of the board in this case? My CH341A is on the way.
Then, just pull it out, write to it, re-solder and that's it right?
Thanks


#230

Calibration is done with really specialized equipment during manufacturing.
So you cant do it at home.

SPI flash should have 25Q32 marking on it.
Yeah,desolder it,flash with flashrom and resolder back


#231

Done, but i dont tested it

https://drive.google.com/open?id=1cQBwnnxFRSq0k-fUstG7ogoYHg9lHTkI

and the ''don't save configs bug'' i think it was not fixed yet


#232

Hi I compiled with luci, and it´s working save changes after reboot, stripped many packages. you got tc shaper control speed by ip, wpa2 eap security etc... but the wifi range it´s really bad.

https://drive.google.com/open?id=1MYJU0euHBEwy57BJ3a8lWnaT4C9t4SWi


#233

any news on wifi driver?


#234

Thanks for this, any stable build with Luci included?

It is possible based on support for another similar 4MB router here https://forum.openwrt.org/t/tp-link-tl-wr841n-d-wa701n-d-wr740n-d-wr741n-d-wr743n-d-wr940n-wr941n-d-ladus-julia-ultra-lite-vpn-builds


#235

Hi the problem is we have only 3.5mb disk space, it needs change partition layout
to gain extra space lets say 300kB, it easy for my put any packge on the router the problem is the wifi driver I have no idea how compile other one with better performance thank you.


#236

under: config wifi-device 'radio0', put this option:
option diversity '0'

It will run much better


#237

Thank you I wil try


#238

Are you using -Os parameter in your compilation? It should give you an image about 200k smaller.

I just compiled minutes ago an 8MB image, this option optimized the result image 600kb smaller. Yours is 4MB, maybe you reach 200~300kb (proportionally thinking..)

It´s worth trying.. :slight_smile:


#239

Thank you for your advice I wil use this parameter in my next try. thank you again


#240

http://lists.infradead.org/pipermail/lede-commits/2018-January/005784.html

Please share if anyone has a working build with Luci for this. Badly needed. :slight_smile:


#241

Thats only 64k increase


#242

Hi, no working yet?