Support for new Archer c50 v3.0

Hello @rgc

Can you tell me how to configure led names and triggers in LUCI GUI?

I simply changed the "LED-Name"s under "System-->LED Configuration" to the values listed:
lan --> c50-v3.green.lan
wan --> c50-v3.green.wlan5g
wlan2g --> c50-v3.orange.wan
wlan5g --> v50-v3.green.wlan2g

Hello @rgc.

I changed the values in system file, it works... Thanks!
Another question: When you revert to original firmware, which file you used?
You flashed using tftp , luci gui or using mtd method in putty?

Regards,
Juliano

For my very first flash I used tftp with the "special" Image
"openwrt-ramips-mt76x8-tplink_c50-v3-squashfs-tftp-recovery.bin"
Later on I only used LUCI.
I never went back to the original firmware.

Claus

Thank you, that worked fine on my C50 BR version.

Hey,

I'm quite new to LEDE/OpenWRT etc. I managed to etablish Heiz' Version to my Archer C50 v3.

My 5G-Wifi is working fine (better than it used to with original firmware). However, my 2.4-Wifi does not work correctly. It doesn't send any signal, if I choose Auto Channel. Even after choosing a Channel, I cannot manage to establish a connection to the router.

Can anyone help me out?

Thanks!

@Heinz Hi, i'm kinda new in Openwrt and LEDE.
i tried to install your firmware but now my archer c50 doesn't work, it won't give me the wifi and i can't get access to the router through the ip address. All the led lights keep blinking at the same time, my router has stopped responding despite of resetting many times, it never changes.
Please help me out,
Thanks

I am new here with open-wrt and lede project. May I ask, why there are two files in every build? A sysupgrade and a recovery. Why? Do I need to flash both of them?

I have an Archer C50 V3 router. I guess mine is a faulty unit because I can't detect 5GHz band. Just to find out if this a firmware issue, I installed the latest build from @Heinz. But the issue remains. So, I just wanted to revert to stock firmware. I tried for several times through tftp. Please watch the video.
If I flash the 5th build again. It boots, but it's not stable enough. How can I get back to stock firmware, any Idea anyone?

Video here.

1 Like

Same here, i'm still looking for solutions. I can't get access to the router, it's bootlooping.

Hi friend, I was having the same problem as you. I was able to get back the firmware by following this tutorial. The site is in Portuguese:

Sorry for my english, I used the google translator.

Thanks buddy, it worked. Thanks a ton!!!!!

Those of you, who can't get back to stock firmware, please download this firmware and flash this. This is EU firmware. It worked for me.

Hello,

I have an AC50 V3 TP-Link with last LEDE firmware. Thats works well, but after a few hours Wifi stops working.

In logs, the error below presents when a station connects in router:
STA XX:XX:XX:XX:XX:XX IEEE 802.11: did not acknowledge authentication response

After hours, the wifi stops to connect (BSSID showing, but don´t connect) and no logs are reported anymore.

I think the problem is in mt76 opensource driver from mt7628 chip. Finding on internet, there is an another driver (called mtk). I´ll try now.

Any suggestions how to get my 2.4G-WiFi working? (Post Mar 24)
Otherwise I'll have to get back to stock firmware...

Thx

Back to stock now...

After installed mtk driver (Nossiac), thw wifi 2.4Ghz works very well.

I think its possible only download the compiled .ko driver from Nossiac webpage: http://nossiac.com/download/mtk-wifi-ko/

in ssh:
lsmod
ifdown wlan0
rmmod mt7603e
rmmod mt76x2
rmmod mt76
modprobe mt7628.ko (downloaded)
ifconfig ra0 up

Install mtk-luci-plugin to config via www.

Does anyone know, how many bytes do I need to cut from OEM firmware to roll back? To keep OEM firmware up to date.

Hello, I have attempted to flash the "build 5" version @Heinz provided, using tftp as specified in the post. However, when it boots it only shows the power LED, and the LAN LED if I connect it to my computer. Tftp is working correctly, as I am able to roll back to factory firmware.

So what am I doing wrong? What is the current status of the project?

My router is Archer C50 ver. 3 (EU), just fyi.

Thanks in advance.

Hi. i not familiar with linux and dont understand how to download the driver. i tried the ssh stuff but stuck. Your help is much appreciated.

hello, I've tried this firmware, and it's been working a week very well in a data center, but I have a problem the kernel that is installed is 4.9.77 and the packages are for the 4.14.4, so it pulls error constantly of kernel invalid, is there a way to solve this? At this moment I just want the openvpn to work well, but the tun module (kmod-tun) is for kernel 4.14.4 and for this reason it does not work on my computer, some solution to these problems?