Support for new Archer c50 v3.0

Hello guys

I would like to know if the new TpLink Archer C50 v3.0 supports the LEDE / OpenWrt firmware ? It´s very similar to Archer C50 v1.0 (MT7628A vs MT7620A)

Thanks

1 Like

For reference: Hardware specs v1 vs. v3:
https://wikidevi.com/wiki/TP-LINK_Archer_C50_v1.x
https://wikidevi.com/wiki/TP-LINK_Archer_C50_v3.x

1 Like

Is anyone working on LEDE firmware for v3.0 Archer c50 ?

Thanks

Hopefully not, because the v2 was a disaster. This entire model should be thrown out.

But while version 2 is equipped with qualcomm chip, version 1 and 3 are with mediatek chips, with small enhancement between them

I am also interested in LEDE firmware for this device, maybe there are plans to prepare it?

Same.. I am also looking for lede for version 3 as it is pretty much a version 1 without USB.

Hope someones working on it.

@Holyyshek @Vikapone Its not pretty much as v1 as it uses a lot simpler and cheaper SoC.
Not to mention that mt76 driver is not really good for MT7628

I am working on it,but since I do not have access to one it will be tricky.
Thankfully GPL sources are available.

I got most of the stuff prepared in my source tree but I need bootlog to check if flash layout is correct

HI. I Try create test image for this router:
Check my commit:
https://github.com/lede-project/source/commit/e8f9eb7cca196bc7476dd1be1b87552b435bdeb2

Image file:

Please check first MAC address on WAN/LAN/WLAN/WLAN5G interfaces then use firmware upgrade with *factory.bin file.
If This file not working, use recovery image in recovery mode.

Thank You for the support.

Hey I tried all the three versions with TFTP. Non of them work.
I am unable to TFTP the original firmware too.
Thank for the effort tho. Maybe the next revision works.

Sysupgrade work only when You update firmware from OpenWrt/LEDE.
Recovery TFTP must work or brick Your device. Check Your TFTP server and disable firewall when use recovery mode.
I dont known why factory image is not accepted.

Try again recovery mode:
Server IP 192.168.0.66
rename ****-tftp-recovery.bin file to tp_recovery.bin

Flash instruction in on this commit message:
https://github.com/lede-project/source/commit/24043a0d2e01b9843c0dc529205b3b0bc7ecbbf9#diff-5950da1c595ed78b01a4050cfb0f5dc6

1 Like

Hey Heinz thanks for the quick support. Initially I flashed my device from stock firmware to openwrt factory.. The device stopped responding after that.

I then upload the recovery firmware using tftp(after renaming it tp_recovery). The upload was successful.
Still not working. Thanks again for the quick revert.

Does the EU version have a different open wrt flash file?

Hi @Holyyshek,

Bootloop? Or any led is powered? Did You try turn on WiFi using WiFi key?

Here is OEM recovery file:

1 Like

Hey Heinz
Thanks for the quick response.
The stock firmware recovery file given in the link provided by you does work. Thanks.

After recovering stock firmware I again tried flashing :

  1. openwrt-ramips-mt76x8-c50-v3-squashfs-factory.bin to the router using GUI of the stock firmware.
    Result: the router stopped responding with all lights on the routers blinking at regular interval.

I recovered the firmware to stock firmware using TFTP again.
2) Then I flashed the file openwrt-ramips-mt76x8-c50-v3-squashfs-factory.bin to router using TFTP after renaming the file to tp_recovery
Result: Same- the router stopped responding with all lights on the routers blinking at regular interval.

I recovered the firmware to stock firmware using TFTP again.
3) Then I flashed the file openwrt-ramips-mt76x8-c50-v3-squashfs-tftp-recovery.bin to router using TFTP after renaming the file to tp_recovery
Result: only one light is continuously lit(depending on the port in which the Lan is connected) and again no response on both LAN and WIFI.Even if the LAN wire is removed the light stays on.

On the stock firmware router model number is : -
Hardware version:Archer C50 v3 00000001
Firmware version:0.9.1 0.4 v0079.0 Build 170608 Rel.35472n(4555)

On the box my model number is : Archer C50(EU) Ver:3.0

Thank you so much for the help!

You are using a file downloaded from the tplink site?
You only change the name? or cut something in the file?

No Using the file in the link provided by you. Using TFTP.

I only changed the name. (rename)

New firmware:

Use only tftp-sysupgrade

new build: https://tplinkforum.pl/t/archer-c50v3-openwrt/9953/3

1 Like