Support for MikroTik RBSXTR

This thread was opened as I would like to switch KIT-LTE devices to OpenWrt.
The KIT-LTE is similar to the Mikrotik wAP LTE kit, treated in another thread on the forum, but has a different form factor.
@dehrmann : The KIT-LTE has two SIM card slots!
KIT-LTE has a circular PCB shape with QCA9531 and 25Q128JV SPI memory. Its intention is to be outside, somewhere in good sight of the cellular network.
The QCA's Wifi capabilities have not been implemented on the PCB. The PCB carries on its backside a set of antennas for different LTE bands in a MIMO fashion. The PCB provides for some filtering of antenna signals before being applied to the R11e-LTE mini PCI express card.
There are 5 LEDS that can be used to indicate e.g. signal strength and that are visible from the outside. Near the reset button there are 3 more LEDS with names 'POWER', 'PoE', and 'LTE'.
RouterOS says:
model: RBSXTR
firmware-type: qca9531L

Based on Marvell's PXA 1802 chipset ( 88MP1802-BNR2 + 88RF858-BRE2) and RF amplifiers by Skyworks (77916-11 + 77643-11) .

Is this the one?

Also,can you Jailbraik it to get the model from cmdline?

Tried Jailbreak on a yet unupdated KIT-LTE (RouterOS 6.41.3) and the program claims success, says I'm set as there are no binaries, the kit reboots and then nothing. Can only revive the kit by repowering while holding reset and letting reset go while the LED is flashing. And, yes, that is the one.

Can you try updating your RouterOS as it should work with never versions also.
You should be able to get board identifier from running initramfs version of OpenWrt also

Tried to load initramfs some days agoe and the tftp server reports uploading it but then nothing. But this may be due to the 25Q128JV not being recognized as discussed in the other thread. Where do I find an image that knows the memory this board uses ?

You cant,but I can build it for you as I already have the patch pushed upstream and backported to 4.9 for wAP R.

Will try jailbreak again after upgrade to 6.42.5 which is the latest stable RouterOS.
Would like of course to try tftp-ing your patched image.

I have a image building.
Its like I read somewhere that that jailbreak does not work if the device only has one port.

Here are the images:

After the upgrade the kit is not responding anymore on its primary ethernet port. The earlier jailbreak must have broken something. The RouterOS is still accessible via the second ethernet port. I did a reset to factory settings but that has not revived the primary ethernet port :frowning:
When tftp-ing should I use the .elf image or the .bin one ?

You can fully reset it to stock using Netinstall.
Just export the RouterOS licence first.

You need the elf image for OpenWrt

Have never used Netinstall before. Is there a Linux version of it or does it run under Wine?

Mikrotik does not really like Linux so there are no Linux tools.
It does run under Linux but I dont think that using it to recover will work.

Since you want to get OpenWrt working you can ignore issues with RouterOS and get the board identifier to figure out what GPIOs are used from GPL

Yeah, will experiment with your .elf image first before firing up here a seldom used Win7 machine ....

Have used Netinstall to get back to fresh start position. The problem with the primary ethernet connection most likely was a cable problem. The cable has to make an akward bend to be stuck into that slot and apparently some contact was bad.
In any case have tried your 'openwrt-ar71xx-mikrotik-vmlinux-initramfs-lzma.elf'
but OpenWrt does not come up on (assume that's the address that should rerspond ??)

Have you tried both ports?
Since the board wont be recognized it should only have eth0 configured.

Too bad that jailbreaking did not work so we can at least get board identifier to get serial working

The tool refuses to work when the OS is later than 6.41rc56. So managed to reinstall 6.41.3, the ex-works firmware for this unit, using Netinstall.
When I run the tool it claims success, albeit '(likely)', but I cannot login as user 'devel'.

Weird,another user used the same tool to jailbreak wAP R last week.
There is only one SXT LTE in GPL,but that one is there from time when it was the old AR7242 with soldered modem.

So,I doubt they share the identifier

Just guessing and looking at the board there is the letter R added for this unit: SXTR-LTE.

About the tool, should it work from virgin RouterOS or does one have to create user devel first from the regular API?

Well,there is no SXTR at all in GPL.
No idea about the devel user