Support for Mikrotik Hap AC2

You don't need any custom distro to build OpenWrt.

Those are git errors, you need to fix them manually with git mergetool and the help of o a program like kdiff3.

hello i had a strange problem installing openwrt on my hap ac2. i downloaded the firmware from @geminis3 and i successfully installed on my ac2 but i needed to revert to router os so i did with net install. Now im unable to install openwrt again, i cant flash the sysupgrade image from GUI or ssh (it boots fine on ram), when i upgrade the usr led start flashing and the it reboot to nothing. Is there any fix for this problem?


Have you upgraded routerboard firmware (bootloader) to 7.X?, currently OpenWrt can only be installed with 6.X firmware.

You can downgrade firmware by downgrading ROS first and then clicking on upgrade routerboard firmware.

Thanks for your reply! I read about this fix. I never installed v7.x bootloader or ROS to this device thats what confusing me i got back from openwrt with 6.48 netinstall. I also tried downgrading to previous os and bootloader with no success.

Ps. sorry for my English.


1 Like

Have you tried setting routerboard settings to try Ethernet once then nand? The PXE server on Ether1 (your PC) should pick it up automatically once you reboot the unit. Also try disabling any antivirus or firewall on the PC.

Thanks i will try this and report back. I netboot by holding reset button on boot before.

1 Like

I tried everything with no success. Maybe its something wrong about my hardware. But how it worked before...


Download ac2-r15387-sqm

Thanks to @robimarko and happy New Year to all :wink:


Scheduled tasks

0 22 * * * reboot
10 22 * * * echo performance > /sys/devices/system/cpu/cpufreq/policy0/scaling_governor
20 22 * * * /sbin/wifi down
15 6 * * * /sbin/wifi up

does not work on my latest build, coz - Uptime 2d 20h 45m 41s

A post was split to a new topic: Can not install udpspeeder

False report at my previous post. After manual reboot scheduled task (crontab) is work fine for me.

Performance should be better IMHO according to official stats:

I can get about 950mbps downstream on a gigabit connection with RouterOS and fasttrack on.

With fast track off I only get 450mbps both ways.

Is software flow offloading only working on upstream data?

Hi @geminis3

i tried your build and i am confused

what is the use of ETH1 ??
to be more specific, why ETH1 is exposed as standalone ?
now it hardcoded to Vlan2 and from Luci there is no way to someone make eth1.200 or multiple eth1.xx interface
because it is not real interface

it is wrong to assume that everibody have flat WAN connection
(plug and play, dhcp, no vlans)

what's wrong with only ETH0, like mt7621 and from there user could choose what to do with ports ?

I would like to request if someone could please share the latest firmware build?
or if someone with the skills and time to maybe create a community build like the RPi4 community build, that would be great... ie: Rpi4 < $(community_build)

just wanted to say that the latest build from, hAP-ac2-cleanup branch is working great! (wifi speed 5GHz too). Installed via dhcp/tftp on eth0 and sysupgrade on a lan port. Several sysupgrades since then.

If someone is interested, my latest build with luci and some minor stuff I need:

(seems I have to rebase something or so for packages: " The installed version of package kernel is not compatible, require 5.4.93-1-b0624da2… while 5.4.91-1-3b9ce087… is installed.")

1 Like

@dlakelan i am really interested in openwrt for this router i have version r15387 for now do you think openwrt 21.X.X will be supported soon? thank you

@anybody, the blink of leds on 100 Mbit/s connection is work for you or not?
With 1Gb connection all leds works fine, but with 100 Mbit/s connection leds is not work for me.

I have one 1Gb connection from my provider (eth1) and one 1Gb connection for my PC (eth2)
eth3 and eth4 is have 100 Mbit/s connection only and they are not flash at hAP ac^2. Need to fix it.



1 Like

I'm not on fiber but in vdsl2 all work led blink too ... If i can help

just a simple question

@flamber how many can you climb with sqm enabled please? thank you

I have a 'new style' hAP ac^2.
My Android TV and Enigma2 satellite receiver is have 100 Mbit/s connection and these leds are no light/no blink :pensive:

1 Like

Led (5) works for me on damaged CAT5e cable and Lenovo Ideapad 510 (100Mbps card) with stock firmware.

May by your TV still using WiFi connection (my android TV with cable attached, does not change network from wifi to cable)