Support for D-Link DIR-620 rev F1?

Telnet is working. But can't access to any folder/file
"Read-only file system"

EDIT: How i can launch this script?

Just call sh /path/to/script.

You need to keep an eye on the LEDs while it runs and write down the GPIO numbers when you see a LED change.

Oh im 30 minutes google"d and successfully copied with netcat (busybox nc) the script but...

$ sh
Usage: [wait time] [gpio start] [gpio end]
Example: 3s 0 1
leave gpio range blank to test all GPIOs.
: not foundne 7: echo line 9: syntax error: unexpected word (expecting "do")

One of folders where the write rule is working...

EDIT: Fixed (windows to unix converted) file

$ sh
Usage: [wait time] [gpio start] [gpio end]
Example: 3s 0 1
leave gpio range blank to test all GPIOs.

cat: can't open '/sys/class/gpio/gpiochip*/base': No such file or directory
cat: can't open '/sys/class/gpio/gpiochip*/ngpio': No such file or directory
[: -1: unknown operand

Now this
EDIT: I think im can't access the gpio without root :frowning:

Dumping all flash is may be useful? (I can try to dump and share the file(s))
I found a universal method.

It's certainly useful to have them as a backup. I really recommend you hook up serial, since once you'll start testing you won't be able to recover if you flash a non-working image e.g.

The device is not a too pity for me. I still want to experiment and test. If something goes wrong, then life of this device does not matter much :slight_smile:
But I will make a backup, I will help you than I CAN.
Another words: I want to try with the some risks.

UPD: i tried to backup all "mtd"s but this:
dd if=/dev/mtd6 of=mtd6.bin
Hangs the device :frowning:

$ cat proc/mtd
dev:    size   erasesize  name
mtd0: 00800000 00010000 "ALL"
mtd1: 00030000 00010000 "Bootloader"
mtd2: 00010000 00010000 "Config"
mtd3: 00010000 00010000 "Factory"
mtd4: 00120000 00010000 "Kernel"
mtd5: 00690000 00010000 "RootFS"
mtd6: 007b0000 00010000 "Linux"
$ mkdir /tmp/www
$ cd /tmp/www/
$ touch ../httpd.conf
$ killall httpd
$ dd if=/dev/mtd0 of=mtd0.bin
16384+0 records in
16384+0 records out
$ dd if=/dev/mtd1 of=mtd1.bin
384+0 records in
384+0 records out
$ dd if=/dev/mtd2 of=mtd2.bin
128+0 records in
128+0 records out
$ dd if=/dev/mtd3 of=mtd3.bin
128+0 records in
128+0 records out
$ dd if=/dev/mtd4 of=mtd4.bin
2304+0 records in
2304+0 records out
$ dd if=/dev/mtd5 of=mtd5.bin
13440+0 records in
13440+0 records out
$ dd if=/dev/mtd6 of=mtd6.bin

And nothing...

But the continuous of this instruction (maybe helpful for many people)
httpd -c ../httpd.conf

just 404, but this in browser for download parts:

1 Like

Alright! Could you share a dump of the "Factory" partition? And list the MAC addresses you see on the device? You can PM them if you don't want to share them in public.

Edit: I checked the Keenetic Omni II DTS and the flash layout exactly matches the one for your DIR-620 F1 (the Asus RT-N14U has double the flash). So it's a starting point. Once you have OpenWrt loaded you can go about testing.

1 Like

This is good news for me :slight_smile:

I was afraid that it would be possible to do what I do not know how.
I'm more software than hardware. XD

Thanks for the dump and the MACs, the addresses usually increment between the wired & wireless interfaces (as yours do). I can now grep through the dump to see where they are located and supposed to be read from the flash upon boot.

Can you describe the LED colours per LED? E.g. WAN green, WiFi blue, ...

All is green as I remember. Im seen only green.
And in google images also all green on photos.

1 Like

I have uploaded an image here, based on master with LuCI. There's an initramfs as well, it's recommended to use that first, but since there are already images for other devices known to be working, you can probably just try and flash the sysupgrade image from the web interface. The RT-N14U doesn't have a factory image either, so if that works on the DIR-620 F1 then you won't need that either.

If it works, please report what's working and what not (which LEDs e.g., if wireless works, ...) and if the MAC addresses are still the same as on stock.

1 Like

I think im can try. IDK how to flash DIR-620. SysUpgrade maybe work with updater in web-interface?
EDIT: Please say simplicity how me to flash? :smiley:
Initramfs or sysupgrade?
Today im simply stupid. Sorry for this XD (memetic situation, oh)

Another words: Which image to flash In web-interface?

Sysupgrade. And run the GPIO script like explained earlier, if the LEDs don't work as they should, so we can fix that.

Thanks a lot. I will try now.

That's not working.

Have any ideas?
This is sysupgrade image.

No. Do you have a link to flashing instructions for the RT-N14U image on your device? If it's in Russian, please translate.

This is need to flash with tftp, like this.

Well, in that case you should try TFTP as well. Do you have a link to instructions on how to flash the Keenetic Omni II or RT-N14U images on the DIR-620 F1 specifically?

Can you check here?
You may use a google-translator for page
Just search "F1" revision, because thread for all revs
I will help if you can't find the info. But please try to find. Thanks :slight_smile:

Sorry man, I won't go dig through a 500 page thread in Russian for the proverbial needle in a haystack. I put a few posts through Google Translate; they talk about installation through the bootloader (so TFTP; even about replacing the bootloader with BREED). So you can try to get the device in TFTP mode and see if there's still some kind of check there. That's how people seem to install the RT-N14U sysupgrade image, and that image not have any custom headers.

I don't have the background to start piecing together the header the web interface requires to accept the image. The images for the older revisions (A1, D1) all have initramfs images and sysupgrade ones, not a factory one. Going by the OpenWrt wiki entry for the DIR-620 series, it looks like those two just accepted the vanilla OpenWrt sysupgrade images. You could try upgrading your firmware to the most recent (2.5.22?) and see if that works, but TFTP seems the best way to try.