Stuck after flashing ZTE MF283+

Hi everyone!

Due to shortage of time I have not replied recently.
I apologize for that.

First of all I wish you all happy holidays with all your merits to be pursued to even higher levels.

I want to thank everyone so far for trying to help me.

I have done some reading up and decided that I want to try to install the snapshot with attended sys-upgrade..... thinking that it might be a tailored solution to my problem.
The initial problem that is.

However, I have done some research about connecting 2 routers which was my purpose in the first place.
After that I am more confused than ever.

I will send a private message to one of the OpenWrt forum members who has been most engaged so far in this matter (frequently posting) and after that I might open another topic.

I will update my findings and results here and due time when the FINAL solution has arrived I will close of this topic as "SOLVED".

Once again, many thanks to everyone being involved as well as the author of the firmware. I am aware we all lack the time but even so, I so much appreciate all of your time and efforts.

Stay safe and a happy new year!!!

1 Like

From the description in the private message, you just plug the OpenWrt downstream of the other device. As long as there's not an IP conflict (i.e. both networks can't be - you're good!

Hope this helps.

(Feel free to make a public post if more is needed.)

Thanks Ileachii.

Just dropping a line so the topic does not close off automatically until I have tried the suggested solution.

Next few days I will have time to work on the routers.

While at that, you might want to test out 22.03.3 release, maybe the kernel bug which caused your initial problems was fixed. Just be sure to have a config backup :wink:
I need to upgrade my fleet to 22.03 finally, but I lack time for that currently.

Hi Leo,

Unfortunately I have not yet configured the router.
Thought of trying the attended system upgrade with a snaphot.

But before getting to that point I need to discover how to make 2 separate private networks, more specifically how to set up the interfaces in OpenWrt.

Tomorrow I will start another topic on that and once I have the networks running I will make a config backup and then try updating it and closing this topic off.

1 Like

Okay, time for a little update....

With the help of @pavelgl & @psherman I have successfully created 2 private networks and finally connected to the internet.

I have installed luci-app-attendedsysupgrade:

And where I expected to be able to directly to 22.03.3 release I hit the wall with:

It gives me the choice of upgrading to 21.02.5 release.
Maybe after upgrading to the 21.02.5 release, a new option of upgrading to 22.03.3 release would become available?

Why did I not try to upgrade yet?

Because I have installed OpenVPN too and I have to smooth out some things first, like DNS leak that I am experiencing. Once I have got the OpenVPN working to my liking, I will back up all my configurations and then finally go over to trying to upgrade to the latest official release available.

And if it can not be done with attended sysupgrade option, then I will find another way of doing it.

Anyway, I will keep you posted and post the final solution so this topic can be closed off as "SOLVED".

I will be back as soon as I have figured out how to get rid off the DNS leak I am experiencing.

When you’re ready….

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

Thank you Peter.

I will do accordingly.

Just dropping a line for everyone to know that I am busy with fixing the DNS leak before going over to backing up the configurations and finally trying to upgrade to the latest stable release of OpenWrt.

Be safe and sound everyone.

Little bit later I will be posting an update on newly acquired findings.

It's been a while but I have finally found some time to perform additional tests so hereby I am presenting the results.

I am tagging @Leo-PL to make sure you check this most recent post.
I am also tagging the developers @lynxis and @981213 so you get a notification regarding this issue as Leo has tagged you before in this thread.

Hopefully the bug preventing the upgrade to the 22.03 release of OpenWrt will be taken care of.

I did not have much time on hands either hence that's why it took so long but eventually I did the necessary.......

Bunny Hopping

...... hopping around versions.....

Here are my findings:

Firstly I tried to upgrade the firmware by using the "attended sysupgrade" that I installed as a package.

When trying to upgrade, the only available version for me was the 21.02.5 as I was on the 21.02.4 version at the time. Going to 21.02.5 succeeded without any hick-ups or problems.

However, when I wanted to go to the next upgrade (22.03.3) after performing the search for firmware upgrade, no more upgrades from within the "attended sysupgrade" were available as can be seen here:

The very reason that there are no more recent firmware versions to upgrade, is actually indicating that the 22.03 release can not successfully be flashed onto this particular router or otherwise the newer releases would be available.

I decided to go to the flash operations section and backed up my settings configuration:

Then I downloaded the latest Snapshot image from the "Firmware Selector" on the OpenWrt website:

And uploaded it:

Then I performed the flashing:

After that I tried to access the router via Putty so that I could install the LuCI interface with "opkg update & opkg install luci" commands but to no avail as I have hit the wall once more.

After restarting the router, only the "Unknown Network" can be found and there is no way to connect to it:

Trying to SSH into the router after Flashing With the Snapshot I

Trying to SSH into the router after Flashing With the Snapshot II

Just to be sure I have also tried SSH-ing into the router with the old stock IP address

Trying to SSH into the router after Flashing With the Snapshot III

Trying to SSH into the router after Flashing With the Snapshot IV

I have also performed ping tests:

After not being successful with upgrading the firmware from within LuCI, I have tried installing the same "snapshot" using the tftpd server and the results were identical to the ones described above.

Then I tried installing several other releases:

  • openwrt-35596fce8ffc-ramips-rt305x-zte_mf283plus-squashfs-sysupgrade
  1. Latest Stable Release 22.03.3 - DOES NOT WORK
  • openwrt-22.03.3-ramips-rt305x-zte_mf283plus-squashfs-sysupgrade
  1. OpenWrt 22.03.0 Stable Release – DOES NOT WORK
  • openwrt-22.03.0-rc1-ramips-rt305x-zte_mf283plus-squashfs-sysupgrade
  1. OpenWrt 22.03.01-rc - DOES NOT WORK
  • openwrt-22.03.0-rc1-ramips-rt305x-zte_mf283plus-squashfs-sysupgrade
  • openwrt-21.02.5-ramips-rt305x-zte_mf283plus-squashfs-sysupgrade

Seemingly the firmware version 21.02.5, is the last stable release working firmware on this particular router. There must be some major bug which prevents flashing the 22.03 + versions to this router.

After flashing the router with the 21.02.5 version I was able to successfully SSH into it via Putty:

So hereby I would like to kindly request the developers to have a look at the issue and possibly fix it so that the newer stable 22.03 release can be used on the ZTE MF283+ router as well.

Please keep me posted on the findings/ progress/ results as the topic automatically closes off within 10 days if no new posts have been published. I would like to close off the topic as "solved" but for that I need the help of you developers to try pinpoint and solve the problem which is making the upgrade to 22.03 impossible.

When you flash from 21 to 22, do not try to keep settings. There is probably a DSA conversion involved which will prevent the Ethernet ports from working if you keep settings.

If it's not that, someone with the device will need to hook up serial to see why it does not work.

1 Like

Thank you for the information Mike.
I was not aware of that.

However, after trying to upgrade from within LuCI I have flashed the router several times with different releases of firmware using the TFTPD server and like stated above none of them worked except for the 21.02 releases which all work.
I was even able to upload the saved back-up configuration files and everything is working like a charm in the 21.02.5 release.

I am afraid that this is a debugging issue (maybe some drivers), best to be addressed by the developers with expertise.


No, there is no DSA conversion ongoing on rt305x subtarget. I think there is still a bug present in the kernel which prevents correct operation of Ethernet interface - which can also be caused by something like missing IRQ connection, a log of which I managed to capture in #63. I need to find some to take a look at that, or try to bisect the code to find the breaking change.

Thank you Leo.

Just dropping by to keep the thread alive.

  • (It's your thread)
  • It's not solved.

No need to spam your own thread.

As far as I know the thread/ topic closes itself off if no one leaves any message within 10 days. I already had to send a message to reactivate it once.
I am checking the thread for new answers/ posts whenever I have got time and I try to make sure to keep it alive until it gets solved. I do not `spam´ it but leave the message once in a while, like I explained so that it does not close off automatically.

I am not sure where are you heading with these remarks laced with a frustrated undertone.

Like I stated previously, I am new here to the forum, new to networking and these kind of half answers/ remarks with a frustrated undertone do not solve anything.

If you are already wanting to help then it would be much more appreciative and effective if you did it in clear words and concise explanations then introducing riddles like:

Whatever is that supposed to mean....

If there is a way to keep the thread open without anyone on it being active then just say so. If my messages give you such a grief I would rather have you skip them.

From what I can tell, this thread is not set to autolock... that is typically done only when a thread is marked as solved, or if it is set to auto-close by a moderator. AFAIK, it will always say that at the bottom of the thread. For example, see the bottom of this thread (still open as of March 1, 2023).

1 Like

No frustration, it was pretty clear - no need to make off topic posts (i.e. the community guidelines).

Feel free to PM me if that's difficult. I can send the link.

It means (generally) you control when the thread is closed, so again, no need to spam it (i.e. forcing everyone who's followong to get a notification saying you're trying to keep an open thread open...? :person_shrugging: ).

It comes to email inboxes if followed. Was just a kind suggestion. If you want, feel free.

I'm still looking and thinking on how to assist, as I'm sure others are.