Still having terrible wifi performance- WRT1900acs

I've had a previous post regarding my terrible wifi performance and a user gave me the suggestion to change channels. With that solution only slightly improving my wifi, I'm still searching for answers on what is wrong with my wifi. I get 400 down/ 12 up over Ethernet but on wifi standing only 1 foot away from the antenna I barely get 40 mbps, it gets worse as I further and further away. I do have multiple neighbors nearby and they're all over the wifi channels but I've chosen the least congested one. I've read somewhere to try changing some settings in etc/config/wireless but I'm slightly a novice at this stuff. Any other suggestions? Thanks for any help in advance

The WiFi issues with the WRT AC Series is environment specific due to Marvell's closed source WiFi driver. To make a long story short, Linksys didn't get Marvell on board before releasing the WRT AC Series, of which is why a stable WiFi driver wasn't released on OpenWrt for a year after the 1900AC V1's release, and is why there is still no opensource driver available for the two radios.

  • What make and model wifi card are you using, and does it have the most up to date drivers installed?

  • If using 5gHz, the channel should be in the upper 150's (157 is a great one if living in the US).

  • If you're using the 2.4gHz network, are you using a wireless N (max 450mbit/s) card or a G [max 54mbit/scard?

.
In regards to LAN, you should be getting speeds above 400mbit/s down over ethernet, as it should be close to 120MB/s (~950mbit/s)... unless this is your speed over WAN.

.
Regardless of the answers to the above, it's always a good idea to have LuCI open to the Wireless page, then adjust each antenna until you find the position with the highest dB signal

  • This is clearly not the problem if you're standing 1ft away and are getting sub-par speeds, but is something that should be done by anyone with a router which has external antennas.

What make and model wifi card are you using, and does it have the most up to date drivers installed?

  • I'm running the speedtest with my 2012 macbook which has everything updated, drivers , etc.

If using 5gHz, the channel should be in the upper 150’s (157 is a great one if living in the US).

  • 5ghz channel is disabled, 2.4 is only channel running. WMM mode is enabled and is set to N mode.

Transmit power is auto but i've set it to 30 before with no change. Channel is set to 3. Channel width is 20 due to the fact I have multiple neighbors nearby and wouldn't benefit me in this situation.

Over LAN I do get over 400 mbit/s , roughly around 460 and upload is always 12.

With no exaggeration standing only 1 foot away from the router I can only get 40 down and the 12 up.

Could it be my antennas? Possibly a bad flash of the firmware? There's a possibility that my wifi drivers could be old on the router but I don't know how to check. At this point i'm frustrated since I spent so much money on the dang router.

So your ethernet speed is for WAN, not LAN.

Please post your WiFi config (/etc/config/wireless), removing passwords and MACs.

Why is 5gHz disabled... does your laptop not have a 5gHz card?

  • Also, is your WiFi card in your macbook G, N, or AC?

.
As to your 2.4gHz, it sounds like either a misconfiguration of settings, or it's due to the Macbook. Apple products for some reason cause performance issues in some environments and I don't recall it ever being fully understood why.

  • You'll need to try connecting from a non-apple device (preferably 2 additional devices) to rule it out.

  • Also, the channel width needs to be set to 40mHz to take advantage of N.

  • Your channel number should be 1, 6, or 11 if in the US.

    • When it comes to channels, you'll need to try each until you find one with optimal speed. It's likely the channel number it's set to [3] is the issue.
  • Transmit power has no effect if you're close to the router... it's to increase the signal range.

Check driver and firmware:

cat /sys/kernel/debug/ieee80211/phy0/mwlwifi/info

image

I disabled the 5Ghz because it was even worse, speeds barely reach 40 mbps as well. I attempted to change channels on that band as well but no success.

As for the 2.4 band i've attempted speed tests over android tablets/phones and still get the same speed(about 40 down.) I've chosen channel 3 because every other channel option such as 1,6,11 is cluttered and 3 is the best speeds I could get. I just attempted all 3 of those recommended channels on 40 mhz and the speed dropped down to 5 down but still got 12 up.

image

After cat /sys/kernel/debug/ieee80211/phy0/mwlwifi/info

Guess you are running stable, with really old mwlwifi, if so load pre-compiled

So SSH into the router then run

wget https://github.com/eduperez/mwlwifi_LEDE/releases/download/af210f0/kmod-mwlwifi_4.4.92.10.3.4.0-20171129-af210f0-9321_arm_cortex-a9_vfpv3.ipk

Then run

opkg install kmod-mwlwifi_4.4.92.10.3.4.0-20171129-af210f0-9321_arm_cortex-a9_vfpv3.ipk

Just making sure I have it all right, i'm a novice at this stuff..

Please don't post screenshots of terminal output, but the actual output via copying/pasting within code blocks [ticks]

There's no way possible you would have worse performance on the 5gHz network, which means the issues are based around misconfiguring each network. 5gHz channels need to be manually set for optimal speeds [157 in the US is a great channel], and 44 is a channel that should never be used for a 5gHz radio (the higher the channel, the better, and 5gHz should always be channels above 100).

  • Encryption needs to be psk2+ccmp

  • Also, remove the following from your /etc/config/wireless:

    • Everything from option noscan through option ar

I'm not sure what you mean by the actual output. Isn't that the config wireless?

When enabling 5Ghz and setting channel to 157 I get 75 mbps which actually is an improvement, but shouldn't the speeds be higher? Changing to 40 mHz on the 2.4 band did not help, I lost about 10 mbit/s.

I've removed everything from option noscan through option AR, Also my 2.4 band is set to psk2+ccmp already as well..

Try the following:

  • Any example of output only, i.e. copy and paste the text from the file itself.

.
/etc/config/wireless

#

    ##::[[---  LEDE Wireless Config  ---]]::##

####################################################
              ##----- Radio 0 -----##
####################################################

    # Options #
#---------------------------------------------------
config wifi-device 'radio0'
    option  type            'mac80211'
    option  hwmode          '11a'
    option  channel         157
    option  path            'soc/soc:pcie-controller/pci0000:00/0000:00:01.0/0000:01:00.0'
    option  htmode          'VHT80'
    option  country         'US'
    option  distance        50
    option  txpower         20

    # Access Point (LAN) #
#---------------------------------------------------
config wifi-iface
    option  device          'radio0'
    option  mode            'ap'
    option  macaddr         'xx:xx:xx:xx:xx:xx'
    option  network         'lan'
    option  ssid            '<ssid>'
    option  encryption      'psk2+ccmp'
    option  key             '<password>'
    option  macfilter       'deny'
    option  hidden          0

####################################################
              ##----- Radio 1 -----##
####################################################

    # Options #
#---------------------------------------------------
config wifi-device 'radio1'
    option  type            'mac80211'
    option  hwmode          '11g'
    option  channel         6
    option  path            'soc/soc:pcie-controller/pci0000:00/0000:00:02.0/0000:02:00.0'
    option  htmode          'HT40'
    option  country         'US'
    option  txpower         17

    # Access Point (LAN) #
#---------------------------------------------------
config wifi-iface
    option  device          'radio1'
    option  mode            'ap'
    option  macaddr         'xx:xx:xx:xx:xx:xx'
    option  network         'lan'
    option  ssid            '<ssid>'
    option  encryption      'psk2+ccmp'
    option  key             '<password>'
    option  macfilter       'deny'
    option  hidden          0

.
If speeds do not improve to where they should be for LAN traffic (5gHz: ~863mbit/s ; 2.4gHz ~300mbit/s - 450mbit/s [depends upon the N generation on your MacBook's WiFi card]), I'd recommend utilizing iperf to determine your LAN speeds between your router and PC over LAN (WAN will depend on ISP, but if you have a 500mbit plan, it should be saturating the 2.4gHz network if your device is the only device connected to WiFi).

  • It's best to troubleshoot WiFi speed issues via LAN, not WAN, as you know what the constant speed should be between your PC and the router on LAN.

  • You will likely need to try different channels, especially if you do not reside within the US, as each country has laws regarding channel widths (for example some European countries limit the 5gHz spectrum to channels 100 and below only).

  • Also, as mentioned before, you'll want to adjust your antennas while logged into LuCI (navigating to Network -> Wireless) in order to position the antennas in a way which gets the highest dB signal

    • Signal should be -65dB and higher (Note the " - " in front of the number, so the lower the dB number, the higher the signal)

Oh I see what you mean, my apologies for the mistake. Connecting my macbook via ethernet shows speeds of 440 down/ 12 up. Multiple devices in my house are connected via wifi so i'm not sure. Channels 1,6,11 are very saturated in my area so that is why I have chosen 3. Doing a scan of the networks in my area is shown below. Any other suggestions please? At this point i'm ripping my hair out

image

I've stated the same thing over and over again at this point, so I'd recommend going back and re-reading, then once you've done what's been suggested, come back and let us know what you've discovered.

Given how crowded the 2.4 band is, this is exactly what I would expect.

by switching to using4 40Mhz, you are now trying to use 2/3 of the band
yourself, so there is only one channel someone else can be on that doesn't
interfere with you.

If there are other people using the band, your system will try to wait for dead
air before transmitting, so this will significantly slow you down.

David Lang

…and exactly that is probably most of your problem, even with 'just' 20 MHz channels you only have 3 independent channels available. In an environment where channel 1, 6 and 11 are congested, channel 3 is not free and full-on overlap is better than partial overlap (because partial overlap is just noise to your AP, but with full on overlap, the AP can try to cooperate and avoid collissions better).

Thank you for the information. I'm guessing there isn't anything I could do then? Then again I could put foil on my walls and block the neighbors dang wifi. Hah..hahah.. i'm sad

This is precisely why if one has the ability to use 5gHz, they should, with the 2.4gHz network left for legacy devices which do not have AC cards.

  • Additionally, if @Admir1387 has a B or G wireless device on their network, the 2.4gHz network becomes worthless for normal browsing since it's required to use the max speed of the oldest technological standard connected.

.
@Admir1387's issue is a refusal to try what's been suggested, of which will fix their issue of misconfigured wireless networks.

  • I'm baffled why one would ask for help then refuse to do the troubleshooting involved to determine and fix their issue.

I'm baffled why you'd suggest I haven't attempted to troubleshoot the problem at all. I came to this forum three times for any other suggestions on improving the speed. I stated multiple times that the 2.4 band is cluttered and that the 5 band is off since I get even worse speeds.

I've suggested numerous times how to go about troubleshooting and fixing your issue, repeating the same thing in multiple posts, so best of luck to you =]