WRT1900ACS v2 WiFi to LAN slow

I have WRT1900ACS v2 running 19.07.2 r10947-65030d81f3

Problem: WiFi (laptop) to LAN (NAS) speed is low (~250mbps) while router reports that laptop is running on 1300mbps WiFi.

Measured with iperf:
WiFi (laptop) <-> LAN (NAS): ~250mbps
LAN (laptop) <-> LAN (NAS): ~900mbps
WiFi (laptop) <-> WAN (another pc): ~250mbps
LAN (laptop) <-> WAN (another pc): ~900mbps

Since I thought that this problem is caused by slow vlan/bridge/routing nonsense I installed iperf on router and ran the tests. Results are promising:
WiFi (laptop) <-> Router: ~550mbps
LAN (laptop) <-> Router: ~700mbps (iperf is CPU bound on router, apparently)

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/soc:pcie/pci0000:00/0000:00:01.0/0000:01:00.0'
	option htmode 'VHT80'
	option country 'US'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option macaddr '16:91:82:c6:95:04'
	option key 'XXX'
	option ssid '-WiFi-Z-5G'
	option encryption 'psk2+ccmp'

config wifi-device 'radio1'
	option type 'mac80211'
	option hwmode '11g'
	option path 'soc/soc:pcie/pci0000:00/0000:00:02.0/0000:02:00.0'
	option htmode 'HT20'
	option country 'US'
	option channel 'auto'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option macaddr '16:91:82:c6:95:03'
	option key 'XXX'
	option encryption 'psk2'
	option ssid '-WiFi-Z'
	option network 'lan'

/etc/config/network

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd35:f904:862b::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option ip6assign '60'
	option ipaddr '192.168.0.1'
	option ifname 'eth0.1'

config interface 'wan'
	option ifname 'eth1.2'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0 1 2 3 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '4 6t'

I have the same problem on stock firmware as well, WiFi speeds are just a bit better (~280), but that's it.

What am I missing? Is it supposed to be that slow?

I am considering to buy this one and would like to know what is the performance for 2.4GHz WiFi? Can you share your results?

Try a different channel. In particular, disable legacy 802.11b rates, and then you can choose DFS-enabled channels (52-140). They tend to be mostly empty, so there will be less interference and more speed. The caveat is that they initially appear as non-working, because the radio needs to scan for radars. It takes one minute, just wait and don't panic. After that, the AP interface magically becomes enabled.

Tested 2.4GHz:
Laptop: MacBook Pro (15-inch, 2019), distance 1 meter
Router advertises 216 mpbs

Command, ran 5 times: iperf -c 192.168.0.111 -p 5201 -t 60

Stock firmware, default settings:
WiFi (laptop) <-> LAN (NAS): 76 ± 1 mbps

OpenWRT 19.07.2, default settings:
WiFi (laptop) <-> LAN (NAS): 65 ± 3 mbps

I heard that drivers are weird

UPDATE:
Switched back to stock firmware, re-tested, got results that are same as OpenWRT:
WiFi (laptop) <-> LAN (NAS): 65 ± 3 mbps

Performance testing is weird ¯_(ツ)_/¯

disable legacy 802.11b rates

done

DFS-enabled channels (52-140)

didn't work for me, but I have pretty much clear channels in 5GHz, so not a big deal

But still it doesn't explain why WiFi to LAN is slow when WiFi to router is fast...

Have you checked whether both of the cores are being used for transferring data? What is the performance for Samba?

I want to use it for NAS with a USB 3.0 HDD. If the performance is, as you say, then there is no point in purchasing it because right now my TD-W8980 gives me around 40-50 mbps on Samba with HH5A doing the main routing.

Edit (My results):

C:\Users\pakah\Downloads\iperf-3.1.3-win64>iperf3 -c 192.168.1.254 -t 60 -b 0 -i 5
Connecting to host 192.168.1.254, port 5201
[  4] local 192.168.1.238 port 57512 connected to 192.168.1.254 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-5.00   sec  22.6 MBytes  37.9 Mbits/sec
[  4]   5.00-10.01  sec  34.5 MBytes  57.8 Mbits/sec
[  4]  10.01-15.01  sec  29.5 MBytes  49.5 Mbits/sec
[  4]  15.01-20.01  sec  29.0 MBytes  48.7 Mbits/sec
[  4]  20.01-25.00  sec  28.2 MBytes  47.5 Mbits/sec
[  4]  25.00-30.00  sec  39.8 MBytes  66.7 Mbits/sec
[  4]  30.00-35.00  sec  32.0 MBytes  53.7 Mbits/sec
[  4]  35.00-40.00  sec  37.4 MBytes  62.7 Mbits/sec
[  4]  40.00-45.00  sec  34.4 MBytes  57.6 Mbits/sec
[  4]  45.00-50.00  sec  45.1 MBytes  75.8 Mbits/sec
[  4]  50.00-55.00  sec  38.4 MBytes  64.4 Mbits/sec
[  4]  55.00-60.00  sec  38.4 MBytes  64.4 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-60.00  sec   409 MBytes  57.2 Mbits/sec                  sender
[  4]   0.00-60.00  sec   409 MBytes  57.2 Mbits/sec                  receiver

iperf Done.

C:\Users\pakah\Downloads\iperf-3.1.3-win64>iperf3 -c 192.168.1.254 -t 60 -b 0 -i 5
Connecting to host 192.168.1.254, port 5201
[  4] local 192.168.1.238 port 57515 connected to 192.168.1.254 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-5.01   sec  41.4 MBytes  69.2 Mbits/sec
[  4]   5.01-10.00  sec  33.1 MBytes  55.7 Mbits/sec
[  4]  10.00-15.01  sec  36.9 MBytes  61.8 Mbits/sec
[  4]  15.01-20.01  sec  29.8 MBytes  49.9 Mbits/sec
[  4]  20.01-25.01  sec  39.8 MBytes  66.7 Mbits/sec
[  4]  25.01-30.01  sec  31.9 MBytes  53.5 Mbits/sec
[  4]  30.01-35.01  sec  35.6 MBytes  59.8 Mbits/sec
[  4]  35.01-40.01  sec  28.6 MBytes  48.0 Mbits/sec
[  4]  40.01-45.02  sec  30.9 MBytes  51.7 Mbits/sec
[  4]  45.02-50.01  sec  30.4 MBytes  51.1 Mbits/sec
[  4]  50.01-55.00  sec  32.2 MBytes  54.2 Mbits/sec
[  4]  55.00-60.02  sec  31.6 MBytes  52.9 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-60.02  sec   402 MBytes  56.2 Mbits/sec                  sender
[  4]   0.00-60.02  sec   402 MBytes  56.2 Mbits/sec                  receiver

iperf Done.

C:\Users\pakah\Downloads\iperf-3.1.3-win64>iperf3 -c 192.168.1.254 -t 60 -b 0 -i 5 -R
Connecting to host 192.168.1.254, port 5201
Reverse mode, remote host 192.168.1.254 is sending
[  4] local 192.168.1.238 port 57517 connected to 192.168.1.254 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-5.00   sec  37.1 MBytes  62.3 Mbits/sec
[  4]   5.00-10.00  sec  46.9 MBytes  78.7 Mbits/sec
[  4]  10.00-15.01  sec  41.9 MBytes  70.2 Mbits/sec
[  4]  15.01-20.00  sec  44.3 MBytes  74.6 Mbits/sec
[  4]  20.00-25.00  sec  38.5 MBytes  64.5 Mbits/sec
[  4]  25.00-30.00  sec  37.4 MBytes  62.7 Mbits/sec
[  4]  30.00-35.00  sec  40.9 MBytes  68.6 Mbits/sec
[  4]  35.00-40.00  sec  40.0 MBytes  67.1 Mbits/sec
[  4]  40.00-45.00  sec  42.3 MBytes  71.0 Mbits/sec
[  4]  45.00-50.00  sec  37.8 MBytes  63.5 Mbits/sec
[  4]  50.00-55.00  sec  39.0 MBytes  65.4 Mbits/sec
[  4]  55.00-60.00  sec  40.3 MBytes  67.6 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-60.00  sec   487 MBytes  68.1 Mbits/sec    2             sender
[  4]   0.00-60.00  sec   487 MBytes  68.1 Mbits/sec                  receiver

iperf Done.

C:\Users\pakah\Downloads\iperf-3.1.3-win64>iperf3 -c 192.168.1.254 -t 60 -b 0 -i 5 -R
Connecting to host 192.168.1.254, port 5201
Reverse mode, remote host 192.168.1.254 is sending
[  4] local 192.168.1.238 port 57520 connected to 192.168.1.254 port 5201
[ ID] Interval           Transfer     Bandwidth
[  4]   0.00-5.00   sec  44.3 MBytes  74.3 Mbits/sec
[  4]   5.00-10.00  sec  45.5 MBytes  76.3 Mbits/sec
[  4]  10.00-15.00  sec  48.7 MBytes  81.8 Mbits/sec
[  4]  15.00-20.00  sec  39.3 MBytes  65.9 Mbits/sec
[  4]  20.00-25.00  sec  41.6 MBytes  69.8 Mbits/sec
[  4]  25.00-30.00  sec  41.9 MBytes  70.2 Mbits/sec
[  4]  30.00-35.00  sec  44.1 MBytes  74.1 Mbits/sec
[  4]  35.00-40.00  sec  38.7 MBytes  64.9 Mbits/sec
[  4]  40.00-45.00  sec  37.7 MBytes  63.3 Mbits/sec
[  4]  45.00-50.00  sec  32.6 MBytes  54.8 Mbits/sec
[  4]  50.00-55.00  sec  43.7 MBytes  73.4 Mbits/sec
[  4]  55.00-60.01  sec  35.4 MBytes  59.2 Mbits/sec
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bandwidth       Retr
[  4]   0.00-60.01  sec   494 MBytes  69.0 Mbits/sec    2             sender
[  4]   0.00-60.01  sec   494 MBytes  69.0 Mbits/sec                  receiver

iperf Done.

My setup is as follows:
HH5A (ADSL2) --> (LAN) TD-W8980
|>> (WiFi) Laptop

So it sums up:
Laptop DL: 68~69 mbps
Laptop UL: 56~57 mbps

I agree, I don't think that you will see much improvement in 2.4GHz.
5GHz – for sure there will be an improvement.

I actually think I may see improvement for Samba. Right now I am getting around 15 mbps UL and 50 mbps DL for Samba because of the ntfs-3g package requiring much CPU for read/write operations on the NTFS drive. If the CPU were powerful enough, as it is for WRT1900ACS, the Samba read/write may actually happen with better speeds. So in case of 2.4GHz it will be at the maximum of WiFi speed (whatever that may be) and 5GHz may also have better speeds up to the maximum of USB interface maybe.

See also this thread for samba speedup tips. Ignore the packet steering advice, it is specific to BT HomeHub.

Guys, thanks for derailing the conversation about my problem :stuck_out_tongue:

That is because I have read here about this router having low WiFi speeds. Even though it has a good CPU and RAM, WiFi speeds are not that good and I'm not sure if you can improve it further. But it is possible that WiFi uses only one core (?).

Did you ever figure this out? I'm running the same WRT1900ACS/LEDE build setup. 5ghz wifi client connection shows 250mbps-ish at best. Luci radio bitrate shows 650mbps. In either case, nowhere near the 1300mbps advertised.

I used wifi-analyzer and there's no 5ghz radio interference. It sounds like your connection speeds are much better. Any advice/tweaks on how to get closer to 1300mbps? I read something about a Marvell driver update. Haven't tried that yet.