Static route forwarding not working [Solved]

Dear guys,
I'm struggling with routing configurations and OpenWrt following the docs found on https://openwrt.org/docs/guide-user/network/routedclient#using_routing.
Here is my network topology (it's not a full diagram)

Now, my goal is to be able to reach every PC on the subnet 192.168.101.0/24 with any PC on the subnet 192.168.0.0/24 and vice-versa.

The main problem is that OpenWrt seem not been able to forward packets from different networks.

This is my network configuration (in OpenWrt):

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fdd1:9b54:5700::/48'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option delegate '0'
        option ipaddr '192.168.101.254'

config device 'lan_eth0_dev'
        option name 'eth0'
        option macaddr '98:da:c4:84:b6:04'

config interface 'wwan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.0.249'

And here, firewall:


config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'
        option network 'lan'
        option mtu_fix '1'

config include
        option path '/etc/firewall.user'

config zone
        option name 'TrustedWAN'
        option network 'wwan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option mtu_fix '1'
        option forward 'ACCEPT'

config forwarding
        option dest 'lan'
        option src 'TrustedWAN'

config forwarding
        option dest 'TrustedWAN'
        option src 'lan'

config nat
        option target 'ACCEPT'
        option src 'lan'
        option enabled '0'

config nat
        option target 'ACCEPT'
        option src 'TrustedWAN'
        option enabled '0'

config rule
        option dest '*'
        list proto 'all'
        option target 'ACCEPT'
        option src '*'

Routing table of PC A:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         _gateway        0.0.0.0         UG    0      0        0 ens160
172.17.0.0      0.0.0.0         255.255.0.0     U     0      0        0 docker0
172.18.0.0      0.0.0.0         255.255.0.0     U     0      0        0 br-0acb1fa784c4
192.168.0.0     0.0.0.0         255.255.255.0   U     0      0        0 ens160
192.168.2.0     192.168.3.2     255.255.255.0   UG    0      0        0 tap0
192.168.3.0     0.0.0.0         255.255.255.0   U     0      0        0 tap0
192.168.101.0   192.168.0.249   255.255.255.0   UG    1      0        0 ens160

Routing table of OpenWrt

Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.0.0     *               255.255.255.0   U     0      0        0 wlan0
192.168.101.0   *               255.255.255.0   U     0      0        0 br-lan

Test done until now:
Ping from PC A to OpenWrt -> OK
Ping from OpenWrt to PC B -> OK
Ping from PC A to PC B -> Not working
Traceroute from PC A to PC B ->

1?: [LOCALHOST]                      pmtu 1500
 1:  192.168.0.249                                         6.378ms
 1:  192.168.0.249                                         2.353ms
 2:  no reply
 3:  no reply
 4:  no reply
...
30:  no reply
     Too many hops: pmtu 1500
     Resume: pmtu 1500

Please, can someone suggest something?

Quick question: what's the default gw on B?
Ping packets may be arriving from A but replies from B might be lost

1 Like

Oh dear... It's embarassing... I spend the whole morning on this problem... I was quite sure that the PC has DHCP active but it has not. The default gw was setted to 192.168.0.254 cause that machine was in building A yesterday...

Thanks for your suggestion... it solved my day...

1 Like

You're welcome :slight_smile:
(no worries: been there, done that)

Please see how to mark the topic as solved

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.