Ssh: Connection to root@openwrt.lan: 22 finished:

After a reset I cannot log into the shell with Putty.
It gives me this error:

ssh: Connection to root@openwrt.lan:22 exited:

Snapshot just installed, so you can also delete everything and re-install it. If the problem is in the operating system.

Yes, the issue is your operating system or ssh app. You need to clear the previous ssh key.

I use Putty the shell shh and W10. Do you know how to do it?

What openwrt version, and try removing old keys.

This is the snapshot
how do you remove old keys?

I tried this but it didn't work

Are you sure that you cannot login? In the screenshot I can see that you are logging into OpenWrt and then you are trying to run the command ssh root@openwrt.lan mkdir -p /tmp/luci-offline


@trendy spotted it... @Kenzo - the command you are running makes no sense. You are already connected to the router via ssh and it appears to be working even when you issue a strange command. What you are seeing is the ssh session that you've attempted to start (while already ssh'd into the router) with an argument that doesn't belong there, so ssh (on the router) is bailing out, as it should. everything seems to be working properly.

1 Like

Thanks for your help first ..
Of course! I log in without password and with "root"

The string should be correct as per the guide to install Luci offline

So I create a folder as reported by the guide :

those commands would be run from the terminal on your computer without explicitly ssh'ing in first. The first line is telling your computer to send the mkdir command over ssh to the router. The second line copies the file from the computer to the router using scp, the third line tells the computer to send the installation commands again via ssh. If you're going to use those commands, you would do this without starting an ssh session to the router.

1 Like

I had already done this job as described in the guide to install Luci offline .

But after an update I didn't have the GUI anymore so I reset the Repeter and I wanted to repeat the job.
But now it doesn't work anymore...

Otherwise what method could I use to transfer and install the packages?

What is the problem exactly?
I understand you are trying to install Luci on snapshot. Do you have downloaded on your pc the necessary packages? It would be easier to connect OpenWrt to the internet and run the opkg update; opkg install luci rather than what you are struggling with.


The packets are all ready for transfer from the PC to the Router ...

The problem is that the repeter only has a wired lan and the antennas are off..

So for the transfer can I use, as I have already done, WinSCP then use opkg to install?

Yes, you can upload with winscp and then opkg install.

It works, at least the first one is gone! :grinning:

Be careful... you have made a directory called /temp/luci-offline -- this is not what the guide said to do. It specifies /tmp/luci-offline -- the difference is really subtle, but important. It is /tmp/ not /temp/, and this matters because /tmp/ is RAM based storage vs flash based storage for the directory you actually created. These ipk package files should be copied to RAM and installed from there -- after the package is installed, the actual ipk can be deleted... when saved in RAM, this happens essentially automatically when you reboot, and it also ensures that the package file itself won't consume valuable flash storage space while you are trying to install the packages, potentially leading to a condition where the flash storage is completely full.

So... delete the files in /temp/ and copy them again to /tmp/

1 Like

in fact at the end of the procedure there was no space to install other optional packages from the GUI. Then LuCi worked badly

So I deleted everything with this string found in the forum:

mtd -r erase rootfs_data

After the reboot the ssh console worked correctly:

So I have installed the packs for LuCi again.

Now LUCI works fine but this error appears on the login page, after complete installation

opkg update
opkg install luci

Apart from this "aesthetic" problem everything seems to be working good.

So me introduce myself: I speak very little and cannot write in English.
I installed OpenWrt for the first time on a Netger WNR3500L and it still works also with latest 21.02.1 excellent.

Where I live, here in Germany, we have a single router and I have also seen up to 50 devices connected ...
A few months ago I bought this Tp-link RE455 Repeter with the Lan Port to create a private network with the Netger compared to the shared Router in my building.

The problem is that the Netgear is very old and I wanted something faster to transfer data locally.

Now thanks to OpenWrt I have transformed a normal repeter into a travel router.

Some clarification on snapshot releases:
I have installed the factory snapshot do I have to install the update? Or to update how about the stable release from opkg?

This is not how you should be deleting files (it should have been a simple Linux rm command). You probably broke something else in the process.

I’d recommend that you flash the firmware again and perform the luci installation again.

1 Like

Is there any way to load the configuration backup? so I would have the external connection and install LuCi from server...

1 Like