[Solved]WRT3200ACM 2.4ghz not working

I have recently installed lede on a wrt3200acm, but recently after fiddling with the wifi settings the 2.4ghz wifi stopped working and now the system and kernel log is now filled with

ieee80211 phy1: buffer is NULL for tx done ring

if i run iw list this is returned

Im avoiding updating the wifi driver for now as this seems like a configuration issue, but im a bit lost

You can restore the default wifi configuration by renaming the /etc/config/wireless file and then executing the wifi command.


Nah, its still in Mode unknown and is still saying Wireless is disabled or not associated and the kernel log error is still there

Ok, found the issue, it was that LED bug in the driver

What version of LEDE and the mwlwifi drivers are you using? My LEDs work perfectly...

It was that bug that caused something with the wifi to crash when you tried to control them using the LED Configuration to customise their behaviour

LEDE Reboot 17.01.4
The the drivers that come with that

Ah, that ol'chestnut :wink: