Davidc502- wrt1200ac wrt1900acx wrt3200acm wrt32x builds

Sometimes they returns...
I meet the old bug again in latest releases, before it was fixed somethere around 8000th.

The bug is there are limited connectivity between clients in different wifi networks (i mean between 2.4 and 5). Both Samba and most of local games can't see stations in other wifi network, but all of them see all in LAN.
Looks like some kind of "isolation" enabled between them.

I don't sure is it package drop or broadcast drop, will investinate deeper this weekend, but meanwhile... Did anyone have some hints/suggestions about it?

PS: It's a release problem, because i didn't change anything in my lan/wifi/firewall configuration last year.

use this solution if you see warning from web browser like this

I'm having a problem with dnscrypt-proxy v2 and my pppoe reconnect cron job. I've set up a cron job (System > Scheduled Tasks) to reconnect my pppoe session at a specific time (my ISP has 24h disconnect) and most of the time I loose access to the internet (DNS server not responding) after the reconnect.
If I go to System > Startup and restart the dnscrypt-proxy service everything it's fine again.

So I wonder if I could set up another cronjob to restart dnscrypt-proxy after the ifup wan command.
Can you guys please help me with that? Currently I'm using "0 8 * * * ifup wan" but I don't know what's the command to restart the dnscrypt-proxy service after the reconnect.

Thanks in advance.

To restart dnscrypt-proxy version 2 is... /etc/init.d/dnscrypt-proxy restart

1 Like

Better way is using procd with wan as service trigger.

1 Like

Hi David, tremendous work on this. Look like old bug resurface in latest build for ACM3200

@see [Solved]WRT3200ACM 2.4ghz not working

error is gone after remove all led config and must restart router for issue to go away.

once reboot, i added setting back for non-wps and non wlan led/interface and no problem now

anyone know how to stop the gmpproxy[6320]: No interfaces found for source spam in system log?

If it isn't going to be used then it should be okay to just uninstall - igmpproxy

There are also these commands --

root@dc502wrt:~# /etc/init.d/igmpproxy -h
Syntax: /etc/init.d/igmpproxy [command]

Available commands:
start Start the service
stop Stop the service
restart Restart the service
reload Reload configuration files (or restart if service does not implement reload)
enable Enable service autostart
disable Disable service autostart

1 Like

Thanks i have disabled it for now, not sure what igmpproxy is used for if its for IPV_TV then i don't use that at all, thanks for your reply.

1 Like

I tried flashing the latest firmware for OpenWrt Rango wrt3200ACM and the checksum are not matching up. is there something I am doing wrong?

File Name
sha 256
Release Date
2019-08-09 12:58

and I get this

Flash Firmware - Verify

The flash image was uploaded. Below is the checksum and file size listed, compare them with the original file to ensure data integrity.
Click "Proceed" below to start the flash procedure.

MD5: 24cf2e8abb33d24e53e283082cef9b69
SHA256: 180d5e0e21a2693af6fa39dd99d946f2e586dadff02b07f48c2d96cb42bab7b5
Size: 18.45 MB
Configuration files will be kept

Thanks for posting this. It might be the site is pulling the wrong sha256sum. I will check it out and report back.

Well, I just downloaded the .bin file for the 3200acm, and the sha256sum checks out as it matches the sum on the website.

Did you try downloading again and checking the sum? It could be you had a bad download which I would think is quite rare for a file that size. Speaking from experience I have to check all of my Cisco downloads of images 2GB or larger because 30% of the time they will be bad. Crazy in this day and age but absolutely happens.

davidc502@Ryzen-3900x:~/Downloads$ sha256sum ./openwrt-mvebu-cortexa9-linksys_wrt3200acm-squashfs-sysupgrade.bin 
362d40d6fc91550b39e2b4e3f637868f36c90ccfd9b723a82309621b1d9c4d0f  ./openwrt-mvebu-cortexa9-linksys_wrt3200acm-squashfs-sysupgrade.bin

@solidus1983 , bug report for your theme: In my installation, when using your theme, it shows no data in the luci-statistics ( Setup ) page . The other themes do show the data. Everything works fine with collectd, it's just a displaying issue:

Also, the ADBlock page does the same... no way to "Enable" it even... and Watchat, and Wake on Lan ... maybe it's something with my configuration?

Have you cleared the browser cache? also you don't state browser so i can't even go on a hunt to see what the issue is.

Clearing the cache worked ( it was Chrome ) ! Thanks.

Why did the cache caused that?

Because it does for some reason, with each new build of the theme its always best to clean the cache anyways.

I will be requiring some help sorting the theme bugs out anyways as i have managed to fix on issue only to make 10 more.

Some times i think it would be handy to just restart the theme from scratch to be honest but will even require help for that as well, because i am still learning.

I fix the bug with client isolation between different wifi networks.
The issue was after some update, broadcast address was set to blank at br-lan interface.
Setting it to X.X.X.255 solves this.

1 Like

Looks like mwlwifi doesn't work with mac80211 5.3-rc4. I made a bug report in the hope it's fixable without changes to mwlwifi.


1 Like