[SOLVED] WRT1900AC Bricked?

Hello there,

Recently I installed the latest OpenWrt firmware (18.06.2 squashfs sysupgrade) onto my router, not keeping the settings. The previous firmware being OpenWrt Attitude Adjustment 19.02 I believe. I made sure the checksums matched and now I'm unable to access the web interface or the internet. I'm not sure whether it's bricked or not, or what I should do next.

The router still turns on, with a flashing power led. When trying to access the web interface, I briefly get a black screen with a luci link and after a few seconds I get redirected to 192.168.2.1/cgi-bin/luci, which is unavailable.

The LAN still works as I'm able to RDP to another computer on the same network. Pinging the router does not work, also trying to SSH using Putty does not work either. Trying to hard reset or failsafe using the reset button on the back of the router does not seem to do anything either.

I'm at a loss, any help would be appreciated!

(sorry if this is the wrong section for this kind of problem)

Attitude Adjustment is pretty old version 12.09.

Your router has dual flash layout so you could roll back to the secondary image if you think something went wrong during flash.

If you use static addresses in the LAN, that is not a surprise. Most likely the switch still works and you can communicate with other hosts in the LAN. Are you able to acquire IP address from DHCP? Since you didn't keep the old settings the default IP for Openwrt is 192.168.1.1. So if you use static IPs you'll need to change them to that address space to be able to communicate with the router.

Power LED should be on steady or it isn't properly booted. It should flash during booting then come on steady. If it flashes constantly that is likely the bootloader waiting for TFTP recovery.

The address should be 192.168.1.1. Clear your browser cache so it doesn't use any old stored redirect. Also connect only your one PC to the router when first setting up.

Thanks for the replies!

The power led is constantly flashing. Trying to switch to the alternate firmware by turning on and off the power switch a couple of times does not work. Connecting/pinging/SSH to 192.168.1.1 does not work either.

So the only option is to open the thing up and use a serial connection I guess?
I don't have a USB to TTL cable though, can this be done with a Raspberry Pi 3B+ instead?

What address does your PC have?
Is it static or DHCP?

Also according to instructions you need to power on-off the device 3 times and then power it on to boot the secondary firmware.

When putting it to DHCP I get this with ipconfig:

Ethernet adapter Local Area Connection:

Connection-specific DNS Suffix . :
Link-local IPv6 Address . . . . . : fe80::bc7e:7519:f5a4:f279%12
Autoconfiguration IPv4 Address. . : 169.254.242.121
Subnet Mask . . . . . . . . . . . : 255.255.0.0
Default Gateway . . . . . . . . . :

Also I've tried turning it on and off 3 times.

This is the IP that Windows auto assign to the interface when DHCP fails. So you don't get any IP from the router.
Better connect console to see what is going on in there.

Trying to switch to the alternate firmware by turning on and off the power switch a couple of times does not work.
Also I've tried turning it on and off 3 times.

Sorry to be pedantic, but just to make sure, you should turn it off and on 3 times and then on the 4th time let it boot, so off/on...off/on...off/on...off/boot.

Naturally not, as like trendy says, your PC does not have a proper IP address, but just an unroutable link-local DHCP fallback address. You should set a fixed IP like 192.168.1.4 to your PC.

After that you should try entering the OpenWrt failsafe mode. See wiki.
https://openwrt.org/docs/guide-user/troubleshooting/failsafe_and_factory_reset#entering_failsafe_mode

And you should test with another browser, as the "get redirected to ..." sounds like browser cache problems, like mk24 already said.

Read also the exact advice about the "3 times power-off" trick. You need to shutdown the router's power in the early boot process, but it still needs a few seconds to start the proper boot process first.
https://openwrt.org/toh/linksys/linksys_wrt1900ac#debricking
(Read the "Power Switch" part)

It is pretty hard to totally brick WRT1900AC thanks to the dual firmware thing, so the alternate firmware should work (once you get there).

Ps. the router has been supported only since 15.05, so you definitely did not have 12.09 there.

Well, I'm not getting there because the 3 times power off trick doesn't work no matter how many times I read that page and try.

I'm not exactly sure which version was installed previously, I do remember in the status page was something with 19.02 (not 12.09) and it being attitude adjustment. Whether that was the actual version of the firmware remains unclear to me but I don't think its relevant anyhow.

Regarding failsafe mode, the power led turns on for a second and then starts flashing indefinitely. I don't think it even gets to the point of other led 'flashing modes'. Pressing 'a button', assuming the reset button, does not change anything.

Having a dynamic or static IP does not seem to change anything either.

sniff the wire to see if it is attempting tftp?

How would I go about doing that without a serial cable?

You can sniff the wire with wireshark, or similar tool. This is a long shot, just to see if the device is doing anything, as it sounds like uboot may have an issue; if so you will need a serial connection.

Edit: as stated above, it is pretty hard to mess these things up just using a stable image. Are you sure about the download used.

1 Like

The device wiki page doesn't say anything about automatic TFTP recovery. If the router is running as a TFTP server, it may not output any packets or respond to anything (even pings) except for a TFTP PUT. It may be worth trying that though. Otherwise you're going to need to use serial.

1 Like

Just to be totally clear here is how to do the switch partitions.

  1. Start With router in power off state (either turn it off or assuming it's already off)
  2. Turn router on, wait 3 seconds, turn off
  3. Turn router on, wait 3 seconds, turn off
  4. Turn router on, wait 3 seconds, turn off
  5. Turn router on, wait for it to boot, attempt to connect

please be absolutely sure you tried this exact process before moving forward. If that process does work, and you boot into the linksys firmware, you can flash a stable current openwrt factory image from the linksys firmware page, and then it will reboot to the newly written openwrt image, problem solved.

If that doesn't work, you'll likely want to get a serial connection and come back with info on what the serial port says.

2 Likes

Side note for posterity: it is possible it was running attitude adjustment. The first third party firmware available for the wrt1900ac was “McWRT” which was AA based. This was before full Openwrt support was available and was based on the GPL code if I recall.

1 Like

wasn't aware of the little tidbit, wonder if that image messed with the mtd layout, possibly leading to the apparent grief being experienced.

Now that you mention it, I think it was McWrt. I flashed that once after a failed flash of an even older version of McWrt years ago (2014-15?), and maybe that's why I can't switch to the secondary firmware because I was already on it. I've forgotten all about that.

The web interface still said OpenWrt, so I just assumed an upgrade would do not knowing about the differences.

Wireshark gave me some output but nothing related to TFTP as far as I know.


I've bought a cp2102 serial converter and will let you know how that goes once I get it up and running correctly.

Ok, solved it.
For those who come across the same problem:

After reflashing both images manually with a serial connection (cp2102 serial converter) I was able to put the default stock firmware back on. From there I downloaded the OpenWrt factory image and flashed that through the stock web interface. (cannot verify checksums on stock web interface, so I used a website)

Works perfectly except for a small bug (18.06.2). I couldn't change the IP of the LAN interface without using SSH and edit the network file manually. It kept changing this setting back to default since there was no connectivity to the web interface anymore on either IP addresses.

But other than that, it works fine now and seems to be stable.

Thanks for all the replies and trying to help out, much appreciated!

3 Likes

If you use LuCI to change the LAN IP and don't do anything on your PC, in about a minute a box with three choices including a red "Apply Unchecked" button should pop up. Click the Apply Unchecked button then change your PC to the new IP.

2 Likes