[Solved] Wifi Lost internet after update

Currently using KONG 22 r19882-3564c22e46. After updating the firmware as it was on pretty old build the WiFi stopped providing internet. I still have internet on the LAN and everything else seems to work but the WiFi. It was working fine before the update.

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'soc/1b500000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option channel '11'
        option hwmode '11g'
        option path 'soc/1b700000.pci/pci0001:00/0001:00:00.0/0001:01:00.0'
        option htmode 'HT20'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio1'
        option mode 'ap'
        option ssid '********'
        option encryption 'psk2'
        option key '********'
        option network 'lan'

config wifi-iface 'wifinet1'
        option device 'radio0'
        option mode 'ap'
        option ssid '********'
        option encryption 'psk2'
        option key '********'
        option network 'lan'

That is the current config file. Any help is welcome.

You've only given one of the config files... we need to see, at the minimum, the /etc/config/network file as well.

A few other notes:

  • depending on the version you were using and what you upgraded to, the settings may be incompatible. In some cases it might be minor and easy to fix. In others it may really require the you do not try to keep your settings.
  • Also, since you are using a non-standard version (relative to the 'official' OpenWrt), you may need to ask for support on the KONG support threads.... we'll see if we can help you here first, but if we can't, your options are to either install a standard release version or to ask KONG for help.

My apologies. Here is the network config as well

config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix '**********::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '10.1.10.1'
        option device 'br-lan'
        list dns '1.1.1.1'
        list dns '8.8.8.8'

config interface 'wan'
        option proto 'dhcp'
        option device 'eth0.2'
        option type 'bridge'

config interface 'wan6'
        option proto 'dhcpv6'
        option device 'eth0.2'
        option type 'bridge'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '1 2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '5 0t'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.1'

The option type 'bridge' entries here may be responsible for the problem. Delete those lines, then restart the router and see if that fixes the issue.

Deleted the option type and restarted. No change in behavior.

To confirm: your wired LAN has normal internet connectivity, but wifi devices do not?

Do the wifi devices have a valid DHCP lease (take a look at one that is not working and check the IP address, subnet, gateway/router, and DNS -- report those here).

Yes my pc is on LAN and has a connection to the internet. It is just WiFi. My phone is reporting a ip address dns and gateway and the router is reporting that same under the dhcp lease. As far as i can tell it should be working.

Ip: 10.1.10.166
Gateway: 10.1.10.1
DNS: 10.1.10.1
Mask: 255.255.255.0

Yeah, I'm not seeing anything else immediately obvious.

Can the phone ping the router or any other devices on the local network?

Yes i was able to ping the router and i was able to ping my phone from my pc. I can even access my media server from my phone just no internet.

try pinging 8.8.8.8 from the phone. Does that work?

Yes i can ping that. weird

that means the problem is DNS.

Is the OpenWrt router intended to be your DNS? Is dnsmasq running properly? Run a dns lookup from your phone and also from your computer (in both cases with the dns set to 10.1.10.1). What happens?

That was the issue. The DNS either got reset/didnt save. I have dns forwarded to 8.8.8.8 and it didnt look like it saved in the router. I have the dns manually set on my pc so that explains why my pc had internet and my phone did not. Thanks for the help!

you're welcome.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.