[Solved] Wifi as client; hardwire as master

I need to set up an access point so that the wifi connects to another wifi AP as client, and the hardwire ethernet port is a client of the network downstream.

I did this several times long ago, but now I am remote and I don’t have a linux laptop with me, so I only have access to the AP via the wifi. This makes testing iffy at best; every mistake means I reset and start over.

Does anyone have network, wifi, and dnsmasq config files for this sort of setup?

At the minimum, you'd have to specify the device you are targeting, since the network and wifi config files are very much tied to the hardware.... don't try to directly import anyone elses files because some things (like MAC addresses) will be different and could cause you problems.

This is the type of thing that is best done with physical access to the hardware...
Do you have someone local-to-the-router who can connect to the device and help you out? Ideally with the ability to connect via ethernet?

This is pretty fraught -- unless you have changed the defaults with your own custom image, a reset also means that wifi will be disabled and ethernet will be required.

I get all that…. I am on an extended trip and I intentionally travelled light - all I have is an iPad. Well it turns out where I am I have no cell coverage, and no wifi except a kind neighbor’s Starlink, and he comes in at 1 bar. So I’m trying to get a repeater set up going so I am not without any communication for 3 months.

I have physical access to the AP; I just don’t have any platform with an ethernt port except another AP……

Oh... I see.

In that case, I'd highly recommend that you get an ethernet adapter. If you have a USB-C iPad, you should be able to use a typical USB-C to Ethernet adapter. If it's lightning based, you'll need a Lighting to USB and then a USB to ethernet adapter.

If your device does have two radios, you can setup a management network and assign that to one of the radios and you should be good as long as you never use that radio for the uplink... but if you only have one radio, things become much harder with respect to guaranteeing that htings stay working..

That said, you should certainly install travelmate -- this is a package developed specifically for this type of scenario.

Yeah. Unfortunately the only AP I could find here is a ramips-mt76x8 - which has a very incomplete build in the repository. Argh. No travelmate, and no supporting packages available. I’ll wait a few days and see if they regenerate. Otherwise I’ll have to keep trying to roll my own.

What is the device? Pretty much anything supported by OpenWrt should have full repos.

ubus call system board

Netgear AC1200 R6120. Only very limited packages available. The hardware is ramips-mt76x8.

If there's anything you can do I'd really appreciate it.

Packages like travelmate should work on basically all targets since they don't really interact with hardware specific functions (travelmate works at a much higher level).

Can you provide this info:

and also, while we're at it:
cat /etc/openwrt_release

root@OpenWrt:~# ubus call system board
        "kernel": "5.10.161",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7628AN ver:1 eco:2",
        "model": "Netgear R6120",
        "board_name": "netgear,r6120",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "22.03.3",
                "revision": "r20028-43d71ad93e",
                "target": "ramips/mt76x8",
                "description": "OpenWrt 22.03.3 r20028-43d71ad93e"

root@OpenWrt:~# cat /etc/openwrt_release
DISTRIB_DESCRIPTION='OpenWrt 22.03.3 r20028-43d71ad93e'

What happens if you issue these commands:

opkg update
opkg list | grep travelmate 

Well i haven't been able to connect the AP to the internet. That's the crux of the matter.

well, that's quite different than this earlier statement...

Anyway, your device has two radios (2.4G and 5G), so you can safely keep one connected to the LAN network while the other is used as an uplink.

Yeah I've been trying to roll that on my own. Thanks for the link. I'll follow-up tomorrow.

I can connect to the starlink router but it appears to not issue IPV4 addresses. I'll keep at it.

In the meantime I've been trying to download individual packages to my ipad and upload them via Luci.

If that's the case, try creating wwan6 with proto dhcpv6 client and associate that with the wan firewall zone.

Awesome, thanks. I've been out of the loop for a few years and I'm super rusty. I'll try thst tomorrow.

YAY! Got it working, got travelmate installed. At least now I don’t feel like my communication with the world is a tin can and a string.


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.