[Solved] vLANs not working on AP setup (Belkin RT3200) - no vLAN traffic on LAN1 interface in Wireshark







Followed this video guide to set this up. Not getting ANY vLAN tagged traffic on LAN1 (monitoring using wireshark).

Any help appreciated.

Hi @kevpatts

looking at screenshots are not so pleasant task

please SSH to your device and

cat /etc/config/network
cat /etc/config/wireless

and paste output here in preformated text "<" & "/>"

1 Like
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
	option device 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fdab:34ad:f708::/48'

config device
	option name 'br-lan'
	option type 'bridge'
	option ipv6 '0'
	list ports 'lan1'
	list ports 'lan2'
	list ports 'lan3'
	list ports 'lan4'

config interface 'lan'
	option device 'br-lan'
	option proto 'static'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'
	option ip6assign '60'

config interface 'wan'
	option device 'wan'
	option proto 'dhcp'

config device
	option type 'bridge'
	option name 'VLANS'
	option ipv6 '0'
	list ports 'lan1'
	list ports 'VLANS.5'

config bridge-vlan
	option device 'VLANS'
	option vlan '5'
	list ports 'VLANS.5:t'
	list ports 'lan1:t'

config device
	option name 'VLANS.5'
	option type '8021q'
	option ifname 'VLANS'
	option vid '5'
	option ipv6 '0'

config interface 'Personal'
	option device 'VLANS.5'
	option proto 'static'
	option ipaddr '10.0.5.4'
	option netmask '255.255.255.0'
	option gateway '10.0.5.1'

config device
	option name 'lan1'
	option ipv6 '0'
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/18000000.wmac'
	option channel '1'
	option band '2g'
	option htmode 'HT20'
	option disabled '1'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option network 'lan'
	option mode 'ap'
	option ssid 'OpenWrt'
	option encryption 'none'

config wifi-device 'radio1'
	option type 'mac80211'
	option path '1a143000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
	option channel '36'
	option band '5g'
	option htmode 'HE80'
	option cell_density '0'

config wifi-iface 'default_radio1'
	option device 'radio1'
	option mode 'ap'
	option ssid 'KevsPersonal'
	option encryption 'psk2'
	option key 'yyyyyyyyyyyyyyyyyyyyyyyy'
	option network 'Personal'

ok

it is a mess :slight_smile:
i suppose you want
untagged (access, native) vlan1 on LAN1-4 port
and tagged vlan5 on LAN1 port
let's start

edit

edit

add this block

config bridge-vlan
        option device 'br-lan'
        option vlan '1'
        list ports 'lan1:u*'
        list ports 'lan2:u*'
        list ports 'lan3:u*'
        list ports 'lan4:u*'

remove whole block

then edit

also edit

remove whole block

Ok, 2,4 GHz is in default 'lan' network

Ok, 5Ghz is on Personal (vlan5) network

You're a legend! Thanks so much. Working fine now.

Much appreciated.

1 Like

hi @kevpatts

glad you did it

if your problem is solved, please rename topic as [Solved] and mark answer as solution