[Solved] Using a network scanner from several zones / subnets


Some weeks ago I configured my home network and installed Openwrt on a router and several managed switches.

I was ready to install the devices but I realized there's a problem with my network multifunction printer.

It's an HP Laserjet M425dn, which can print and scan and is connected to my network using an ethernet cable.

The computers, located in their own zones / subnets, can print. I opened the ports to the printer on the Openwrt router and in Windows I defined the printer by entering its IP address.

However, I do have a problem for scanning from that device. To scan I have two possibilities :

  • scanning with the HP Smart application,
  • my prefered solution : scanning with the naps2 open-source application which is compatible with both WIA and TWAIN.

Both HP Smart and Naps2 don't "see" my printer/scanner. That's probably due to the fact there're located in different subnets.

I tried Avahi and mDNS without any success. With Avahi the HTTP printer interface was accessible using an address like m425dn.local. but HP Smart and Naps2 still didn't see the scanner.

In the firewall, I even allowed both zones to fully communicate in both direction. I allowed the router to listen to its interfaces on UDP port 5353. I allowed the router to send UDP packets to / port 5353.

Is there a way to use my scanner from computers located in different zones / subnets ?

Thanks for your help.

I installed Avahi on the router, and the printer/scanner is detected on the Windows computer :

dns-sd -B _scanner._tcp
Browsing for _scanner._tcp
Timestamp     A/R Flags if Domain                    Service Type              Instance Name
11:57:48.409  Add     2  9 local.                    _scanner._tcp.            M425DN

It's detected when adding a printer (I don't have to enter its IP anymore), and an HP program called "HP Print and Scan Doctor 5.0.15" sees it :

So, it's discovered from zone A while it's on zone B. I can print from zone A. But I can't scan from zone A.

I got it working. The issue wasn't related to the discovery service. I solved my problem by :

  • deinstalling the "not so smart" HP Smart software
  • downloading HP Easy Start and specifying there my printer/scanner IP address (on another subnet)
  • HP Easy Start offered me to install 2 softwares. HP Smart or the "HP LaserJet Pro 400 MFP M425 Printer Series Full Software Solution". I installed the full software solution.
    I was then able to scan from NAPS2 (and print as usual) on my computer, which is on another network than my printer/scanner.

Glad you solved the problem.

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.