[SOLVED] Unable to install ip-full/ip-tiny

I'd like to add a static arp entry and wanted to install ip-full to do this so I could use ip neigh but neither ip-full or ip-tiny now appear in the package lists.

Is there another way to do this now ?

building error.

The iproute2 regression might be caused by this commit merged by you:
"elfutils: install library files for pkg-config"


Package ip-tiny is missing dependencies for the following libraries:
Makefile:187: recipe for target '/var/lib/buildbot/slaves/slave-lede-builds4/mips_24kc/build/sdk/bin/packages/mips_24kc/base/ip-tiny_4.19.0-6_mips_24kc.ipk' failed

Possibly now the iproute2 compilation find elfutils and tries to link it in, causing the dependency error.

The only other reasonably possible change was by @dedeckeh for iproute2, but that seems more farfetched as it only touched tc
"iproute2: backport patch fixing incorrect usage of LDFLAGS"

Thanks for the speedy responses. At least I know it’s not me doing something wrong, will keep an eye on the snapshots for this to be fixed

I reverted the elfutils change in master. I don't understand how I didn't fall over this issue myself as I was certainly able to replicate!

1 Like

Has your problem been solved by recent snapshots?
If so, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

Yes thanks - different problem now with 5Ghz wifi drivers (see separate thread)

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.