[solved] TPLink Omada Clients no available

And you get full speeds from previous router? Are you using pi4 with a USB ethernet?

yes and yes. UE300

Is there a switch involved? Can you provide the network topology in general?

Laptop => RJ45 => Switch Zyxcel GS1900-24 => OpenWRT Router => ISP Modem

As i said if i replace the Raspberry pi with my asus , i have full speed. same cables , same setup not even a restart required. i tried it several times now.

You are not running a stock OpenWrt right? Which build are you running?

OpenWrt SNAPSHOT r15323-7ba2f5c96f / LuCI Master git-20.339.75073-e54708a

So it's @wulfy23 build. Maybe he has some suggestions as to what would cause speed loss.

1 Like

can i remove these ? and how? maybe it will be used ?

ok i made a speedtest on my wrt

looks perfect. i dont know whats wrong now. maybe the lan interface ? i guess this speed test use the wan interface direct.

please disable sqm and test over wired ( from a client )...

you can ignore the unused network interfaces / modules... ( dummy teql ) or uninstall the related kmods...

Hi wulfy23 thanks for your response.

i rebooted and removed the QSM

speedtest on my laptop only :

it looks like something block at 100mbit...

1 Like

yes... looks like the zyxel switch... does it have a webui so you can check the link ( or link speed leds? )? you can also try plugging your pc directly into the LAN port of the PI and testing directly from there...

But why does it work if i replace openwrt router with my old one ?

1 Like

excellent question... faster to test with the laptop direct than answer that tho'

the only thing that seems plausible is something related to the fast switching of network topology ( layer1/2 learning and auto link detection / mcast auto whatever / stp et. al. )...

there is nothing within the build that explains this phenomenon...

ok i will try a restart from all devices , one by one. lets see what happen

Log into the switch and plug the RPI in and see if it's negotiating a 100Mbps ethernet instead of gigabit!

1 Like

yep i thought the same. made this already. its 1GBIT

1 Like

how about the port your laptop is connected to ? :slight_smile:

also do you have any bandwidth limitations in the switch? it has a bandwidth limiter for various ports, and I found it wasn't capable of really operating at full gigabit, if I tried to set it to say 700Mbps it would limit at 200Mbps because it would run out of CPU capacity.

1 Like
ethtool eth1 | grep Speed
ethtool eth0 | grep Speed

root@rpi-dca6326af5 /47# ethtool eth1 | grep Speed
Speed: 1000Mb/s
root@rpi-dca6326af5 /44# ethtool eth0 | grep Speed
Speed: 1000Mb/s

rebooted , still same
image