[SOLVED] TP-LINK MR3020 renumber LAN and reseting

Hi all! I have a problem with TP-LINK mr3020 rev 1.9 portable router and its default gateway. I was configured it with static default gateway but I didnt wait till the end of saving that configuration and plug the power off. I have used it before for picking internet connection from my mobile phone hotspot and that works like before but I cannot access to router settings over default gateway or If I connect it with ethernet to my pc and type ipconfig I get the screen where it says it dont read default gateway IP adress. There is ipv4 adress which isnt accessible through internet browser, subnet mask is I dont know what to do now?


netsh interface ipv6 show neighbors


The 169.254 address occurs when Windows doesn't get a response from a DHCP server.

If DHCP works from wireless but not wired you probably don't have the Ethernet port in the LAN.

1 Like

What do you mean I dont have ethernet port in the LAN? The router is connected to PC over ethernet cable and I cannot enter in its settings. None of default gateway IP adresses are working. Im looking for a way to reset it. IPconfig in CMD isnt reading the default gateway IP.

It says Unreachable on the right side under Type

It means we need to know your configurations and assignment of Ethernet ports.

Obviously you can't have a default gateway on a computer until you've setup the router and connected it to WAN. And as I noted in a thread you hijacked, you have to fix the problem you caused:

  • What other setting changes did you make?
  • Did you get any other errors?
  • Please explain what you mean, how did you perform it, and why did you remove the power while making a settings change?
  • Have you tried statically assigning an IP in the 192.168.0.xxx or 192.168.1.xxx ranges on the Windows machine - to see if you can access the router?
1 Like

I will give you info you want to know just tell me which info exactly do you need?

How to setup the router when it is impossible (for me) to enter in router settings? I can enter to failsafe mode with pressing router wps/reset key but cannot get in. I tried to get in by Putty telnet and SSH but I cant. If I put the IP adress in web browser there is LuCI - Lua Configuration Interface showing for a second and dissapears ant I get message that it is unreachable or cant open.

First I changed accidently the settings to DHCP client mode and after that I couldnt get into router untill I connected it to home router ethernet port which assigned him IP adress which I used to enter settings. After that I changed back from dhcp client mode to static ipv4 and put default gateway to and now router is hanging obviously not letting me in.

No I did not

I performed it exactly as I said before and I removed power because router was saving new settings for a long time 2-3 minutes which wasnt the case before so I thought that new settings are applied and I dont have to wait anymore.

No, I dont know how to do that?

OK, you've offered some helpful information. Do you mean you changed LAN from Static Addressed to DHCP Client, or that you turned DHCP server off on LAN?

If you did the former, this gets more difficult; and you'll need a second router with DHCP turned on, for easy fixing.

@vgaetera asked you to run that IPv6 command to see if we could access things that way. So I'm now suggesting using IPv4.

OK this is how you assign a static IP:


You only need to temporally assign an IP and Subnet Mask in order to attempt access:

  • for ease, use and
  • your subnet mask is
  • after you've tried, don't forget to change the setting back to automatic

This is likely just your browser's cache. Yes, try PuTTY during failsafe attempts on versions 15+.



I did that before but no succes maybe I did something wrong. Which IP adress to enter in IP adress and which in Default gateway?

My openwrt version is 15.05.1. I tried to connect over Putty both telnet and ssh, tried various IP adresses and ports but cannot connect

Then, you'll need to borrow a router and plug a OpenWrt LAN port to it, use another LAN port on the Windows PC to access it at the IP assigned by the borrowed router. Then change LAN back to Statically Addressed.

You don't need a default gateway for the experiment. I clearly noted:

I'm not sure why you're fixated on the concept a "default gateway IP" before you even setup your router - you can't go to a WAN until you can reach LAN.

1 Like

Can I use my home router for that? I have some SpeedPort router. In fact I have do that at first, my home router assigned IP to TP-link and I accessed it through that IP adress and set back to static and the rest you know what happened.

You can use any router (with DHCP enabled) with at least 2 LAN ports:

  • to plug OpenWrt LAN to borrowerd router LAN
  • to plug Windows computer to LAN
  • Both should get an IP and then you can access it
  • Immediately change protocol back to static and assign an IP
  • Do not assign gateway or DNS servers on LAN - unless you intend to use this device as an Access Point

EDIT: you can also do a reset to defaults!

Ok, one more thing about ethernet settings, I've connected TP-LINK with ethernet on PC and changed IP to those two IP adresses you suggested and I could not access to TP-LINK via internet browser. Now I will try to connect my notebook and TP-link to home router and see if it is getting IP adress,

Understood. Given you changed LAN from Static to DHCP, it wouldn't work.


  • Be sure to connect to LAN ports!
  • I edited above, you can also reset the OpenWrt to default once getting access - this may be easier for your to start from the beginning

Do I have to connect my notebook to home router over ethernet or I can keep it connected over WLAN? Thats how I gain access at first, TP-link was connected to LAN port in home router by wire and notebook was connected by wifi, I went to home network connected device list found the TP-link and used its IP adress to access it.

Not sure about your question. This seems like a wireless configuration inquiry. If so, make another (properly titled) post. If you reset the OpenWrt to defaults, you will have to reconfigure your WiFi.

If your problem is solved, feel free to mark the relevant post as the solution; and edit the title to add "[SOLVED]" to the beginning (click the pencil behind the topic).


you missunderstood me I didnt solved the problem yet. I plugged TP-link to LAN 1 port, and my notebook to LAN 2 port. TP-link is shown on device list connected with network cable with assigned IP (I confirmed that by clicking on that device and see its MAC adress) but it is not accessible. If I try to access it with that IP ower internet browser it says that IP isnt reachable. What to do now?

  • Can you ping it?
  • Can you SSH to it?
1 Like

Plug your laptop LAN port into TP-link LAN port.

No, I cant SSH to it (tried with putty) neither can ping it. The router isnt showed on the list when I connect it with cable he appears when I plug it off and on and after 2 seconds his IP adress is grayed out and I cant access it by any way.