[SOLVED] SSH into router using password rejected

I need to SSH into my EA4500 but am failing for what are probably stupid user error reasons, getting "Unable to negotiate with UNKNOWN port -1: no matching host key type found. Their offer: ssh-rsa". I don't even know what this error is telling me; is it about a port error, about wanting a key rather than a password, about unexpected cipher???

Router is on 19.07, all settings cleared, dropbear enabled with password authentication and password for root enabled, port 22 selected. Chromebook connected directly to router via ethernet. Attempting to SSH using Secure Shell to root@ gives above error. There are no keys on either device. What am I doing wrong?

The client and server must agree on encryption parameters. You need to set the client on the Chromebook to accept ssh-rsa.

1 Like

Thanks @mk24 and @frollic, that did it. I had actually tried that solution but did it wrong (Secure Shell on Chromebook is a form with fields, rather than a command line).

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.