[Solved] Ssh connection refused right after installing OpenWrt

Hi i just installed openwrt on my Xiaomi 4A router R4AC, and after reboot i cant do nothing.

I see OpenWrt.mshome.net in my network under adress i can ping it, but i cant ssh or telnet.

ssh: connect to host port 22: Connection refused

The default address of OpenWrt is It sounds like you're trying to connect from an upstream LAN (i.e. internet > main router > wan port of Xiaomi 4A R4C w/ OpenWrt; your computer connected to the main router with an address on the network).

All unsolicited incoming connections from the WAN are blocked by the firewall by default. Therefore, you need to connect to one of your R4AC's lan ports, then try to connect via ssh:

ssh root@

Try that and report back.

1 Like

My computer is connected to a Wifi network, and I am sharing this connection to the ethernet socket that is connected with a cable to the WAN port in Openwrt

Yes, this makes sense. You will not be able to connect to OpenWrt from the WAN side by default, since the firewall blocks incomming connections.

You must connect by an ethernet cable from your computer to the OpenWrt lan port.

1 Like

Yes, I went down to the main router with the laptop, connected the Xiaomi to the router and everything started working


If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.