[SOLVED] Sophos AP 55 problems

I just got my hands on a Sophos AP 55 access point. Read through the instructions in git-commit and did the following:

  • Set up a TFTP server at and connected the AP to it
  • Downloaded the latest sophos_ap55-initramfs-kernel.bin, made it available via TFTP, and renamed it uImage_AP55
  • Connected to the AP via console, restarted the AP, stopped the boot, and got the bootloader command prompt

Here's what happened at the bootloader prompt next:

ath> tftpboot
Speed is 1000T
dup 1 speed 1000
Using eth0 device
TFTP from server; our IP address is
Filename 'uImage_AP55'.
Load address: 0x81000000
         ### Hash marks indicating progress ###
Bytes transferred = 6422825 (620129 hex)

ath> cp.b $fileaddr 0x9f070000 $filesize
Copy to Flash...
 Copy 6422825 [0x620129] byte to Flash... write addr: 9f070000

ath> boot
## Booting image at 9f070000 ...
Bad Header Checksum
Speed is 1000T

After that, the Speed is 1000T line repeats ad infinitum.

Tried loading older (22.03.0) initramfs-kernel.bin, same result. Out of desperation, tried loading the latest squashfs-sysupgrade.bin, got a Bad Magic Number instead of Bad Header Checksum. So... where to from here? Inquiring minds want to know... :smile:

Hi, i found this Thread while i wanted to flash an AP55.
Following the information from the mentioned git-commit, the device acted exactly as nc1 wrote.
The solution is (found it here:Sophos AP55 support):

ath> setenv fwaddr 0x9f070000
ath> echo $fwaddr
ath> erase $fwaddr +$filesize
Erasing flash...
First 0x7 last 0x59 sector size 0x10000
Erased 83 sectors
ath> cp.b $fileaddr $fwaddr $filesize
Copy to Flash...
 Copy 5391042 [0x5242c2] byte to Flash... write addr: 9f070000
ath> iminfo $fwaddr
ath> boot

Then you can edit /etc/config/network from "static" to "dhcp" in order to get an IP Address via dhcp.
"service network restart" and looking for the ip address via "ip a"
The image allready contains Luci, so you can use your browser from now on. In the webinterface upgrade the firmware with the openwrt-22.03.4-ath79-generic-sophos_ap55-squashfs-sysupgrade.bin file.

1 Like

This sounds promising... Will try it out and report back.

Well, it worked. :smile: A big thank-you to @sophosap for pointing me in the right direction and to the posters in the original thread for suggesting a solution.

Now I owe the community a debt of gratitude and another HOWTO... Will post it in a new thread as soon as I write it up...

...and done! The new HOWTO can be found here:

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.