[Solved] Rp-pppoe-server not found even after a package list update

I am running OpenWrt Chaos Calmer 15.05.1 on my TP-Link TL-WR841N (ver 8.3). I wanted to make a PPPoE server to secure my Cat 6 running through a hostile alien environment (anyone practically has an option to cut the cable, insert a switch and piggyback on my LAN). After making up my mind to encrypt the cable using PPPoE, I went ahead to install rp-pppoe-server. But to my surprise opkg wasn't able to install it even after an update. Here's what I did:

root@OpenWrt:~# opkg update
Downloading 
.
Updated list of available packages in /var/opkg-lists/chaos_calmer_base.
Downloading 
.
Signature check passed.
Downloading 
Updated list of available packages in /var/opkg-lists/chaos_calmer_luci.
Downloading 
Signature check passed.
Downloading 
Updated list of available packages in /var/opkg-lists/chaos_calmer_packages.
Downloading 
Signature check passed.
Downloading 
Updated list of available packages in /var/opkg-lists/chaos_calmer_routing.
Downloading 
Signature check passed.
Downloading 
Updated list of available packages in /var/opkg-lists/chaos_calmer_telephony.
Downloading 
Signature check passed.
Downloading 
Updated list of available packages in /var/opkg-lists/chaos_calmer_management.
Downloading 
Signature check passed.

root@OpenWrt:~# opkg install rp-pppoe-server
Unknown package 'rp-pppoe-server'.
Collected errors:
 * opkg_install_cmd: Cannot install package rp-pppoe-server.

What am I doing wrong?

I think it doesn't exist, at least I could not find it.
http://archive.openwrt.org/chaos_calmer/15.05.1/ar71xx/generic/packages/
Can't you upgrade to a newer version of Openwrt?

Thanks! I upgraded to 18.06.1. But now the only problem I face is that I can't seem to get it working due to lack of proper documentation of rp-pppoe-server for openwrt.

Have you tried to configure it via luci? There is luci-app-pppoe-server which might make things easier.

Yep. Interestingly, I cannot manipulate any settings through it :frowning:

15%20PM

You are right, edit in console the /etc/config/pppoe and remove the first hash character from all lines. Then save and open again the page. That will give you the options to work on.

Yes it works! But even now it's messy to setup since there is no option to add users for PPPoE :frowning:

@heychirag If your problem is solved, please consider marking this topic as [Solved]. (Click the pencil behind the topic...)

You need to edit the file:
/etc/ppp/chap-secrets

#USERNAME  PROVIDER  PASSWORD  IPADDRESS
username * password *

thanks a lot @trendy

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.